wpa_supplicant crashed with SIGSEGV in get_iface_by_dbus_path()

Bug #1482439 reported by Anders Kaseorg on 2015-08-07
182
This bug affects 56 people
Affects Status Importance Assigned to Milestone
wpa (Fedora)
Fix Released
Undecided
wpa (Ubuntu)
Medium
Unassigned

Bug Description

wpa_supplicant crashed with SIGSEGV in dbus_connection_dispatch()

ProblemType: Crash
DistroRelease: Ubuntu 15.10
Package: wpasupplicant 2.4-0ubuntu1
ProcVersionSignature: Ubuntu 4.1.0-3.3-generic 4.1.3
Uname: Linux 4.1.0-3-generic x86_64
NonfreeKernelModules: openafs
ApportVersion: 2.18-0ubuntu5
Architecture: amd64
Date: Wed Aug 5 00:08:21 2015
ExecutablePath: /sbin/wpa_supplicant
InstallationDate: Installed on 2015-06-02 (65 days ago)
InstallationMedia: Ubuntu-GNOME 15.04 "Vivid Vervet" - Release amd64 (20150422)
ProcCmdline: /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant
ProcEnviron:
 LANG=en_US.UTF-8
 PATH=(custom, no user)
SegvAnalysis:
 Segfault happened at: 0x7f8880818cba <__strcmp_sse2_unaligned+26>: movdqu (%rdi),%xmm1
 PC (0x7f8880818cba) ok
 source "(%rdi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%xmm1" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: wpa
StacktraceTop:
 ?? ()
 ?? ()
 ?? () from /lib/x86_64-linux-gnu/libdbus-1.so.3
 dbus_connection_dispatch () from /lib/x86_64-linux-gnu/libdbus-1.so.3
 ?? ()
Title: wpa_supplicant crashed with SIGSEGV in dbus_connection_dispatch()
UpgradeStatus: Upgraded to wily on 2015-06-17 (50 days ago)
UserGroups:

Related branches

Version-Release number of selected component:
wpa_supplicant-2.4-2.fc22

Additional info:
reporter: libreport-2.6.0
backtrace_rating: 4
cmdline: /usr/sbin/wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -u -f /var/log/wpa_supplicant.log -P /var/run/wpa_supplicant.pid
crash_function: __strcmp_sse2_unaligned
executable: /usr/sbin/wpa_supplicant
global_pid: 27905
kernel: 4.0.5-300.fc22.x86_64
runlevel: N 5
type: CCpp
uid: 0

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 __strcmp_sse2_unaligned at ../sysdeps/x86_64/multiarch/strcmp-sse2-unaligned.S:29
 #1 get_iface_by_dbus_path at dbus/dbus_new_handlers.c:160
 #2 wpas_dbus_handler_remove_interface at dbus/dbus_new_handlers.c:653
 #3 msg_method_handler at dbus/dbus_new_helpers.c:349
 #4 message_handler at dbus/dbus_new_helpers.c:405
 #5 _dbus_object_tree_dispatch_and_unlock at dbus-object-tree.c:1018
 #7 dispatch_data at dbus/dbus_common.c:38
 #8 process_watch at dbus/dbus_common.c:74
 #9 process_watch_read at dbus/dbus_common.c:90
 #10 eloop_sock_table_dispatch at ../src/utils/eloop.c:502

Created attachment 1039179
File: backtrace

Created attachment 1039180
File: cgroup

Created attachment 1039181
File: core_backtrace

Created attachment 1039182
File: dso_list

Created attachment 1039183
File: environ

Created attachment 1039184
File: limits

Created attachment 1039185
File: maps

Created attachment 1039186
File: mountinfo

Created attachment 1039187
File: namespaces

Created attachment 1039188
File: open_fds

Created attachment 1039189
File: proc_pid_status

Created attachment 1039190
File: var_log_messages

wpa_supplicant-2.4-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/wpa_supplicant-2.4-3.fc22

Package wpa_supplicant-2.4-3.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wpa_supplicant-2.4-3.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10215/wpa_supplicant-2.4-3.fc22
then log in and leave karma (feedback).

wpa_supplicant-2.4-3.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Anders Kaseorg (andersk) wrote :

StacktraceTop:
 get_iface_by_dbus_path (global=0x55ec8dd3cd50, path=0x55ec8dd6b5a4 "/fi/w1/wpa_supplicant1/Interfaces/1") at dbus/dbus_new_handlers.c:168
 wpas_dbus_handler_remove_interface (message=0x55ec8dd405f0, global=0x55ec8dd3cd50) at dbus/dbus_new_handlers.c:749
 msg_method_handler (obj_dsc=0x55ec8dd3d540, obj_dsc=0x55ec8dd3d540, message=0x55ec8dd405f0) at dbus/dbus_new_helpers.c:349
 message_handler (connection=0x55ec8dd3ddd0, message=message@entry=0x55ec8dd405f0, user_data=user_data@entry=0x55ec8dd3d540) at dbus/dbus_new_helpers.c:405
 _dbus_object_tree_dispatch_and_unlock (tree=0x55ec8dd3da70, message=message@entry=0x55ec8dd405f0, found_object=found_object@entry=0x7ffc19020b44) at ../../dbus/dbus-object-tree.c:1018

Changed in wpa (Ubuntu):
importance: Undecided → Medium
summary: - wpa_supplicant crashed with SIGSEGV in dbus_connection_dispatch()
+ wpa_supplicant crashed with SIGSEGV in get_iface_by_dbus_path()
tags: removed: need-amd64-retrace
Anders Kaseorg (andersk) on 2015-08-15
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wpa (Ubuntu):
status: New → Confirmed

The linked Fedora bug is closed with a note that wpa_supplicant-2.4.3 should fix this issue.

tags: added: bugpattern-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wpa - 2.4-0ubuntu3

---------------
wpa (2.4-0ubuntu3) wily; urgency=medium

  * debian/patches/dbus-fix-operations-for-p2p-mgmt.patch: fix operations
    when P2P management interface is used (LP: #1482439)

 -- Ricardo Salveti de Araujo <email address hidden> Wed, 07 Oct 2015 10:21:39 -0300

Changed in wpa (Ubuntu):
status: Confirmed → Fix Released

wpa_supplicant-2.4-8.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-68136b911f

wpa_supplicant-2.4-8.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-68136b911f

wpa_supplicant-2.4-8.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Changed in wpa (Fedora):
importance: Unknown → Undecided
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.