wpa_supplicant high cpu load after going to Promiscuous Mode

Bug #1450393 reported by Jim Beam on 2015-04-30
This bug affects 2 people
Affects Status Importance Assigned to Milestone
wpa (Ubuntu)

Bug Description

i ran kismet and it wont see any networks, but wpa_supplicant will go into rage mode and consume much cpu time.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: wpasupplicant 2.1-0ubuntu7.1
ProcVersionSignature: Ubuntu 3.19.0-15.15-generic 3.19.3
Uname: Linux 3.19.0-15-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
Date: Thu Apr 30 11:37:22 2015
EcryptfsInUse: Yes
ExecutablePath: /sbin/wpa_supplicant
InstallationDate: Installed on 2011-10-13 (1294 days ago)
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
 PATH=(custom, no user)
SourcePackage: wpa
UpgradeStatus: Upgraded to vivid on 2015-04-23 (6 days ago)

Jim Beam (crosbow) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wpa (Ubuntu):
status: New → Confirmed
BCW142 (bcw142) wrote :

I ran in to this with Ubuntu 20.04.1 LTS when using wired connection. I turned off Wi-Fi now so I hope that fixes it (as I use wired on this system). It was taking 25% of CPU time as shown with htop. I shutdown the service (sudo service wpa_supplicant stop) and then disabled Wi-Fi.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers