Unclean termination on dbus-daemon shutdown

Bug #1124789 reported by Daniel Gnoutcheff on 2013-02-14
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
hostap
Fix Released
Medium
wpa (Ubuntu)
Medium
Unassigned

Bug Description

When wpa_supplicant is terminated normally (i.e. with SIGTERM or SIGINT or 'wpa_cli terminate'), it brings down any wireless interfaces it is managing. However, if wpa_supplicant is started by dbus activation and if the dbus messagebus is then shut down, it terminates abruptly and improperly without deconfiguring any network interfaces.

Note that wpa_supplicant has its PID file installed in /run/sendsigs.omit.d, so /etc/init.d/sendsigs makes no attempt to shut it down. Since wpa_supplicant is not supervised by upstart, it is typical for dbus-daemon to be shut down before wpa_supplicant is.

This has been reported upstream (along with steps to reproduce and a patch) at:
  http://w1.fi/bugz/show_bug.cgi?id=474

This bug, along with bug 1124803 (in network-manager), means that when I connect my laptop to a wifi network, no attempt is made to disconnect from that network when shutting the system down. This in turn triggers a bug in my BIOS which causes this system to hardlock in the middle of BIOS post when I reboot while still connected to a wifi network:
  http://thread.gmane.org/gmane.linux.kernel.wireless.general/102862

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: wpasupplicant 1.0-2ubuntu5
ProcVersionSignature: Ubuntu 3.5.0-24.37-generic 3.5.7.4
Uname: Linux 3.5.0-24-generic x86_64
ApportVersion: 2.6.1-0ubuntu10
Architecture: amd64
Date: Wed Feb 13 22:12:08 2013
MarkForUpload: True
SourcePackage: wpa
UpgradeStatus: Upgraded to quantal on 2012-10-20 (116 days ago)

Daniel Gnoutcheff (gnoutchd) wrote :
description: updated
Changed in hostap:
importance: Unknown → Medium
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wpa (Ubuntu):
status: New → Confirmed

Thanks!

The patch does make some sense to me; so I'd be in favor of including it once it got a review from upstream. In order to speed up this process, would you be up to sending the patch on the hostapd mailing list?

Changed in wpa (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → Medium
tags: added: patch

On 04/15/2013 11:45 AM, Mathieu Trudel-Lapierre wrote:
> The patch does make some sense to me; so I'd be in favor of including it
> once it got a review from upstream. In order to speed up this process,
> would you be up to sending the patch on the hostapd mailing list?

Sure, patch (lightly edited and) sent.
(Message-Id <email address hidden>)

Sorry about my super-slow response time. :)

Changed in hostap:
status: Confirmed → Fix Released
Changed in wpa (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.