Workrave Unity indicator does not work

Bug #1176620 reported by Gioele Barabucci on 2013-05-05
96
This bug affects 18 people
Affects Status Importance Assigned to Milestone
workrave (Ubuntu)
High
Unassigned

Bug Description

Workrave has introduced a Unity indicator (available in the package `workrave-unity` from [1]). However, it looks like the indicator is not working properly: no workrave indicator is shown, only the floating window.

This is not a duplicate of bug #796824, that bug lamented the lack of support for Unity indicators. Now that support has been introduced but it seems that it is faulty.

[1] ppa:rob-caelers/workrave

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in workrave (Ubuntu):
status: New → Confirmed
razor7 (ghiamar) wrote :

Hi, I have installed workrave 1.10-0ubuntu2 and the indicator appears!

See screenchots

razor7 (ghiamar) wrote :

Just in case, i've set interface config to:
General->Show systray icon: checked
Status window->SHow Status Window: Unchecked
Applet->Applet activated: unchecked

Gioele Barabucci (gioele) wrote :

@ghiamar,

did you install it from the PPA or from main repository? Which Ubuntu version are you using?

Mick (mickmize) wrote :

I installed thru the Terminal, with 'apt-get install workrave', and I get a big question mark on the launchbar. It looks like the attached picture.

This may be a different bug...

Matt Fischer (mfisch) wrote :

Mick, That's not an indicator, that's a launcher icon.This is fixed in Saucy. It is unlikely to be a backport

Matt Fischer (mfisch) wrote :

Confirmed that it is also not working for me. 1.10-0ubuntu2 should have fixed this. Oddly when I enable and disable it, I see some flickering in the systray area, but it never shows up.

Changed in workrave (Ubuntu):
importance: Undecided → High
Matt Fischer (mfisch) wrote :

update: Its working for me after a reboot. Anyone else?

Yes, I experienced the same: It fails immediately after installation, but after a reboot, the indicator shows up.

Marius B. Kotsbak (mariusko) wrote :

Poking around in the settings made the sheep appear as indicator.

Adam (papapa909090) wrote :

the same for me. After restart it works

Ubuntu 14.04, workrave 1.10.1 from software center

rubo77 (rubo77) wrote :

This is broken again in Trusty 14.04.

Workrave works fine in the defaault setting, but there is no way to enter the settings of workrave anymore this way

information type: Public → Public Security
information type: Public Security → Public
Teodor Milkov (tm-del) wrote :

No indicator with 1.10.6.0-ppa3~utopic1 :-(

Jeff Adamson (jwadamson) wrote :

FYI a reboot seems to have worked for now.

Jeff Adamson (jwadamson) wrote :

p.s. in Trusty 14.04

FlyingMG (flyingmg) wrote :

Just installed workrave on 16.04 and get an empty indicator where I would expect something similar to the cup of coffee and a timer like in 14.04.
Any workaround?

Ivan Garavito (ivangaravito) wrote :

It seems a problem with version 1.10.10-1 at 16.04, I get an empty indicator too.

Igor Plyatov (plyatov) wrote :

Bug remains in Ubuntu 16.10.

Workrave-1.10.10.0 works, but applet is invisible on the panel.

Installed by "sudo apt install workrave" (No PPA used).

tjiagoM (tjiagom) wrote :

I've just installed workrave in Ubuntu 16.04 and unity panel doesn't show as well. I installed via software center and the version I have is 1.10.10-1. So, workrave is working, just the panel is not showing.

In a previous laptop with Ubuntu 14.04 it was showing...

tjiagoM (tjiagom) wrote :

AS the image shows, a big empty space is in the place where the system tray should be

james (mrquintopolous) wrote :

Reboot does not help for me in either 16.04 or 16.10. Anyone have any thoughts on what the underlying cause could be?

tjiagoM (tjiagom) wrote :

I've noticed that it is working for me now, maybe it was the headers which got updated?
My kernel now is 4.4.0-66-generic

tjiagoM (tjiagom) wrote :

I'm sorry for the last message, but it seems that actually the indicator appears "randomly" just sometimes.

Josh (graymouser) wrote :

I just started getting this bug in Ubuntu 16.04
After installing WordRave the indicator worked fine for a few days but now appears as just a long blank space

Linux josh-XPS-13-9350 4.4.0-116-generic #140-Ubuntu SMP Mon Feb 12 21:23:04 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers