Ubuntu

wmctrl:Setting virtual workspace/desktop/viewport.

Reported by moma on 2010-03-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
wmctrl (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: wmctrl

Hello,
I run Compiz desktop with several virtual viewports/workspaces/desktops.

The total size of display is 1680x1050, and wmctrl -d reports:
$ wmctrl -d
0 * DG: 10080x2100 VP: 0,0 WA: 0,25 1680x1000 Compiz desktop 1

The viewport layout has 6 columns and 2 rows. The co-ordinates should be like this
(0, 0), (1680, 0), (3360, 0), (5040, 0), (6720, 0), (8400, 0)
(0, 1050), (1680, 1050), (3360, 1050), (5040, 1050), (6720, 1050), (8400, 1050)

This works right.
$ wmctrl -o 5040,0

These fails. The Y co-ordinate has no effect.
$ wmctrl -o 5040,1050
$ wmctrl -o 5040,2100

Note. With Metacity Window Manager, you have to type
$ wmctrl -s desktopnumber
While Compiz operates with viewport widths and heights, therefore wmctrl -o X,Y.

For more info.
$ wmctrl --help

Please enlighten me.

ProblemType: Bug
Architecture: amd64
Date: Sun Mar 7 10:13:46 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate amd64 (20091020.3)
NonfreeKernelModules: nvidia
Package: wmctrl 1.07-6
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-20.57-generic
SourcePackage: wmctrl
Uname: Linux 2.6.31-20-generic x86_64

moma (osmoma) wrote :
moma (osmoma) wrote :

Additional info.

Desktop pager:
The second rows of the desktop-pager is not clickable. The desktop-pager reacts only to clicks on the first (upper) row.
The pager looks like this: http://bildr.no/view/603055

I 've rebooted twice and tested it immediately after login. No success. The second row is dead.

I did earlier today a package-check from "sudo init 1" and its Maintenance Menu. The "check broken packages" menu also upgraded a lot of packages. I may re-install the entire system or move to Lucid Lynx A3.

moma (osmoma) wrote :

Hello,
I got the same error in Lucid Lynx (Ubuntu 10.04 from daily built iso).
I do not know what to say.

moma (osmoma) wrote :

Re-hi,

Ok, case solved.
Wmctrl -o X,Y command does not work with Compiz if its "Desktop Cube" and "Rotate Desktop" plugins are activated. AFAIK, the desktop layout in that case has only one row (internally), even the pager can show more than one row.

Picture: http://bildr.no/view/603160
The "Desktop Wall" plugin is OK.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wmctrl (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers