QT is compiled without wkhtmltopdf patches.

Bug #1000961 reported by mbailey on 2012-05-17
66
This bug affects 12 people
Affects Status Importance Assigned to Milestone
wkhtmltopdf
Fix Released
Unknown
wkhtmltopdf (Debian)
New
Unknown
wkhtmltopdf (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu server 12.04 x86_64

If you install wkhtmltopdf (0.9.9) (a tool to convert html documents into PDF's using QT's WebKit renderer) on a server without X already installed, it fails to function.

Reasoning from the --help:

Reduced Functionality:
  This version of wkhtmltopdf has been compiled against a version of QT without
  the wkhtmltopdf patches. Therefore some features are missing, if you need
  these features please use the static version.

  Currently the list of features only supported with patch QT includes:

 * Printing more then one HTML document into a PDF file.
 * Running without an X11 server.
 * Adding a document outline to the PDF file.
 * Adding headers and footers to the PDF file.
 * Generating a table of contents.
 * Adding links in the generated PDF file.
 * Printing using the screen media-type.
 * Disabling the smart shrink feature of webkit.

See second item.

The wkhtmltopdf package should either require X, or QT should be distributed with the aforementioned wkhtmltopdf patch (or a patched version should be available)

mbailey (mbailey-system42) wrote :

Workaround:

Use statically linked binary from the developer:

http://code.google.com/p/wkhtmltopdf/

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wkhtmltopdf (Ubuntu):
status: New → Confirmed
Mantas Kriaučiūnas (mantas) wrote :

Tested releases of wkhtmltopdf (wkhtmltox) with up-to-date test results are available from Odoo developers, see:
https://github.com/odoo/odoo/wiki/Wkhtmltopdf

Changed in wkhtmltopdf:
status: Unknown → Fix Released
Changed in wkhtmltopdf (Debian):
status: Unknown → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.