Please merge wireshark 1.0.5-1 (universe) from Debian unstable (main)

Bug #305789 reported by Nick Ellery on 2008-12-06
2
Affects Status Importance Assigned to Milestone
wireshark (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: wireshark

Please merge wireshark 1.0.5-1 (universe) from Debian unstable (main).

wireshark (1.0.5-1) unstable; urgency=low

  * New upstream release 1.0.5
    - release notes:
     http://www.wireshark.org/docs/relnotes/wireshark-1.0.5.html
    - security fixes:
      - The SMTP dissector could consume excessive amounts of CPU and memory
      - The WLCCP dissector could go into an infinte loop

 -- Joost Yervante Damad <email address hidden> Sat, 13 Dec 2008 14:31:33 +0100

 wireshark (1.0.4-1) unstable; urgency=low

   * New upstream release 1.0.4
     - release notes:
      http://www.wireshark.org/docs/relnotes/wireshark-1.0.4.html
     - security fixes:
       - Bluetooth ACL dissector could crash or abort
       - The Q.931 dissector could crash or abort
       - Wireshark could abort while reading Tamos CommView
         capture files
       - the USB dissector could crash, also BT RFCOMM
       - PRP and MATE dissectors could make Wireshark crash
     - CVE-2008-4680, CVE-2008-4681, CVE-2008-4682, CVE-2008-4683,
       CVE-2008-4684, CVE-2008-4685
   * disable clique_rm support patch (if you're interested in this
     dissector please get it accepted by upstream)
   * add description to some patches

 -- Joost Yervante Damad <email address hidden> Fri, 05 Dec 2008 10:35:47 +0100

Nick Ellery (nick.ellery) wrote :

wireshark (1.0.4-1ubuntu1) jaunty; urgency=low

  * Merge from debian unstable, remaining changes (LP: #305789):
    - Add debian/patches/20_sigpipe.dpatch, which restores the default sigpipe
      action, meaning that the app won't hang under gksu.
    - Add 20_sigpipe to debian/patches/00list.
    - Add debian/README.source
    - debian/control:
      + Replace gksu with menu in wireshark recommends.
    - debian/rules:
      + Corrected FTBFS on all architectures related to autotools and
        config.guess/config.status by allowing a check to fail in some cases

 -- Nick Ellery <email address hidden> Sat, 06 Dec 2008 12:03:49 -0800

Changed in wireshark:
importance: Undecided → Wishlist
status: New → Confirmed
Morten Kjeldgaard (mok0) wrote :

Unstable version is 1.0.5-1 now. Can you please update the merge? Thanks!

Changed in wireshark:
status: Confirmed → Incomplete
assignee: nobody → bobbo
assignee: bobbo → nick.ellery
description: updated
Nick Ellery (nick.ellery) wrote :
Nick Ellery (nick.ellery) wrote :

Updated merge attached.

Changed in wireshark:
assignee: nick.ellery → nobody
status: Incomplete → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wireshark - 1.0.5-1ubuntu1

---------------
wireshark (1.0.5-1ubuntu1) jaunty; urgency=low

  * Merge from debian unstable (LP: #305789), remaining changes:
    - replace gksu with menu in Recommends
    - Add debian/README.source.
    - Add debian/patches/20_sigpipe.dpatch, which restores the default sigpipe
      action, meaning that the app won't hang under gksu.
    - Add 20_sigpipe to debian/patches/00list.
    - Corrected FTBFS on all architectures related to autotools and
      config.guess/config.status by allowing a check to fail in some cases

wireshark (1.0.5-1) unstable; urgency=low

  * New upstream release 1.0.5
    - release notes:
     http://www.wireshark.org/docs/relnotes/wireshark-1.0.5.html
    - security fixes:
      - The SMTP dissector could consume excessive amounts of CPU and memory
      - The WLCCP dissector could go into an infinte loop

wireshark (1.0.4-1) unstable; urgency=low

  * New upstream release 1.0.4
    - release notes:
     http://www.wireshark.org/docs/relnotes/wireshark-1.0.4.html
    - security fixes:
      - Bluetooth ACL dissector could crash or abort
      - The Q.931 dissector could crash or abort
      - Wireshark could abort while reading Tamos CommView
        capture files
      - the USB dissector could crash, also BT RFCOMM
      - PRP and MATE dissectors could make Wireshark crash
    - CVE-2008-4680, CVE-2008-4681, CVE-2008-4682, CVE-2008-4683,
      CVE-2008-4684, CVE-2008-4685
  * disable clique_rm support patch (if you're interested in this
    dissector please get it accepted by upstream)
  * add description to some patches

 -- Nick Ellery <email address hidden> Sun, 14 Dec 2008 13:20:07 -0800

Changed in wireshark:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers