cannot connect to network with iwconfig

Bug #365198 reported by PrebenR on 2009-04-22
2
Affects Status Importance Assigned to Milestone
wireless-tools (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: wireless-tools

Description: Ubuntu 9.04
Release: 9.04
Installed: 29-1.1ubuntu2

I tried to connect to an open network. The card is an ralink rt2860 in an Asus Eee 1000H. I run:
iwlist ra0 scan
sudo iwconfig ra0 essid network-name
sudo iwconfig ra0

the essid is not set. I have tried key open, mode ad-hoc or managed, but it does not help.

When I run sudo dhclient it doens't find an IP and gives up.

Here is a link to another with the same problem: http://ubuntuforums.org/showthread.php?p=7118036

If I run nm-applet, I can connect with that to the net. So it seems to be a problem with iwconfig? I'm not running xfce4 nor gnome, but dwm so that is why I want iwconfig to work.

I have looked at http://wiki.debian.org/rt2860sta and it says iwconfig cannot be used for this card. One must use iwpriv, but I don't get this to work either. ralink just released new source code 2.1.0 now so I'll have a look at that.

please advice what debugging info that are needed.

PrebenR (randhol) on 2009-04-22
description: updated
tags: added: iwconfig iwpriv rt2860
PrebenR (randhol) wrote :

wicd works with the card since 9.10, so this bug can be closed

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers