Failure to recognize wireless network

Bug #312443 reported by Jan H. Guettler on 2008-12-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
wireless-tools (Ubuntu)
Undecided
Unassigned

Bug Description

The systems requires me to identify the faulty package. I have no clue. I have tried to select a package dealing with wireless networks that is accepted by the system.

I have a dual Windows / Ubuntu installation on a Lenovo Thinkpad T61P. I recently upgraded from 8.04 to 8.10 without any problem indication. I can see that my network settings have been kept. However, my wireless connection which had worked for months under 8.04 is no longer detected with 8.10. While I can see about half a dozen of my neighbors' networks, I cannot see my own, so I am unable to connect to it. When I boot up the same PC with Windows XP, I see more or less the same networks including my own, which has about double signal strength of any of the others.

Of course, I have rebooted the system several times and observed the failure to "see" my own network over some days. I therefore fear that there could be a bug that somehow prevents my network from being shown.

I have also tested the wireless access moving away from my house. Several new wireless networks appeared, but not my own. If it has any relevance, my network name is Themaras

I should add that I have three other computers:
1. HP compac nc6000 running native Ubuntu 8.10. No connection problem here. I have compared the list of the wireless networks on the HP with list of the Lenovo Thinkpad in 8.10 mode at the same moment in time. The Lenovo Thinkpad has a significantly more sensitive WIFI unit and sees more than twice as many networks as the HP. But the HP includes my own network, wheras the Thinkpad does not.
2 IBM Thinkpad T60P running dual Windows XP / Ubuntu 8.04. No connection problem in either mode. If requested, I am willing to upgrade to 8.10 also on this PC to see if the problem will be replicated.
3. Macbook. No connection problem
All these PCs have robust Internet connections via my wireless lan. This rules out any network problem.

Jan H. Guettler (jan-guettler) wrote :

I have now upgraded my Thinkpad T60P from Ubuntu 8.04 to Ubuntu 8.10. I have the same problem as for Thinkpad T61P as described above. My WIFI system which worked perfectly under 8.04 is no longer visible under 8.10. When I run the T60P under Windows XP, my wifi system is recognized with signal strength 100%. (The PC is next to the WIFI router). But under Ubuntu 8.10, while other neighborhood wifi systems are visible, I cannot see my own system. I have also tried to reset the security settings and force reconnection without any success.

Philip Wyett (philwyett) wrote :

These laptops have an option of different wifi adapters. Please can you specify which your machines have?

Jan H. Guettler (jan-guettler) wrote :

Thinkpad T6oP has: Intel (R) PRO/Wireless 3945 ABG Network Connection
Thinkpad T61P has: Intel (R) Wireless WIFI link 4965 AGN

Baeckman (stefan-baeckman) wrote :

I have the same problem as Jan has. I have written on Ubuntu forums about it I will make a short version about it here. Link to ubuntuforums is http://ubuntuforums.org/showthread.php?t=1056042.

Network: D-Link DIR-635 wireless 802.11n router. Combined g/n network with WPA2 security.

I have four computers at home.
1. Desktop running ubuntu 8.10. Works fine and connects to my network.
2. Dell (D620) laptop running Windows XP. Works fine.
3. Old Dell laptop running Ubuntu 8.10. Works fine.
4. Acer Aspire One 110 netbook. Wireless chipset Atheros 5424/2424. Running Ubuntu 8.10 with madwifi driver (0.10.5.6-r3904) for the wireless network. Was working fine but now it cannot see my own network. It can see 25-30 other network though.

"sudo iwlist scan" does not list my network.

I can connect to other wireless network with AA1.

iwlist: wireless-tools version 29 ath0 compiled with wireless extension 22.

regards
Stefan Bäckman

zertz (zertz) wrote :

this bug also effects Jaunty alpha 5 and Linksys routers. network devices will be blind to broadcasted SSID.

Jan H. Guettler (jan-guettler) wrote :

I have now installed the latest version of Ubuntu (if my memory serves me right, it was 9.04. the version number was reported when I did the update, but later I have not able to find any information about the version on the system itself.)

Anyway, the problem I reported here disappeared with the new version. Two of my three Linux PCs went onlin with my WIFI system immediately after login. The third required me to reinsert the WEP key.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers