Please remove wireless-tools from oracular

Bug #2068612 reported by Ravi Kant Sharma
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
Confirmed
Undecided
Unassigned
wireless-tools (Ubuntu)
Confirmed
Undecided
Ravi Kant Sharma

Bug Description

Wireless Extensions support in the kernel has been deprecated[1] for a long time now. wireless-tools[2] userspace utility should be removed. iw[3] is considered as the alternate.

See page[4] for comparison between wireless-tools and iw. iw supports everything except deprecated Wireless-Extensions.

See page[5] for replacing iwconfig with iw.

$ reverse-depends wireless-tools
Reverse-Recommends
==================
* broadcom-sta-dkms
* hw-probe
* laptop-mode-tools
* task-laptop
* whereami

Reverse-Depends
===============
* aircrack-ng [amd64 ppc64el s390x]
* kubuntu-desktop [amd64 arm64 armhf ppc64el]
* linssid [amd64 arm64 ppc64el s390x]
* lubuntu-desktop [amd64 arm64 armhf ppc64el s390x]
* vanilla-gnome-desktop [amd64 arm64 armhf ppc64el]

Packages without architectures listed are reverse-dependencies in: amd64, arm64, armhf, i386, ppc64el, s390x

$ reverse-depends -b wireless-tools
Reverse-Build-Depends
=====================
* networkd-dispatcher

[1] https://wireless.wiki.kernel.org/en/developers/documentation/wireless-extensions
[2] https://hewlettpackard.github.io/wireless-tools/Tools.html
[3] https://wireless.wiki.kernel.org/en/users/documentation/iw
[4] https://wiki.archlinux.org/title/Network_configuration/Wireless#iw_and_wireless_tools_comparison
[5] https://wireless.wiki.kernel.org/en/users/documentation/iw/replace-iwconfig

Related branches

Revision history for this message
Ravi Kant Sharma (ravi-sharma) wrote :

$ reverse-depends -a source src:wireless-tools
Reverse-Build-Depends
=====================
* conky (for libiw-dev)
* guessnet (for libiw-dev)
* haskell-iwlib (for libiw-dev)
* libwlocate (for libiw-dev)
* lxpanel (for libiw-dev)
* matchbox-panel (for libiw-dev)
* mate-applets (for libiw-dev)
* networkd-dispatcher (for wireless-tools)
* ubiquity (for libiw-dev)
* wmwave (for libiw-dev)

description: updated
Revision history for this message
Ravi Kant Sharma (ravi-sharma) wrote :
Changed in wireless-tools (Ubuntu):
assignee: nobody → Ravi Kant Sharma (ravi-sharma)
Revision history for this message
wontfix (wontfix) wrote :

wireless-tools has been a required dependency of the ubuntu-desktop-minimal package going back at least to focal.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed
Changed in wireless-tools (Ubuntu):
status: New → Confirmed
Revision history for this message
Paride Legovini (paride) wrote :

FWIW I maintain iw in Debian, so if there is anything that can be done in iw packaging to make this easier, just ping me.

no longer affects: aircrack-ng (Ubuntu)
no longer affects: aircrack-ng (Ubuntu)
Revision history for this message
Ravi Kant Sharma (ravi-sharma) wrote :
description: updated
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.