Please update regulations to support VHT

Bug #1284093 reported by Nate Carlson on 2014-02-24
64
This bug affects 14 people
Affects Status Importance Assigned to Milestone
wireless-regdb (Ubuntu)
Undecided
Unassigned
Vivid
Undecided
Unassigned
Wily
Undecided
Unassigned

Bug Description

Only very recent versions of wireless-regdb have support for VHT (80mhz channels); in addition, all current kernels have a bug that will cause your card to fail to associate with a VHT ap when your local regdb didn't allow VHT:

https://bugzilla.kernel.org/show_bug.cgi?id=70881

I have updated the existing Debian bug requesting this too:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=729089

Well, more precisely I have emailed the update but it hasn't gone through yet. :)

I would recommend updating to 2013.11.27 (current upstream) as it includes other regulatory fixes. I would also recommend applying this to at least Precise and Trusty, possibly Saucy since it is still supported.

Here is the update that should post to the Debian bug soon:
"I would much appreciate this, especially you make the jump to 2013.11.27. The new regdb will also solve issues with 802.11ac; the referenced version appears to be the first with support for 80mhz channels. Without the new regdb (or a patch the kernel that masks the symptoms, below), when you connect to an AP that supports 80mhz channels, you are disconnected with a nearly useless error. Link to the ticket, with details and the symptom-masking patch that will be in future kernels:

https://bugzilla.kernel.org/show_bug.cgi?id=70881

It would be great if we could get the new regdb upstream into Debian asap; in the meantime I will try to get an updated version into a ppa for Ubuntu users at least. ;)"

Nate Carlson (natecarlson) wrote :

Debian has packaged 2013.11.27:
http://anonscm.debian.org/gitweb/?p=kernel/wireless-regdb.git

Any chance we could get this into Trusty? Without it, there are weird connection issues with 802.11ac.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wireless-regdb (Ubuntu):
status: New → Confirmed
Nick Maynard (nick-maynard) wrote :

Come on now - surely this is embarassing?

The regdb on Ubuntu is now almost *2 years* out of date.

As of now, the latest stable version is 2014-10-07.

For all those suffering from this (and VHT issues, etc.), I've found the Debian testing package to apply cleanly and enable VHT successfully - https://packages.debian.org/jessie/wireless-regdb

Ryan Finnie (fo0bar) wrote :

This is one of the major contributing factors to LP: #1437913.

I have rebased 2013.02.13-1ubuntu1 on top of Debian 2014.11.18-1, please see:

https://launchpad.net/~fo0bar/+archive/ubuntu/ppa/+build/7325504

Could I get a sponsor upload? Thank you.

Jonathan Riddell (jr) wrote :

Lovely, successfully fixes my laptop.

I've uploaded to wily

I've uploaded to vivid-proposed awaiting approval from ~ubuntu-sru

TEST CASE:
Buy a Thinkpad 450s in the US with "Intel Corporation Wireless 7265 (rev 59)"
If you can use the internet for 10 minutes without pulling out your hair it has worked

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wireless-regdb - 2014.11.18-1ubuntu1

---------------
wireless-regdb (2014.11.18-1ubuntu1) wily; urgency=medium

  * Resynchronise with Debian. LP: #1284093
    Remaining changes:
    - Replace REGDB_AUTHOR with the ubuntu-devel-discuss@ list, to create
      our own private key for signing the regulatory data.
    - Explicitly override dh_auto_build to make a new private key.
    - Don't remove pubkeys, to make sure the key can be verified; but still
      remove /lib/crda/pubkeys/linville.key.pub.pem since that conflicts
      with crda.
    - debian/patches/dont_auto_create_keypair: Drop the tilde from the key
      path, since it isn't guaranteed to work on buildds.

 -- Ryan Finnie <email address hidden> Mon, 13 Apr 2015 19:56:45 +0000

Changed in wireless-regdb (Ubuntu Wily):
status: Confirmed → Fix Released

Hello Nate, or anyone else affected,

Accepted wireless-regdb into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/wireless-regdb/2014.11.18-1ubuntu1~ubuntu15.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in wireless-regdb (Ubuntu Vivid):
status: New → Fix Committed
tags: added: verification-needed
Jonathan Riddell (jr) wrote :

I install vivid and tried to download some packages (for an upgrade to wily). After initial successs download slowed and pings to google.com were equally 1000ms. Other computers on my network for pings of 30ms. On installing this package and rebooting the packages all downloaded fine and pings to google.com were 30ms reliably for the 30 minutes it took to download them.

I installed 2014.11.18-1ubuntu1~ubuntu15.04.1 from vivid-proposed

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wireless-regdb - 2014.11.18-1ubuntu1~ubuntu15.04.1

---------------
wireless-regdb (2014.11.18-1ubuntu1~ubuntu15.04.1) vivid; urgency=medium

  * Vivid SRU LP: #1284093

 -- Jonathan Riddell <email address hidden> Fri, 12 Jun 2015 07:02:48 +0200

Changed in wireless-regdb (Ubuntu Vivid):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for wireless-regdb has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers