wireguard-dkms 0.0.20190913-1ubuntu1: wireguard kernel module failed to build

Bug #1862413 reported by Kolman Czito on 2020-02-07
110
This bug affects 21 people
Affects Status Importance Assigned to Milestone
wireguard (Ubuntu)
Undecided
Unassigned
Eoan
Undecided
Marcelo Cerri
wireguard-linux-compat (Ubuntu)
Undecided
Unassigned
Eoan
Undecided
Marcelo Cerri

Bug Description

apt -y upgrade initiated

ProblemType: Package
DistroRelease: Ubuntu 19.10
Package: wireguard-dkms 0.0.20190913-1ubuntu1
ProcVersionSignature: Ubuntu 5.3.0-29.31-generic 5.3.13
Uname: Linux 5.3.0-29-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu8.3
Architecture: amd64
DKMSKernelVersion: 5.3.0-40-generic
Date: Fri Feb 7 13:36:03 2020
DuplicateSignature: dkms:wireguard-dkms:0.0.20190913-1ubuntu1:/var/lib/dkms/wireguard/0.0.20190913/build/socket.c:145:20: error: ‘const struct ipv6_stub’ has no member named ‘ipv6_dst_lookup’; did you mean ‘ipv6_dst_lookup_flow’?
InstallationDate: Installed on 2019-10-29 (101 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
PackageArchitecture: all
PackageVersion: 0.0.20190913-1ubuntu1
Python3Details: /usr/bin/python3.7, Python 3.7.5, python3-minimal, 3.7.5-1
PythonDetails: /usr/bin/python2.7, Python 2.7.17, python-minimal, 2.7.17-1
RelatedPackageVersions:
 dpkg 1.19.7ubuntu2
 apt 1.9.4
SourcePackage: wireguard
Title: wireguard-dkms 0.0.20190913-1ubuntu1: wireguard kernel module failed to build
UpgradeStatus: No upgrade log present (probably fresh install)

Kolman Czito (mindfriends) wrote :
tags: removed: need-duplicate-check
Marcelo Cerri (mhcerri) on 2020-02-14
Changed in wireguard (Ubuntu Eoan):
status: New → In Progress
assignee: nobody → Marcelo Cerri (mhcerri)
Jason A. Donenfeld (zx2c4) wrote :

The latest version is v0.0.20200214.

Kolman Czito (mindfriends) wrote :

@zx2c4 I noticed.

Using the PPA I was able to bump up my version:

Setting up wireguard-tools (1.0.20200206-0ppa1~19.10) ...
Setting up wireguard (1.0.20200206-0ppa1~19.10) ...

Neither the PPA nor the Ubuntu repository have version x.0.20200214. Personally, I'm not afraid to build from source but having nightly builds in the repositories would be great. Is anyone setting that up I can reach out to assist?

Jason A. Donenfeld (zx2c4) wrote :

Go to www.wireguard.com/install/ , find the links for Ubuntu and Debian, and press the "out of date" button.

Kolman Czito (mindfriends) wrote :

Done, thank you. I completely missed that those were links.

Marcelo Cerri (mhcerri) wrote :

We are already working to bring a newer version.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wireguard (Ubuntu):
status: New → Confirmed
Jason A. Donenfeld (zx2c4) wrote :

The Ubuntu kernel team seems to be behind in deploying a fix for this. In the interim you can solve this by using the WireGuard project's PPA, which now has backports for 19.10. Run this command to fix your issue:

sudo add-apt-repository ppa:wireguard/wireguard && sudo apt-get update && sudo apt-get upgrade

Hello Kolman, or anyone else affected,

Accepted wireguard into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/wireguard/1.0.20200206-1ubuntu1~19.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in wireguard (Ubuntu Eoan):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-eoan
Andy Whitcroft (apw) wrote :

Hello Kolman, or anyone else affected,

Accepted wireguard-linux-compat into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/wireguard-linux-compat/0.0.20200205-1ubuntu1~19.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in wireguard (Ubuntu):
status: Confirmed → Invalid
Changed in wireguard-linux-compat (Ubuntu):
status: New → Invalid
Changed in wireguard-linux-compat (Ubuntu Eoan):
status: New → Fix Committed
Brett Frankenberger (rbfnet) wrote :

Tested wireguard-dkms_0.0.20200205-1ubuntu1~19.10.1_all.deb; module builds and functions properly on kernel 5.3.0-40-generic.

tags: added: verification-done-eoan
removed: verification-needed-eoan
Marcelo Cerri (mhcerri) on 2020-02-20
Changed in wireguard-linux-compat (Ubuntu Eoan):
assignee: nobody → Marcelo Cerri (mhcerri)
Marcelo Cerri (mhcerri) wrote :

I also tested wireguard-dkms from eoan-proposed (0.0.20200205-1ubuntu1~19.10.1) and it builds and works fine.

I tested it against 5.3.0-1018-raspi2 (using a raspberry pi 4) and against 5.3.0-40-generic (using qemu). I was able to connect these two nodes and also from the Android app.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wireguard - 1.0.20200206-1ubuntu1~19.10.1

---------------
wireguard (1.0.20200206-1ubuntu1~19.10.1) eoan; urgency=medium

  * Sync with Focal to fix build issues (LP: #1862413)

 -- Marcelo Henrique Cerri <email address hidden> Fri, 14 Feb 2020 13:27:45 +0000

Changed in wireguard (Ubuntu Eoan):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wireguard-linux-compat - 0.0.20200205-1ubuntu1~19.10.1

---------------
wireguard-linux-compat (0.0.20200205-1ubuntu1~19.10.1) eoan; urgency=medium

  * Sync with Focal to fix build issues (LP: #1862413)

 -- Marcelo Henrique Cerri <email address hidden> Fri, 14 Feb 2020 13:28:57 +0000

Changed in wireguard-linux-compat (Ubuntu Eoan):
status: Fix Committed → Fix Released
Anton C (ac14112) wrote :

The fixed version (0.0.20200205-1ubuntu1~19.10.1) works for me. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers