Gnome Software catalog entry missing for Wine

Bug #1571816 reported by carlix on 2016-04-18
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
wine (Ubuntu)
Medium
Unassigned
Yakkety
Medium
Unassigned
wine-development (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned
Yakkety
Medium
Unassigned
wine1.6 (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned

Bug Description

Original Bug Report
===================
A very beautiful app, but is missing in the Gnome-Software catalog!!!
You can install it from terminal but if you search for it in gnome-software you can´t install it.

Impact
======
If you search for Wine in the Software app in Ubuntu 16.04 LTS or 16.10, you get no results for wine.

Test Case
=========
Note that you probably need to wait a day or two after this package is published to -proposed for the appstream generator to work and this test case to work.

1. Enable proposed updates
2. Open the Software app. Search for wine

There should be two wine entries, one named Wine, one named Wine (development version).
3. Optionally install wine

Note that wine in Ubuntu 16.10 and newer and wine-development in all versions does not currently install any .desktop launchers. One way to verify that wine is installed by running wineconsole-stable or wineconsole-development

For wine in Ubuntu 16.04, you can verify wine1.6 is installed by running the Notepad app which should be installed.

Regression Potential
====================
Almost none. This just adds an app icon and appstream metadata.

carlix (carlixlinux) on 2016-04-18
affects: steam (Ubuntu) → wine1.6 (Ubuntu)
summary: - Wine doesnt appear to install in Gnome-Software
+ Wine doesnt appear to install in Gnome-Software Ubuntu Gnome 16.04

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wine1.6 (Ubuntu):
status: New → Confirmed
Changed in wine (Ubuntu):
status: New → Confirmed
Changed in wine-development (Ubuntu):
status: New → Confirmed
shankao (shankao) on 2016-05-24
tags: added: yakkety
carlix (carlixlinux) on 2016-06-13
summary: - Wine doesnt appear to install in Gnome-Software Ubuntu Gnome 16.04
+ Wine doesnt appear to install in Gnome-Software

In Xenial, Wine is showing as "Wine Settings", probably because there is a "NoDisplay=true" line in the wine.desktop file (because we don't want the Wine launcher to be displayed in the menu, we just want it to handle the corresponding mimetypes); in Yakkety, Wine is not showing at all because the wine.desktop and other desktop/icon files are missing.

AsciiWolf (0cs9r-cyil-wz6b3) wrote :
summary: - Wine doesnt appear to install in Gnome-Software
+ Gnome Software catalog entry missing for Wine
tags: added: zesty
jre (jre-phoenix) wrote :

src:wine (1.8.6-3) and src:wine-development (2.0~rc6-1) add AppStream metainfo to the packages. This should fix this.

Changed in wine (Ubuntu):
status: Confirmed → Fix Committed
Changed in wine-development (Ubuntu):
status: Confirmed → Fix Committed
Jeremy Bicha (jbicha) on 2017-01-23
Changed in wine (Ubuntu):
importance: Undecided → Medium
Changed in wine (Ubuntu Yakkety):
status: New → Triaged
importance: Undecided → Medium
Changed in wine-development (Ubuntu Yakkety):
status: New → Triaged
importance: Undecided → Medium
Changed in wine-development (Ubuntu):
importance: Undecided → Medium
no longer affects: wine (Ubuntu Xenial)
Changed in wine-development (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Medium
no longer affects: wine1.6 (Ubuntu Yakkety)
Changed in wine1.6 (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in wine1.6 (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Medium
tags: added: appstream xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wine - 1.8.6-3ubuntu1

---------------
wine (1.8.6-3ubuntu1) zesty; urgency=medium

  * Merge with Debian (LP: #1571816). Remaining changes:
    - Use unversioned sonames in debian/scripts/sonames2elf
      so that dpkg-shlibdeps can find libGL.so in Ubuntu (closes: #827770).
    - Rename package wine to wine-stable. Needed for the transition to a
      0-epoch in the version number.
      Necessary until after the transition is complete (18.04).

wine (1.8.6-3) unstable; urgency=medium

  * Fix AppStream metainfo file (closes: #848839).

wine (1.8.6-2) unstable; urgency=medium

  [ Jens Reyer ]
  * Cherrypick changes from master:
    - Reorganize patches and add some metadata.
    - Drop shlib-exit-calls.patch.
    - Drop openal.patch, fixed upstream.
    - Simplify the foreign-arch test in the wine script.
    - Let wine suggest winbind.
    - Change trigger interest to noawait (LP: 1652434).
    - Documentation updates.
    - Blacklist some extensions for native file type association
      (closes: #845334).
  * Sort packages in debian/control.in.
  * Drop obsolete entries from d/clean.
  * Check for invalid WINEARCH values (closes: #838474).
  * Generate and install wine.svg icon.
  * Add initial AppStream metainfo file (closes: #848839).

 -- Jeremy Bicha <email address hidden> Mon, 23 Jan 2017 16:43:02 -0500

Changed in wine (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wine-development - 2.0~rc6-1ubuntu1

---------------
wine-development (2.0~rc6-1ubuntu1) zesty; urgency=medium

  * Merge with Debian (LP: #1571816). Remaining changes:
    - Use unversioned sonames in debian/scripts/sonames2elf
      so that dpkg-shlibdeps can find libGL.so in Ubuntu (closes: #827770).

wine-development (2.0~rc6-1) unstable; urgency=medium

  [ Michael Gilbert ]
  * New upstream release 2.0-rc6, released Jan 20, 2017.
  * Add libxml-parser-perl to the build dependencies.

  [ Jens Reyer ]
  * Drop obsolete entries from d/clean.
  * Keep tools/make_makefiles in the orig.tar.
  * Generate and install wine.svg icon.
  * Add initial AppStream metainfo file (see: #848839).

wine-development (2.0~rc5-1) unstable; urgency=medium

  * New upstream release 2.0-rc5, released Jan 13, 2017.

 -- Jeremy Bicha <email address hidden> Mon, 23 Jan 2017 17:10:39 -0500

Changed in wine-development (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2017-02-08
description: updated
Jeremy Bicha (jbicha) on 2017-02-08
Changed in wine-development (Ubuntu Xenial):
status: Triaged → In Progress
Changed in wine-development (Ubuntu Yakkety):
status: Triaged → In Progress
Changed in wine-development (Ubuntu Xenial):
status: In Progress → Triaged
Changed in wine (Ubuntu Yakkety):
status: Triaged → In Progress
Jeremy Bicha (jbicha) on 2017-02-08
Changed in wine1.6 (Ubuntu):
status: Triaged → Fix Committed
Changed in wine1.6 (Ubuntu Xenial):
status: Triaged → In Progress
Jeremy Bicha (jbicha) on 2017-02-08
Changed in wine-development (Ubuntu Xenial):
status: Triaged → In Progress

Hello carlix, or anyone else affected,

Accepted wine-development into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/wine-development/1.9.20-1ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in wine-development (Ubuntu Yakkety):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in wine (Ubuntu Yakkety):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello carlix, or anyone else affected,

Accepted wine into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/wine/1.8.5-1ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in wine-development (Ubuntu Xenial):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello carlix, or anyone else affected,

Accepted wine-development into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/wine-development/1.9.6-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in wine1.6 (Ubuntu Xenial):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello carlix, or anyone else affected,

Accepted wine1.6 into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/wine1.6/1:1.6.2-0ubuntu14.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Jeremy Bicha (jbicha) wrote :

From Ubuntu GNOME 16.04.2 and 16.10, I enabled -proposed updates. I opened the Software app and searched for wine. The entries showed correctly for wine-development on 16.04 LTS and 16.10 and for wine in 16.10.

For 16.04 LTS, the entry showed as "Configure Wine" when it should be just "Wine". I will need to do more research to find out how to improve this. For the SRU team, you are welcome to release all but wine1.6. You can even release wine1.6 if you want to since it's still an improvement to show something rather than nothing.

tags: added: verification-done-yakkety
removed: verification-needed

On Wed, Feb 22, 2017 at 02:45:14AM -0000, Jeremy Bicha wrote:
> >From Ubuntu GNOME 16.04.2 and 16.10, I enabled -proposed updates. I
> opened the Software app and searched for wine. The entries showed
> correctly for wine-development on 16.04 LTS and 16.10 and for wine in
> 16.10.
>
> For 16.04 LTS, the entry showed as "Configure Wine" when it should be
> just "Wine". I will need to do more research to find out how to improve
> this. For the SRU team, you are welcome to release all but wine1.6. You
> can even release wine1.6 if you want to since it's still an improvement
> to show something rather than nothing.

Please confirm or deny whether

  http://appstream.ubuntu.com/data/xenial-proposed/universe/Components-amd64.yml.gz

contains the right thing for wine1.6.

If it does, then the problem is probably on the client side. If not,
then it's obviously on the server (or in the package).

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

Jeremy Bicha (jbicha) wrote :

The .yml says the right thing for wine1.6.

Iain Lane (laney) wrote :

On Wed, Feb 22, 2017 at 12:05:46PM -0000, Jeremy Bicha wrote:
> The .yml says the right thing for wine1.6.

Oh, and you can use `appstreamcli get org.winehq.wine' to verify that
appstreamcli sees the right thing.

Note that if this is right then it does *not* mean that gnome-software
will report the same data. It's just to check that the data has been
downloaded onto the system properly. appstreamcli is provided by
src:appstream (AFAIK used by Discover, but maybe not in 16.04), but
gnome-software uses src:appstream-glib to parse the appstream, as well
as doing its own manipulations.

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

Jeremy Bicha (jbicha) wrote :

SRU Team, I uploaded wine1.6 1.6.2-0ubuntu14.2 to the xenial unapproved queue to try to improve wine1.6's appearance in the Software app.

Hello carlix, or anyone else affected,

Accepted wine1.6 into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/wine1.6/1:1.6.2-0ubuntu14.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Jeremy Bicha (jbicha) wrote :

I filed https://bugzilla.gnome.org/779379 since the name is still not ideal for wine1.6/xenial-proposed. This might be a gnome-software bug since the appstream data seems correct.

SRU Team, I'm fine if you release all of these SRUs. We can track the remaining wine1.6 issue in a separate bug but having the wrong name is better than not showing up at all.

tags: removed: verification-needed
Jeremy Bicha (jbicha) wrote :

I'm marking this verification-done since it looks to me like we'll need to backport changes from appstream-glib and gnome-software to fix the wine1.6 name issue. Or if that's too invasive, maybe we can figure out another way to work around the issue.

tags: added: verification-done verification-done-xenial
removed: xenial
Robie Basak (racb) wrote :

12:49 <jbicha> wine1.6 is just a transitional package in 16.10+
12:49 <rbasak> OK, so Invalid?
12:50 <jbicha> if you want; I just had it set to the same status as xenial

Changed in wine1.6 (Ubuntu):
status: Fix Committed → Invalid

The verification of the Stable Release Update for wine-development has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wine - 1.8.5-1ubuntu2

---------------
wine (1.8.5-1ubuntu2) yakkety; urgency=medium

  * Add app icon and appstream metadata to enable wine to show in
    Software app (LP: #1571816)

 -- Jeremy Bicha <email address hidden> Wed, 08 Feb 2017 15:09:37 -0500

Changed in wine (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wine-development - 1.9.20-1ubuntu2

---------------
wine-development (1.9.20-1ubuntu2) yakkety; urgency=medium

  * Add app icon and appstream metadata to enable wine to show in
    Software app (LP: #1571816)

 -- Jeremy Bicha <email address hidden> Wed, 08 Feb 2017 15:21:20 -0500

Changed in wine-development (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Robie Basak (racb) wrote :

12:51 <rbasak> jbicha: OK thanks. wine1.6 for Xenial hasn't aged enough anyway. The others look fine to accept. Personally I'd hold wine1.6 in xenial-proposed until it's properly resolved, and drop the X-AppStream-Ignore change unless it is demonstrably required.

12:52 <rbasak> (demonstrably required whether for this bug or some other SRU-worthy issue)

12:54 <jbicha> ok

Full discussion at: https://irclogs.ubuntu.com/2017/03/01/%23ubuntu-devel.html around 12:28 UTC. Switching back to verification-needed for wine1.6 in Xenial (and all others are released).

Robie Basak (racb) wrote :

jbicha, thanks again for driving the fixes for these.

tags: added: verification-needed
removed: verification-done verification-done-xenial verification-done-yakkety
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wine-development - 1.9.6-1ubuntu1

---------------
wine-development (1.9.6-1ubuntu1) xenial; urgency=medium

  * Add app icon and appstream metadata to enable wine to show in
    Software app (LP: #1571816)

 -- Jeremy Bicha <email address hidden> Wed, 08 Feb 2017 17:31:19 -0500

Changed in wine-development (Ubuntu Xenial):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) wrote :

Robie decided not to accept wine1.6/xenial today because the bug is still not fully fixed. Also, he'd prefer to not have an SRU add X-AppStream-Ignore unless it's needed to fix the bug.

As part of a recent change in the Stable Release Update verification policy we would like to inform that for a bug to be considered verified for a given release a verification-done-$RELEASE tag needs to be added to the bug where $RELEASE is the name of the series the package that was tested (e.g. verification-done-xenial). Please note that the global 'verification-done' tag can no longer be used for this purpose.

Thank you!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers