Migrate to wine1.6 and remove old wine things from archive

Bug #1218645 reported by Scott Ritchie
92
This bug affects 16 people
Affects Status Importance Assigned to Milestone
wine-gecko1.4 (Ubuntu)
Wishlist
Unassigned
wine1.4 (Ubuntu)
Wishlist
Unassigned

Bug Description

Wine has a new stable release that requires migrating some of its dependent packages.

Uploaded now are:
wine1.6
wine-mono0.0.8
wine-gecko2.21

Please delete:
wine1.4
wine-gecko1.4

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wine-gecko1.4 (Ubuntu):
status: New → Confirmed
Changed in wine1.4 (Ubuntu):
status: New → Confirmed
Revision history for this message
Scott Ritchie (scottritchie) wrote : Re: [FFE] Migrate to wine1.6 and remove old wine things from archive

It seems these were uploaded about an hour after Feature Freeze :/ So, this is also a feature freeze exception request. Wine is currently a leaf package, and is also engineered to be backwards compatible and regression free from one stable release to the next, so I don't see any significant difficulties.

Wine releases in general are pretty much bugfix-only releases, so I feel like this qualifies for that part of the FFE process.

summary: - Migrate to wine1.6 and remove old wine things from archive
+ [FFE] Migrate to wine1.6 and remove old wine things from archive
Revision history for this message
Susan Cragin (susancragin) wrote :

As of today, 2-Oct-2013, none of the versions of wine are installable, including 1.5 and 1.6.
I am running Saucy, but if I switch to the Raring PPA, terrible things happen. Attempts to install announce that wine will install, but at the same time remove about 3 dozen necessary (and unrelated to wine) packages.

Revision history for this message
Adam Conrad (adconrad) wrote :

Unfortunately, getting around to reviewing this just came way too late, and I'm really sorry about that. I'm going to have to reject these uploads from the saucy queue, but would request that they land in 14.04 pretty much on opening day, and I'll quickly review, do the removals, etc, so there's some time to bake and test the lot.

summary: - [FFE] Migrate to wine1.6 and remove old wine things from archive
+ Migrate to wine1.6 and remove old wine things from archive
Revision history for this message
Stéphane Graber (stgraber) wrote :

Unsubscribing ~ubuntu-archive for now, please re-subscribe once wine1.6 is in the archive and 1.4 is ready to be removed.

Revision history for this message
Stéphane Graber (stgraber) wrote :

Unsubscribing ~ubuntu-release since that didn't make it into saucy.

Rolf Leggewie (r0lf)
Changed in wine1.4 (Ubuntu):
importance: Undecided → Wishlist
Changed in wine-gecko1.4 (Ubuntu):
importance: Undecided → Wishlist
Changed in wine1.4 (Ubuntu):
status: Confirmed → Triaged
Rolf Leggewie (r0lf)
tags: added: trusty upgrade-software-version
Changed in wine1.4 (Ubuntu):
milestone: none → ubuntu-14.04-alpha-1
Changed in wine-gecko1.4 (Ubuntu):
milestone: none → ubuntu-14.04-alpha-1
Revision history for this message
Scott Ritchie (scottritchie) wrote :

After some further modifications, I have now uploaded new packages for Trusty:

wine1.6
wine-gecko2.21
wine-mono0.0.8

Revision history for this message
Kai Mast (kai-mast) wrote :

where are those packages? I can only find wine1.4 in trusty[-proposed].

Revision history for this message
Scott Ritchie (scottritchie) wrote :

They are sitting in the NEW queue waiting for an archive admin to approve them.

Revision history for this message
Adam Conrad (adconrad) wrote :

Removing packages from trusty:
 wine1.4 1.4.1-0ubuntu7 in trusty
Comment: Superseded by wine1.6
Remove [y|N]? y
1 package successfully removed.
Removing packages from trusty-proposed:
 wine1.4 1.4.1-0ubuntu9 in trusty
Comment: Superseded by wine1.6
Remove [y|N]? y
1 package successfully removed.
Removing packages from trusty:
 wine-gecko1.4 1.4.0-0ubuntu2 in trusty
  wine-gecko1.4 1.4.0-0ubuntu2 in trusty amd64
  wine-gecko1.4 1.4.0-0ubuntu2 in trusty i386
Comment: Superseded by wine-gecko2.21
Remove [y|N]? y
1 package successfully removed.

Changed in wine1.4 (Ubuntu):
status: Triaged → Fix Released
Changed in wine-gecko1.4 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers