wine cannot be installed on 64-bit Ubuntu Precise: dependency problems

Bug #1004217 reported by Dima Ryazanov on 2012-05-24
100
This bug affects 21 people
Affects Status Importance Assigned to Milestone
wine1.4 (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading to 12.04, I cannot install wine anymore:

$ sudo apt-get install wine1.4
[...]
The following packages have unmet dependencies:
 wine1.4 : Depends: wine1.4-amd64 (= 1.4-0ubuntu4)
           Depends: wine1.4-i386 (= 1.4-0ubuntu4)

$ sudo apt-get install wine1.4-i386
[...]
The following packages have unmet dependencies:
 wine1.4-i386:i386 : Depends: libgl1-mesa-glx:i386 but it is not going to be installed or
                              libgl1:i386
                     Depends: libglu1-mesa:i386 but it is not going to be installed or
                              libglu1:i386
                     Recommends: gettext:i386 but it is not going to be installed

And so on.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: wine1.4 (not installed)
Uname: Linux 3.3.0 x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Thu May 24 15:14:27 2012
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: wine1.4
UpgradeStatus: Upgraded to precise on 2012-04-27 (26 days ago)

kroq-gar78 (kroq-gar78) on 2012-05-24
summary: - wine cannot be installed on 64-bit Ubuntu Precise
+ wine cannot be installed on 64-bit Ubuntu Precise: dependency problems
kroq-gar78 (kroq-gar78) wrote :

Try installing wine1.4 and wine1.4-amd64

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wine1.4 (Ubuntu):
status: New → Confirmed
Eric Urban (hydrogen18) wrote :
Download full text (24.5 KiB)

I am experiencing the same bug when trying to use aptitude to install wine:

sudo aptitude install wine
The following NEW packages will be installed:
  cabextract{a} fonts-horai-umefont fonts-unfonts-core{a} gettext:i386{ab} gettext-base:i386{ab} libcapi20-3{a} libgif4:i386{a} libmpg123-0{a} libodbc1{a} libpam-winbind{a} ttf-mscorefonts-installer{a} ttf-umefont{a}
  ttf-unfonts-core{a} unixodbc{a} unrar{a} winbind{a} wine wine-gecko1.4{a} wine-gecko1.4:i386{a} wine1.4{a} wine1.4-amd64{a} wine1.4-common{a} wine1.4-i386:i386{a} winetricks{a}
0 packages upgraded, 24 newly installed, 0 to remove and 1 not upgraded.
Need to get 144 MB of archives. After unpacking 391 MB will be used.
The following packages have unmet dependencies:
 gettext-base : Conflicts: gettext-base:i386 but 0.18.1.1-5ubuntu3 is to be installed.
 gettext-base:i386 : Conflicts: gettext-base but 0.18.1.1-5ubuntu3 is installed.
 gettext : Conflicts: gettext:i386 but 0.18.1.1-5ubuntu3 is to be installed.
 gettext:i386 : Conflicts: gettext but 0.18.1.1-5ubuntu3 is installed.
Internal error: the solver Install(grub-common:i386 1.99-21ubuntu3 <grub2-common:amd64 1.99-21ubuntu3 -> {grub-common:amd64 1.99-21ubuntu3 grub-common:i386 1.99-21ubuntu3}>) of a supposedly unresolved dependency is already installed in step 168
Internal error: the solver Install(grub-common:i386 1.99-21ubuntu3 <grub-pc-bin:amd64 1.99-21ubuntu3 -> {grub-common:amd64 1.99-21ubuntu3 grub-common:i386 1.99-21ubuntu3}>) of a supposedly unresolved dependency is already installed in step 168
Internal error: the solver Install(grub-pc:i386 1.99-21ubuntu3 <grub-gfxpayload-lists:amd64 0.6 -> {grub-pc:amd64 1.99-21ubuntu3 grub-pc:i386 1.99-21ubuntu3}>) of a supposedly unresolved dependency is already installed in step 177
Internal error: the solver Install(espeak:i386 1.46.02-0ubuntu1 <espeak-data:amd64 1.46.02-0ubuntu1 -S> {espeak:amd64 1.46.02-0ubuntu1 espeak:i386 1.46.02-0ubuntu1}>) of a supposedly unresolved dependency is already installed in step 228
open: 47; closed: 245; defer: 12; conflict: 13 .Internal error: the solver Install(ghostscript:i386 9.05~dfsg-0ubuntu4 <gs-cjk-resource:amd64 1.20100103-3 -> {ghostscript:amd64 9.05~dfsg-0ubuntu4 ghostscript:i386 9.05~dfsg-0ubuntu4}>) of a supposedly unresolved dependency is already installed in step 634
Internal error: the solver Install(ghostscript:i386 9.05~dfsg-0ubuntu4 <ghostscript-x:amd64 9.05~dfsg-0ubuntu4 -> {ghostscript:amd64 9.05~dfsg-0ubuntu4 ghostscript:i386 9.05~dfsg-0ubuntu4}>) of a supposedly unresolved dependency is already installed in step 634
Internal error: the solver Install(gvfs-daemons:i386 1.12.1-0ubuntu1 <gvfs-backends:amd64 1.12.1-0ubuntu1 -> {gvfs-daemons:amd64 1.12.1-0ubuntu1 gvfs-daemons:i386 1.12.1-0ubuntu1}>) of a supposedly unresolved dependency is already installed in step 661
Internal error: the solver Install(gvfs-daemons:i386 1.12.1-0ubuntu1 <gvfs:amd64 1.12.1-0ubuntu1 -> {gvfs-daemons:amd64 1.12.1-0ubuntu1 gvfs-daemons:i386 1.12.1-0ubuntu1}>) of a...

benste (benste) wrote :

have the same error on two fresh installations,
my 12.04 which got upgraded from 11.10 runs fine with 1.4

jokker (david-las-solanas) wrote :
Download full text (23.9 KiB)

Hello,

Same thing here, I added the wine ppa and launched aptitude instal wine1.5, check this out:

sudo aptitude install wine1.5
The following NEW packages will be installed:
  fonts-droid{a} fonts-horai-umefont gettext{ab} gettext:i386{ab} gettext-base:i386{ab} gnome-exe-thumbnailer{a} icoutils{a} imagemagick{a} imagemagick-common{a} libcapi20-3{a} libcdt4{a}
  libgettextpo0{a} libgif4:i386{a} libgraph4{a} libgvc5{a} libilmbase6{a} libmagickcore4{a} libmagickcore4-extra{a} libmagickwand4{a} libmpg123-0{a} libnetpbm10{a} libopenexr6{a} libpam-winbind{a}
  libpathplan4{a} libunistring0{a} netpbm{a} ttf-droid{a} ttf-umefont{a} winbind{a} wine-gecko1.6{a} wine-gecko1.6:i386{a} wine1.5 wine1.5-amd64{a} wine1.5-i386:i386{a} winetricks{a}
0 packages upgraded, 35 newly installed, 0 to remove and 0 not upgraded.
Need to get 139 MB of archives. After unpacking 394 MB will be used.
The following packages have unmet dependencies:
 gettext-base : Conflicts: gettext-base:i386 but 0.18.1.1-5ubuntu3 is to be installed.
 gettext-base:i386 : Conflicts: gettext-base but 0.18.1.1-5ubuntu3 is installed.
 gettext : Conflicts: gettext:i386 but 0.18.1.1-5ubuntu3 is to be installed.
 gettext:i386 : Conflicts: gettext but 0.18.1.1-5ubuntu3 is to be installed.
Internal error: the solver Install(espeak:i386 1.46.02-0ubuntu1 <espeak-data:amd64 1.46.02-0ubuntu1 -S> {espeak:amd64 1.46.02-0ubuntu1 espeak:i386 1.46.02-0ubuntu1}>) of a supposedly unresolved dependency is already installed in step 121
Internal error: the solver Install(wine1.5:i386 1.5.9-0ubuntu2~pulse19+build1 <wine1.5-amd64:amd64 1.5.9-0ubuntu2~pulse19+build1 -> {wine1.5:amd64 1.5.9-0ubuntu2~pulse19+build1 wine1.5:i386 1.5.9-0ubuntu2~pulse19+build1}>) of a supposedly unresolved dependency is already installed in step 401
Internal error: the solver Install(wine1.4-i386:i386 1.4.1-0ubuntu1~precise1~ppa3 <wine1.4:amd64 1.4.1-0ubuntu1~precise1~ppa3 -> {wine1.4-i386:i386 1.4.1-0ubuntu1~precise1~ppa3}>) of a supposedly unresolved dependency is already installed in step 422
Internal error: the solver Install(espeak:i386 1.46.02-0ubuntu1 <espeak-data:amd64 1.46.02-0ubuntu1 -S> {espeak:amd64 1.46.02-0ubuntu1 espeak:i386 1.46.02-0ubuntu1}>) of a supposedly unresolved dependency is already installed in step 457
Internal error: the solver Install(wine1.4-i386:i386 1.4-0ubuntu4.1 <wine1.4:amd64 1.4-0ubuntu4.1 -> {wine1.4-i386:i386 1.4-0ubuntu4.1}>) of a supposedly unresolved dependency is already installed in step 469
Internal error: the solver Install(wine1.4-i386:i386 1.4-0ubuntu4 <wine1.4:amd64 1.4-0ubuntu4 -> {wine1.4-i386:i386 1.4-0ubuntu4}>) of a supposedly unresolved dependency is already installed in step 471
The following actions will resolve these dependencies:

       Remove the following packages:
1) bluez-alsa:i386
2) glib-networking:i386
3) gstreamer0.10-plugins-base:i386
4) gstreamer0.10-plugins-good:i386
5) gstreamer0.10-x:i386 ...

jokker (david-las-solanas) wrote :

oops duplicate... my bad !

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers