Ubuntu

Maximizing Spotify in Wine does not work with compiz enabled

Reported by Andris Sprūds on 2009-10-26
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Wine
Invalid
Low
compiz (Ubuntu)
Undecided
Thomas Thurman
wine1.2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: wine1.2

The Maximize button of the Spotify application window does not work in wine1.2. This button works just fine if I install the old wine (1.0.1-0ubuntu7). Altough this is a minor annoyance, this seems like a regression, which is not that good.

I am running Karmic Beta with all updates applied as of today (Oct 25, 2009).

Ubuntu version: 9.10
Wine: 1.1.31-0ubuntu2
Spotify: 0.3.21

Please let me know if I can help with additional information.

Scott Ritchie (scottritchie) wrote :

Unfortunately, regressions like this were always possible - it's why Wine 1.0 is still available.

So let's see if this is fixed in upstream Wine already: Add the ubuntu-wine PPA (https://edge.launchpad.net/~ubuntu-wine/+archive) and see if the issue remains.

Jack Leigh (leighman) wrote :

This is not fixed in 1.1.34.

There doesn't appear to be a bug at WineHQ.
Andris, any chance you could file one at http://bugs.winehq.org/?

Created an attachment (id=25169)
terminal output when clicking the maximise button

Clicking the maximise button just blinks the window, it does not maximise.

I can only reproduce this bug if visual effects (compiz) is enabled.

If this is a regression, please run a regression test:
http://wiki.winehq.org/RegressionTesting

It also happens in Xubuntu 9.10, wine 1.1.33 from Scott's PPA, with or without XFCE compositor.

Changed in wine:
status: Unknown → New

I can only reproduce this bug if visual effects (compiz) is enabled.

I tried the regression testing and got:

c9ef063e12d2c2ef7ef5ccafad525b3cd31ba61d is first bad commit
commit c9ef063e12d2c2ef7ef5ccafad525b3cd31ba61d
Author: Rob Shearman <email address hidden>
Date: Sat Jun 14 16:29:35 2008 +0100

    rpcrt4: Fix ndr_marshall tests to cope with using pointer ids instead of using pointer values.

    This fixes a number of test failures on XP SP3 and Win2003 upwards.

:040000 040000 8147fac233ddd140770f07abb9c60392954d1d7b 1dfdb96d360fda85db55ed9e33702006b4993a02 M dlls

Sorry if it's entirely useless.

It seemed to go at some point from not-maximising to covering the entire screen, which is not the desired behaviour so I ignored that.

(In reply to comment #5)

> Sorry if it's entirely useless.
>

I'm afraid it is. This commit didn't touch code, only tests. You probably should give it another try starting bisect again.

Thought so.
Lame lame lame

Andris, what kind of maximising behaviour does it show in 1.0.1?
Does it cover the panels?

Andris Sprūds (aspruds) wrote :

Sorry that it took so long to follow up on this. With the old Wine, maximize button expanded the window to full screen (that is, regular Ubuntu panels were not visible, only the Spotify window was).

Okay. According to the OP the maximising behaviour in Wine 1.0.1 covered the panels in Gnome, which I wouldn't really call desirable behaviour either, so I'm removing the regression tag.

Sounds like a Compiz bug, please report it there.

Closing invalid.

Changed in wine:
status: New → Invalid
Jack Leigh (leighman) on 2009-12-21
summary: - Maximize button does not work in Spotify, worked in old wine
+ Maximizing Spotify in Wine does not work with compiz enabled

This is not a compiz bug, it also happens without Compiz. See my previous comment.

(In reply to comment #11)
> This is not a compiz bug, it also happens without Compiz. See my previous
> comment.

See the bug summary.

Jack Leigh (leighman) on 2010-09-12
Changed in wine1.2 (Ubuntu):
status: New → Invalid
Changed in wine:
importance: Unknown → Low

*** Bug 22321 has been marked as a duplicate of this bug. ***

Changed in wine1.2 (Ubuntu):
status: Invalid → Confirmed
Changed in compiz (Ubuntu):
status: New → Confirmed
assignee: nobody → Thomas Thurman (marnanel)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.