Ubuntu

sound playback stops when a wine program is opened

Reported by Dave Gallenberger on 2010-02-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
wine (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: wine

I can't tell if this is an issue with pule audio or WINE.

I only have one program installed with wine, "verse perfect" it can be found here: http://mcgill-english-dictionary-of-rhyme-verse.software.informer.com/download/

The installation of "verse perfect" was fine, no sound issues then. As soon as I launched verse perfect through wine, my sound stops playback in rhythmbox, flash, system sounds, etc. I tried: [code]killall pulseaudio[/code] this did not help. When i reboot the machine my sound works fine again.

Also this bug is only with the 64 bit install of Ubuntu 9.10. I can not reproduce the problem on a 32 bit install of Ubuntu 9.10.

I am on Ubuntu 9.10, 64 bit
WINE version 1.0.1

ProblemType: Bug
Architecture: amd64
Date: Thu Feb 11 00:36:08 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: nvidia
Package: wine 1.0.1-0ubuntu8
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
SourcePackage: wine
Uname: Linux 2.6.31-17-generic x86_64

Dave Gallenberger (switch10) wrote :
benste (benste) wrote :

HI dave, did you try other audio options in winecfg

usually it is set to ALSA and full emulation - you might play around with those configs to see whether it helps.

Dave Gallenberger (switch10) wrote :

Thanks for the suggestion. I forgot about winecfg. I tried all the settings and combinations of settings in winecfg.

I ended up just disabling sound in wine. Since the one wine program that I use does not require sound. After a reboot, my sound stays on while using verse perfect.

Thanks for the help.

Dave

Thank you for posting this bug.

As per your post this problem is fixed. Marking as such.

Changed in wine (Ubuntu):
status: New → Fix Released
Jack Leigh (leighman) wrote :

'disabling sound' is not a fix!
admittedly sound is a difficult issue in wine at the moment.

Changed in wine (Ubuntu):
status: Fix Released → New

Dave Gallenberger & leighman thank you both for your contributions and helping to make Ubuntu better. I beg your pardon on my hasty action. The next step to addressing this issue is for a test of the sound to be conducted in the newest WINE, via our WINE Maintainer Scott Ritchie's PPA, found at https://launchpad.net/~ubuntu-wine/+archive/ppa

Jack Leigh (leighman) on 2010-10-07
tags: added: karmic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers