use wine-pulse for wine-packages

Bug #488981 reported by Serious on 2009-11-26
148
This bug affects 45 people
Affects Status Importance Assigned to Milestone
Wine
New
Undecided
Unassigned
wine (Debian)
New
Undecided
Unassigned
Nominated for Squeeze by Aigars Mahinovs
wine (Ubuntu)
Wishlist
Unassigned
Nominated for Lucid by Dag Odenhall

Bug Description

problem:
currently wine + pulseaudio is a pain in the a**, at least on my ubuntu box. the normal alsa-backend of wine eg. kills my other audio streams like music which in the case of banshee means I have to restart the app (as banshee only pauses but doesn't stop, but afaik rythmbox does the same). And no, padsp is not a real solution either imo.

solution:
patch wine with wine-pulse (http://art.ified.ca/?page_id=40) in the repositories and configure wine accordingly so it uses pulseaudio and not the alsa/oos/whatever emulation layers

pro:
- better sound experience with wine (for instance not getting your normal audio streams killed once you start wine)
- people without pulse should still be able to chose another sound backend afaik

contra:
- the wine-guys will complain that "as you use wine-pulse it is not supported" if you report a bug/problem (but well, they seem pretty unfriendly to me in general, so nothing new, really ;))

Vish (vish) wrote :

Thank you for bringing this bug to our attention. However, a paper cut should be a small usability issue, in the default Ubuntu 9.10 install, that affects many people and is quick and easy to fix. So this bug can't be addressed as part of this project.

- Wine is not part of the default install , hence not a papercut.
For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.

Don't worry though, this bug has been marked as "Invalid" only in the papercuts project.

This bug does not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers.
Kindly re-assign the bug to the package . You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage.

When reporting bugs in the future please use apport, either via the appropriate application's "Help -> Report a Problem" menu or using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in hundredpapercuts:
status: New → Invalid
Serious (cs071007) wrote :

thx for the reply.
I posted this as a papercut as there is a ready-made solution that just has to be applied and it would really help a lot of people (first thing when some classmate whines that he has probs with wine and sound is pointing them toward wine-pulse here and nobody has had probs with it until now). there is even a ppa from some guy (linked on the page) already so maybe you could work together or figure sthg out? :)

as about the package hint: can I change that somewhere? I can't find the option :(
also as wine per se doesn't have a menu that last paragraph is somewhat moot ;)

Vish (vish) on 2009-11-27
affects: hundredpapercuts → wine
Changed in wine:
status: Invalid → New
Kai Mast (kai-mast) wrote :

would like to see this too!

Eric Astor (eric-astor) wrote :

I understand that the Wine project has decided not to integrate the winepulse patchset due to various issues - some reputedly political, but the most cited one being that the Wine audio layer is now queued up for a full redesign. Apparently, a decision has been made to lean on OpenAL, to avoid the pain of building their own drivers every time. I think that's a great idea.

However, I'd very much like to see this patch applied as well. Until WineHQ gets a version of wine together that avoids the severe sound-skipping (Bug #371897) and other problems caused by the ALSA emulation layer, I see no reason why these patches (which cause no problems in any tests I've run) can't be applied in a distribution that defaults to PulseAudio.

I'm currently maintaining a version of Wine with the latest winepulse patches in my PPA at https://launchpad.net/~eric-astor/+archive/epastor - I try to keep it fully up-to-date with the latest Wine releases, and occasionally even manage to release a new version before it makes it into the WineHQ repositories. I'd welcome any users - and any help testing the package, to verify that the patch set doesn't cause any problems on other machines!

Radu Cristescu (radu.c) wrote :

ESounD emulation in PulseAudio seems to do the trick, using the ESounD driver that Wine already ships with.

Also, possible duplicate: #437749

Aigars Mahinovs (aigarius) wrote :

Wine-pulse backend has worked for me for almost a year now. I do not understand the reasoning for WineHQ not to include it. And especially I am baffled that Wine in Ubuntu does not have support for the default sound output system of Ubuntu.

Please update Wine before Lucid release to include PulseAudio support and use it by default. In my experience this solves all sound related problems that Wine has on Ubuntu systems.

Shimi Chen (shimi-chen) wrote :

ESounD emulation was removed from wine, so that workaround is not available anymore. Now theres just ALSA,OSS,JACK,NAS.

Thank you for posting this bug.

As per comments, this seems a wishlist bug and should be marked as such.

Jack Leigh (leighman) on 2010-10-07
Changed in wine (Ubuntu):
status: New → Opinion
importance: Undecided → Wishlist
Kai Mast (kai-mast) wrote :

Indeed its wishlist but it also solves a lot of glitches and bugs in Wine. In my opinion the Audio at the moment is a showstopper for it.

I really think this is not a "Opinion" but more a workaround until the new architecture based on OpenAL makes it into Wine. I don't see why adding this patch would cause any problems. It's already there and as long as people don't change their settings they don't get affected at all by it.

Keep in mind that this will just be another option for sound output and not a replacement for the ALSA backend. Ubuntu decided to move to PulseAudio but didn't offer any solutions for this over the last releases.

Jack Leigh (leighman) wrote :

I set it as 'Opinion' because it seems to exactly fit the definition of 'there’s a difference of opinion around this bug and people are free to continue the discussion, but the project or package maintainers need to move to other work and are considering the issue closed' since Scott has said he won't apply the patch.
It is a bit annoying that it removes it from the default bug search which perhaps prevents people from finding the solution so maybe 'Triaged' would be better.

Rune K. Svendsen (runeks) wrote :

I have put up a package in my PPA with Wine 1.3 with the most recent WinePulse patches (as of 2010-01-25) if there are people interested in testing:
https://launchpad.net/~runeks/+archive/winepulse/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers