Ubuntu

Wine related applications are in Lost & Found in K menu.

Reported by Rafael Belmonte on 2008-08-30
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
kde4libs (Ubuntu)
Undecided
Unassigned
wine (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: wine

Wine configuration tool and programs installed with wine appears in Lost & Found in K menu.
This is in KDE 4.1 on Intrepid Ibex.

Matt Neilson (ichthyoboy) wrote :

I can confirm this. This is a usability bug: ideally, the behavior of Wine and its installed programs should be the same between the GNOME and KDE menus.

Changed in wine:
status: New → Confirmed
SRElysian (srelysian) wrote :

I too can confirm this, no "Wine" menu. All Wine apps show in Lost & Found, including itself :/

SRElysian (srelysian) wrote :

I found a way to fix it... it turns out that while kde-applications.menu contains the mergedir option, kde4-applications does not, so, I fixed it like so:

> sudo nano /etc/xdg/menus/kde4-applications.menu

or if you are not a console jockey:

> alt-f2
> kdesudo kate /etc/xdg/menus/kde4-applications.menu

All the way at the bottom of the file you should find the item, <DefaultMergeDirs/>.

Directly below that add, <MergeDir>applications-merged</MergeDir>

so it should generally look like this:
....
       <Include>
                <And>
                        <Category>KDE</Category>
                        <Category>Core</Category>
                </And>
        </Include>
        <DefaultMergeDirs/>
        <MergeDir>applications-merged</MergeDir>
        <MergeFile>applications-kmenuedit.menu</MergeFile>
....

After saving you should pretty much immediately see the new "Wine" menu and sub menu's. Good luck.

ANDREA (andrea54) wrote :

SRElysian 's solution works very well - Wine shows up along with the whole menu. Congratulations!!! (by the way any idea how the rest of the Lost&Found stuff can get sorted? I have Amarok in there, for instance...)

Toni Helenius (toni-helenius) wrote :

It would be great if somebody uploaded this to updates. I mean, it doesn't broke anything and it's solved? Apparently the solution is valid? Usability and finishing of Ibex would rise easily. Very buggy release (not all Kubuntu's fault, but KDE's too) and even the smallest fix would be huge improvement...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kde4libs (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers