Ubuntu

Wine should install (some) fonts system wide in a separate package

Reported by Scott Ritchie on 2008-07-11
14
Affects Status Importance Assigned to Milestone
wine (Ubuntu)
Wishlist
Scott Ritchie

Bug Description

Binary package hint: wine

Wine should install some of its fonts system-wide, since they can be useful in other applications. This requires identifying the useful ones (tahoma.ttf for instance), as well as defoma scripts and splitting the additional fonts into separate ttf-foo packages.

Changed in wine:
assignee: nobody → scottritchie
importance: Undecided → Wishlist
status: New → Confirmed
Denis Moyogo Jacquerye (moyogo) wrote :

Two things could be wrong with that font

1. WineTahoma is a Bitstream Vera Sans derivative, it must have the same license.

See the copyright notice in the ttf file:
Copyright (c) 2004 Larry Snyder, Based on Bitstream Vera Sans Copyright (c) 2003 by Bitstream, Inc. Font renamed in accordance with former's license. Please do not contact Bitstream Inc. for any reason regaurding this font.

Yet the license is LGPL.

2. Some characters are poorly drawn, this could be really bad at some sizes but turns out fine for Wine's usage.
The Bitstream Vera Sans glyphs have been modified to look narrower and thus match Tahoma more. Some look really strange, as if only part of them add been condensed: '5', '6', '9', 'a', 'b', 'c', 'd', 'g', 'p'.

I'm not sure this offers much when compared with DejaVu Sans Condensed, except for having some bitmapped sizes.
The license issue should be fixed, regardless of this bug report.

Scott Ritchie (scottritchie) wrote :

The license is ok. See: http://www.gnome.org/fonts/#Final_Bitstream_Vera_Fonts

Basically, we're fine as long as the name doesn't contain Bitstream Vera.

Is DejaVu Sans what is substituted now when a website asks to render text with tahoma and it's unavailable?

Ansus (neptunia) wrote :

Thank you for posting this bug. Meny people prefere aliased fonts and for then choosing the Wine Tahoma would be the best choice (now they have to install msttfcore fonts and even with them they do not have good rendering).

Also msttfcore fonts have no free license and as such not allowed for distribution on the CD.

Besides this, many people have nostalgia for Windows and for them Wine Tahoma would be also the best choice.

Scott Ritchie (scottritchie) wrote :

I've started work on this. I believe the best way is to create a separate "ttf-tahoma-replacement" package containing tahoma.ttf and tahomabd.ttf. Just in case a user manually installs the real tahoma, I'm going to rename them tahoma-replacement.ttf and tahomabd-replacement.ttf, and then give them a font alias.

Changed in wine (Ubuntu):
status: Confirmed → In Progress
Scott Ritchie (scottritchie) wrote :

The ttf-tahoma-replacement pacakges and ttf-symbol-replacement pacakges are now part of the wine1.2 package in Karmic

Changed in wine (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers