Wine cannot run some games like CoD 4

Bug #247398 reported by Drk_Guy
8
Affects Status Importance Assigned to Milestone
Wine
Fix Released
Low
wine (Ubuntu)
Low
Unassigned

Bug Description

This is not a really serious bug, but it should be taken in account as the only way to fix it is to recompile, and that's something (IMHO) newbies shouldn't do...

A fix for this bug is attached.

Revision history for this message
In , Thesource-mail (thesource-mail) wrote :

Created an attachment (id=7448)
3dmark06 wine output

Revision history for this message
In , Vitaliy-bugzilla (vitaliy-bugzilla) wrote :

Have you enabled GLSL? Without it Wine reports 1.4 shaders only.
Other then that - duplicate.

*** This bug has been marked as a duplicate of 8597 ***

Revision history for this message
In , Vitaliy-bugzilla (vitaliy-bugzilla) wrote :

Closing duplicate.

Revision history for this message
In , Thesource-mail (thesource-mail) wrote :

Now I have GLSL enabled in registry but 3dmark still says pixel shader 2.0 is not supported.

Revision history for this message
In , Vitaliy-bugzilla (vitaliy-bugzilla) wrote :

What video card and drivers (full version)?

Revision history for this message
In , Thesource-mail (thesource-mail) wrote :

GeForce 8800 GTX, nvidia 100.14.19 drivers.

Revision history for this message
In , Hverbeet (hverbeet) wrote :

There are two issues here. The crash happens because HalGetBusData is unimplemented. You can work around that by setting the Windows version to Win98. The issue with caps is that 3DMark06 wants MaxSimultaneousTextures to be 8 and MaxPointSize to be 64.0f. On a typical nVidia card these are currently 4 and 63.75f.

Revision history for this message
In , Marco Trevisan (Treviño) (3v1n0) wrote :

I'm using a nvidia 8600M GT with same driver version, and I get the message about missing Pixel Shader 2.0 support...
Using Win98 settings, it started btw...

Revision history for this message
In , Greg87 (greg87) wrote :

Call of Duty 4 also wants MaxSimultaneousTextures = 8 ,so this time a real app.
We might consider, due to the high popularity of the game, this bug getting fixed before 1.0.
The question is what is the showstopper? wine or the drivers?

Revision history for this message
In , Dossjh (dossjh) wrote :

*** This bug has been confirmed by popular vote. ***

Revision history for this message
In , Vitaliy-bugzilla (vitaliy-bugzilla) wrote :

Created an attachment (id=13960)
Patch to fix MaxSimultaneousTextures

Googling around pointed to this possible solution. I have not tested it with actual app(s) just with a caps viewer. Not safe yet during the code freeze so attaching here.

Revision history for this message
In , Hverbeet (hverbeet) wrote :

That patch is not a proper fix. MaxSimultaneousTextures referes to the number of fixed function samplers a program can use, GL_MAX_TEXTURE_IMAGE_UNITS_ARB refers to the number of samplers a fragment shader can use. The issue here is that the nvidia drivers only expose a max of 4 sampler when using fixed function. The only way we can work around this is to write a replacement shader for fragment processing. This would require a decent amount of work, but should be doable.

Revision history for this message
In , uxeng (listmail) wrote :

I'm not implying that this is a proper fix either, but I don't see it mentioned here in the bug and I feel like its related to the bug.

BennyP had created an updated fix to an older 3dmark patch http://bugs.winehq.org/attachment.cgi?id=10811) which also originally fixed COD4 up until version 0.9.59.

I've used BennyP's update since 0.9.59 and through some of the 1.0rcX releases without issue. http://www.bennyp.org/wine/wine-0.9.59-3dmark.patch. I believe COD4 still gives "Error during initialization: Video card or driver doesn't support enough textures for the DirectX 9 code path." when the patch isn't applied.

Revision history for this message
In , uxeng (listmail) wrote :
Revision history for this message
Drk_Guy (drk-red) wrote :

This is not a really serious bug, but it should be taken in account as the only way to fix it is to recompile, and that's something (IMHO) newbies shouldn't do...

A fix for this bug is attached.

Revision history for this message
Drk_Guy (drk-red) wrote :
Revision history for this message
In , Vitaliy-bugzilla (vitaliy-bugzilla) wrote :

*** Bug 14457 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Bellegueulle-damien (bellegueulle-damien) wrote :

Good morning,

Patch not work with wine 1.1.2
Why not include the patch forever in wine ?

Thank you for your work.

Revision history for this message
In , uxeng (listmail) wrote :

Those patches are more so hardcoded hacks and comment #12 details what would be a proper fix. I am not sure if anyone has commenced work that would ultimately remedy the problem or not.

Revision history for this message
In , uxeng (listmail) wrote :

I'm trying to track down how is it that (at least as of wine-1.1.2-151-gc2c1a55) I did not apply the 3dmark patch yet and COD4 loaded up just fine. This is a new hardy heron install using the 177.13 drivers (for the 260/280 but with a 8800 GTS). I had to reinstall COD4 + 1.6 as well so I am certain that I have not applied the patch (let alone the fact that none exists for 1.1.2). It would be interesting to know if new code was put in wine to remedy this issue or is that some driver versions have changed perhaps for the better.

Revision history for this message
In , chourmovs (chourmovs) wrote :

If you can patch it, wine team can include it easily, it was a question fo time and priority
Anyway, it smells good for recent game support

Revision history for this message
In , uxeng (listmail) wrote :

just an update --
I've tested today's git wine-1.1.2-253-g9b57217 with Nvidia driver 173.14.12 on COD4 and the 3dmark hack wasn't required to run the game. The possibility exists that this issue is addressed for 3dmark as well (I don't run it) and that this bug could be closed.

Revision history for this message
In , uxeng (listmail) wrote :

problem non-existent in wine 1.1.3 as well (COD4 test). Can anyone comment on the original app, 3dmark06?

Revision history for this message
In , Kgbricola (kgbricola) wrote :

This isn't fixed for 3DMark06. Additionally not related to this bug, 3DMark06 crashes after the warning message.

Revision history for this message
Scott Ritchie (scottritchie) wrote :

The 3d Mark patch causes regressions in other applications and can't be included. However, when the bug is fixed properly upstream we'll definitely include it in Ubuntu. Thank you :)

Changed in wine:
importance: Undecided → Low
status: New → Triaged
Changed in wine:
status: Unknown → Confirmed
Revision history for this message
In , Jerome-gardou (jerome-gardou) wrote :

Created an attachment (id=17172)
Hack to round up the value of gl_info->max_pointsize

The only problem remaining to fix this bug is that the max point size is below 64 currently in wined3d.

Here is a hack to correct this.

Revision history for this message
In , Austin English (austinenglish) wrote :

Is this still an issue in current (1.1.21 or newer) wine?

Revision history for this message
In , Xnitropl (xnitropl) wrote :

Still an issue in current 1.1.22 Wine.

Revision history for this message
In , Austin English (austinenglish) wrote :

Is this still a problem in current (1.1.35 or newer) wine?

Revision history for this message
In , Wylda (wylda) wrote :

Still does not work. Retested under wine-1.1.35-364-g9dc584d, but does not run. Just says "...Pixel Shader 2.0 (or higher)..."

Graphics: nVidia 8600GT, driver v190.53

Revision history for this message
In , Austin English (austinenglish) wrote :

*** Bug 19007 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Wylda (wylda) wrote :

Still does not work. Retested under wine-1.1.39-163-g583f0f0, but does not run.
Just says "...Pixel Shader 2.0 (or higher)..."

Graphics: nVidia 8600GT, driver v190.53

Revision history for this message
In , Dan Kegel (dank) wrote :

Is this still an issue? Seems to work for me.

Revision history for this message
In , Kgbricola (kgbricola) wrote :

Still an issue with wine-1.1.43.

nvidia 8800GTS, driver 195.36.15

Revision history for this message
In , Dan Kegel (dank) wrote :

Whoops, I was mistaken. Still a problem here (nvidia GT 220, wine from git).

I'll attach a log.

Revision history for this message
In , Dan Kegel (dank) wrote :

Created an attachment (id=27404)
+seh,+d3d,+relay,+dialog,+text log; app complains that "Pixel Shader 2.0" is missing.

Revision history for this message
In , Wylda (wylda) wrote :

Subject states "crashes", but the crash does not have nothing to do with message "...Pixel Shader 2.0 (or higher)...". To bypass the crash, run

wine 3DMark06.exe --nosysteminfo

So the crash has something to do with getting HW info. With this command it stills complain about Shader2.0, but click OK and application continues.

So this should be separated into two bug reports.

Revision history for this message
In , Dan Kegel (dank) wrote :

Filed the systeminfo crash as bug 22392.

Passing -nosysteminfo (single dash!) bypasses it on 3dmark06 for me,
but not on 3dmark03 (which is strange, it's a widely mentioned option,
and the nosysteminfo string is in the exe). Perhaps they broke it in
the 2010 release of 3dmark03.

The only thing in the current free version of 3dmark06 that appears to
be enabled is the 'demo' button, and to get that to work, I have to
do 'winetricks d3dx9' to avoid the error dialog
"D3DXGetImageInfoFromFileInMemory failed: Invalid data (D3DXERR_INVALIDDATA)".
(winetricks d3dx9_36 isn't quite sufficient, it gets past that
dialog, but crashes shortly thereafter).

Revision history for this message
In , Dan Kegel (dank) wrote :

Filed the need for 3d3x9 as bug 22393.

So the only remaining part of this bug is that 3dmark06 reports we don't
have shader 2.0 support, right?

Revision history for this message
In , Dan Kegel (dank) wrote :

And as a consequence, it doesn't enable the "Run Benchmark" button.

On Vista, 6 of the benchmarks are selected, and you can press "Run Benchmark"
to start them. On Wine, 0 of the benchmarks are selected, and "Run Benchmark"
is disabled. (You can still run the demo, but that doesn't generate a
report. Even on the free version, running it on Windows lets you generate
and save a report to disk.)

Revision history for this message
In , Dan Kegel (dank) wrote :

Created an attachment (id=27642)
One-line patch from Henri against current git

Revision history for this message
In , Dan Kegel (dank) wrote :

I attached the minimal hack for current git (from Henri).

Revision history for this message
In , Zilforever (zilforever) wrote :

wine-1.2-rc2

3DMark05 Free Edition

wine 3DMark05.exe -nosysteminfo

'Your hardware does not support the features required to run 3DMark05. Pixel Shader 2.0 (or higher) is one of these.'

Revision history for this message
David Futcher (bobbo) wrote :

Patch has been rejected upstream due to it causing regressions in other areas. However, please feel free to submit any further patches, either here or upstream.

If any other patches are added, please remove the 'patch-rejected' tag.

Thanks!

tags: added: patch-rejected
Revision history for this message
In , Wylda (wylda) wrote :

Still present in wine-1.2-rc4.

Benchmark startup failure is caused by 3dmark's systeminfo component. This bug is about unrecognized PS, changing subject...

Revision history for this message
In , Francois Gouget (fgouget) wrote :

I'll just repeat what I heard from the experts (so don't ask me to explain). The reason for the 'No Pixel Shader 2.0' error would be that the NVidia proprietary driver reports the pixel size to be 63.75 instead of 64 as expected by 3DMark.

Note that the error also happens with the Intel driver which means this may be a general issue where OpenGL's and Direct3D's idea of where a pixel starts and stops differs.

Revision history for this message
In , Wylda (wylda) wrote :

Still present in wine-1.3.1-267-g7ab48e8.

Revision history for this message
In , rusivi2 (rusivi2-deactivatedaccount) wrote :

Does this occur in newest WINE?

Revision history for this message
In , Winehq-org (winehq-org) wrote :

(In reply to comment #44)
> Does this occur in newest WINE?

Yes. Present for the last three years, and not fixed since the last guy tested 2 weeks ago (tested w/today's git).

Revision history for this message
rusivi2 (rusivi2-deactivatedaccount) wrote :

Thank you for posting this bug.

This still occur in newest WINE?

Changed in wine:
importance: Unknown → Low
Revision history for this message
In , Francois Gouget (fgouget) wrote :

> Note that the error also happens with the Intel driver which means this
> may be a general issue where OpenGL's and Direct3D's idea of where a
> pixel starts and stops differs.

One more note about the issue on Intel: I tested this during WineConf on my EeePC 1000H which has a GMA 950 integrated graphics card. 3DMark06 works fine on windows XP getting a fantastic score of 57 ;-). In Wine/Linux I get the missing PS 2.0 error. By adding a trace I noticed that MaxPointSize was 255.0! So that may be part of the issue. 'glxinfo -l' gives me:

    GL_ALIASED_POINT_SIZE_RANGE = 1, 255
    GL_SMOOTH_POINT_SIZE_RANGE = 1, 3

If told how to do so, I can check what value I get on Windows XP (3DMark itself does not provide this information).

I then applied the hack that hardcodes MaxPointSize to 64.0. However 3DMark06 still complained about the lack of pixel shader 2.0 support. So there's probably another issue.

The uptake is that we now have a second group we can ask to figure out what's up with the point sizes.

Revision history for this message
In , Francois Gouget (fgouget) wrote :

Some more data:
 * I ran the DirectX Caps Viewer (http://msdn.microsoft.com/en-us/library/ee417852%28VS.85%29.aspx) on Windows and in 'Mobile Intel(R) 945 Express Chipset Family\D3D Device Types' I got the following information:
   HAL\Caps: MaxPointSize = 256
   Reference\Caps: MaxPointSize = 64

 * I also ran the OpenGL Extensions Viewer (http://www.realtech-vr.com/glview/download.html) on Windows which showed:
   Point size range: 0.5 to 1.0
   Smoothed point size range: 1 to 256

So the DirectX capability matches the OpenGL one, but the Windows max point size is a bit different from what it is on Linux.

Revision history for this message
In , Wylda (wylda) wrote :

Still present in wine-1.3.22-255-g4c0c0d3.

Revision history for this message
In , Ycarus (ycarus) wrote :

Still present in 1.4-rc2

Revision history for this message
Scott Ritchie (scottritchie) wrote :

I believe this is largely solved upstream, but regardless future patches will need to go directly there anyway.

Changed in wine (Ubuntu):
status: Triaged → Won't Fix
Revision history for this message
In , Wylda (wylda) wrote :

Still present in wine-1.5.3-164-gdec3d50.

Revision history for this message
In , Patrick1804 (patrick1804) wrote :

I have no problems to run 3DMark05 / 3dMark06 using wine 3DMark05.exe -nosysteminfo. PS version 3.0 is detected. All tests are running.

Without -nosysteminfo an error message is shown, and 3DMark0x quits.

direct rendering: Yes
server glx vendor string: ATI
server glx version string: 1.4
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 4800 Series
OpenGL version string: 3.3.11005 Compatibility Profile Context
OpenGL shading language version string: 3.30

MaxSimultaneousTextures is 8192
MaxPointSize is 8192

wine 1.5.9

maybe this is a vendor specific problem not related to wine ?

Revision history for this message
In , T-artem (t-artem) wrote :

(In reply to comment #51)
> I have no problems to run 3DMark05 / 3dMark06 using wine 3DMark05.exe
> -nosysteminfo. PS version 3.0 is detected. All tests are running.
>
> Without -nosysteminfo an error message is shown, and 3DMark0x quits.
>
> direct rendering: Yes
> server glx vendor string: ATI
> server glx version string: 1.4
> OpenGL vendor string: ATI Technologies Inc.
> OpenGL renderer string: ATI Radeon HD 4800 Series
> OpenGL version string: 3.3.11005 Compatibility Profile Context
> OpenGL shading language version string: 3.30
>
> MaxSimultaneousTextures is 8192
> MaxPointSize is 8192
>
> wine 1.5.9
>
> maybe this is a vendor specific problem not related to wine ?

I cannot reproduce your positive results with proprietary NVIDIA drivers which support OpenGL 3.2, thus I'm inclined to delete your AppDB results as knowingly false.

OpenGL renderer string: GeForce 8800 GT/PCIe/SSE2
OpenGL version string: 3.3.0 NVIDIA 304.22
OpenGL shading language version string: 3.30 NVIDIA via Cg compiler

The 3DMark 2005 in my case says: "Your hardware does not support the features required to run 3DMark05. Pixel Shader 2.0 (or higher) is one of these..."

Out of the box Wine is written with proprietary NVIDIA drivers in mind so it's a very strange fluke on your side that the 3DMark 2005 works for you.

Can you post a screenshot of the main 3DMark 2005 window on, say, http://imageshack.us/ ?

Revision history for this message
In , Patrick1804 (patrick1804) wrote :
Revision history for this message
In , T-artem (t-artem) wrote :

(In reply to comment #53)
> I attached two pictures, made using virtual desktop:
> https://imageshack.us/photo/my-images/841/3dmark05main.png/
> https://imageshack.us/photo/my-images/215/3dmark05screen.png/

Can you please also post the following file

WINEDEBUG=+d3d,+d3d9,+d3d_shader,+d3d_caps,+d3d_draw,+d3dx wine 3DMark05.exe -nosysteminfo &> /tmp/3dmark05d3d9.log

And the last question, make sure you are installing 3DMark05 into a *fresh* wine prefix (delete or move ~/.wine into another location or use `export WINEPREFIX="/home/$USER/.wine.test"`)

Revision history for this message
In , Patrick1804 (patrick1804) wrote :

Created attachment 41056
+d3d,+d3d9,+d3d_shader,+d3d_caps,+d3d_draw,+d3dx wine 3DMark05.exe -nosysteminfo first 700k lines

Revision history for this message
In , Hverbeet (hverbeet) wrote :

(In reply to comment #51)
> maybe this is a vendor specific problem not related to wine ?
Mostly, yes. There's a small chance we're interpreting the point size limits wrongly in some way though.

(In reply to comment #52)
> Out of the box Wine is written with proprietary NVIDIA drivers in mind so it's
That's just not true.

Revision history for this message
In , T-artem (t-artem) wrote :

(In reply to comment #56)
> (In reply to comment #52)
> > Out of the box Wine is written with proprietary NVIDIA drivers in mind so it's
> That's just not true.

It was true just a few years ago, when Intel had absolutely awful drivers, and ATI drivers barely worked.

Even nowadays NVIDIA proprietary drivers for Linux are far superior to anything else available on the platform.

Revision history for this message
In , Austin English (austinenglish) wrote :

(In reply to comment #57)
> (In reply to comment #56)
> > (In reply to comment #52)
> > > Out of the box Wine is written with proprietary NVIDIA drivers in mind so it's
> > That's just not true.
>
> It was true just a few years ago, when Intel had absolutely awful drivers, and
> ATI drivers barely worked.
>
> Even nowadays NVIDIA proprietary drivers for Linux are far superior to anything
> else available on the platform.

That doesn't mean that Wine is written specifically for NVIDIA's drivers. Mesa's r600g drivers also works well with Wine, and likely others.

Revision history for this message
In , T-artem (t-artem) wrote :

For NVIDIA binary drivers the issue is still relevant as for wine 1.5.30 :-(

Revision history for this message
In , T-artem (t-artem) wrote :

Created attachment 44471
"Invalid shaders" on NVIDIA binary drivers

It looks like it's not just a warning message.

When you manually select all the tests in 3DMark06 (you need a valid license key for the professional version) and run it you get this error message:

(see the attached screenshot).

So, it's not a "minor" bug report. Something is indeed broken in terms of shaders support.

Revision history for this message
In , T-artem (t-artem) wrote :

This is what I see in console:

fixme:win:EnumDisplayDevicesW ((null),0,0x32d2e8,0x00000000), stub!
fixme:hlsl_parser:hlsl_parse Check for valued return on void function.
fixme:hlsl_parser:hlsl_parse Implicit conversion to the return type if needed, error out if conversion not possible.
err:d3dcompiler:compile_shader HLSL shader parsing failed.

P.S. The previous error message in text:

"C:\Program Files\Futuremark\3dMark06\data\timeline\loading\proxycon_in.txt:
D3DXCompileShader failed: Invalid data (D3DXERR_INVALIDDATA)"

Revision history for this message
In , Matteo-mystral (matteo-mystral) wrote :

(In reply to comment #61)
> This is what I see in console:
>
> fixme:win:EnumDisplayDevicesW ((null),0,0x32d2e8,0x00000000), stub!
> fixme:hlsl_parser:hlsl_parse Check for valued return on void function.
> fixme:hlsl_parser:hlsl_parse Implicit conversion to the return type if needed,
> error out if conversion not possible.
> err:d3dcompiler:compile_shader HLSL shader parsing failed.
>
> P.S. The previous error message in text:
>
> "C:\Program Files\Futuremark\3dMark06\data\timeline\loading\proxycon_in.txt:
> D3DXCompileShader failed: Invalid data (D3DXERR_INVALIDDATA)"

That's a separate issue, you can open a new bug report for that if you want (and installing native d3dcompiler e.g. via "winetricks d3dx9_36" should workaround it).

Revision history for this message
In , T-artem (t-artem) wrote :

(In reply to comment #62)
>
> That's a separate issue, you can open a new bug report for that if you want
> (and installing native d3dcompiler e.g. via "winetricks d3dx9_36" should
> workaround it).

It doesn't make a lot of sense until this bug report is not fixed.

Revision history for this message
In , apemax (apemax) wrote :

This is still a issues with the latest stable wine release 1.6. I get this error at startup:

https://lh5.googleusercontent.com/-MwdG8FlOd8k/Uf-qbx-2wBI/AAAAAAAABQo/5uVa4ck38HY/s800/3DMark-error.png

And the output from the terminal:

fixme:win:EnumDisplayDevicesW ((null),0,0x32f208,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f1e8,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f1e8,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32ef38,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32ef38,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f1e8,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f1e8,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f1e8,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f1e8,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f468,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f468,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f1b8,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f1b8,0x00000000), stub!
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 20000
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 20000
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 20000
fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_DATA_RECEIVE_TIMEOUT (20000): STUB
err:ole:CoInitializeEx Attempt to change threading model of this apartment from apartment threaded to multi-threaded
fixme:ole:CoInitializeSecurity ((nil),-1,(nil),(nil),2,3,(nil),0,(nil)) - stub!
err:ole:CoUninitialize Mismatched CoUninitialize

When you click on any of the options this box pops up:

https://lh3.googleusercontent.com/-I7rS_zgaeHY/Uf-rx6I8BDI/AAAAAAAABRM/tNynbBUCvjI/s800/3DMark-popup1.png

and then both windows go away again. The demo option will run fine however.

If you need any more info just ask.

Revision history for this message
In , T-artem (t-artem) wrote :

Created attachment 45530
kludx 2.0.0.51

Can anyone who doesn't experience this 3DMark06 bug, post kludx screenshots of the Pixel Shader and Vertex Shader tabs?

Revision history for this message
In , Bruno Gonçalves de Jesus (00cpxxx) wrote :

Instead of attaching the program I think a link to http://www.kludx.com/kludx.php would be more appropriate.

Revision history for this message
In , T-artem (t-artem) wrote :

(In reply to comment #66)
> Instead of attaching the program I think a link to
> http://www.kludx.com/kludx.php would be more appropriate.

This program is freeware and taking into consideration that its website hasn't been updated for 5 years already I guess it won't hurt to have it here, since the original website can easily disappear given the lack of interest from its authors/developers.

Revision history for this message
In , Dan Kegel (dank) wrote :

Our standard practice is to post the sha1sum:
fe9afdbe18e0e4af2fa96c2e6927c09a11b6460f kludx_2_0_0_51.zip
so you can google for the binary and verify the download you get is
identical.

Revision history for this message
In , Austin English (austinenglish) wrote :

The content of attachment 45530 has been deleted by
    Austin English <email address hidden>
who provided the following reason:

copyrighted file

The token used to delete this attachment was generated at 2013-08-07 12:43:47 CDT.

Revision history for this message
In , Zilforever (zilforever) wrote :

wine 1.6
Nvidia drivers 310.14 560Ti
Ubuntu 12.04 64bit
and still got popup with no support of Pixel Shader 2
Kludx says pixel and shader version 3

Revision history for this message
In , T-artem (t-artem) wrote :

Created attachment 45979
3DMark06/Wine 1.7.1

Wine 1.7.1, NVIDIA GTX 660, binary drivers:

3DMark06 no longer whines about missing shaders 2.0 support and shows all tests as available, but when you try to run it, it gives this error:

C:\Program Files\Futuremark\3DMark06\data\timeline\loading\proxycon_in.txt:
D3DXCompileShader failed: Invalid data (D3DXERR_INVALIDDATA)

Revision history for this message
In , T-artem (t-artem) wrote :

Other tests fail too.

In console I have this:

fixme:win:EnumDisplayDevicesW ((null),0,0x32d2c8,0x00000000), stub!
fixme:hlsl_parser:hlsl_parse Check for valued return on void function.
fixme:hlsl_parser:hlsl_parse Implicit conversion to the return type if needed, error out if conversion not possible.
err:d3dcompiler:compile_shader HLSL shader parsing failed.

It seems like shaders compilation support in Wine is incomplete.

So, this bug can be safely closed then.

With native d3dx9_36.dll 3DMark06 crashes, it's gonna be a new bug.

Revision history for this message
In , Wylda (wylda) wrote :

>
> 3DMark06 no longer whines about missing shaders 2.0 support...

I can't confirm that. I still see the problem even in wine-1.7.11 NVIDIA binary.

Revision history for this message
In , Jarkko Korpi (jarkko-korpi-t) wrote :

I tried the 3dmark with 1.7.17 and I thought it crashed, I was looking for console output and suddenly it just opened a dialog (there was around 30s-1min delay), but trying to run the benchmark gives an error

http://bugs.winehq.org/attachment.cgi?id=45979

already mentioned here.

I rerun the program and it felt that the delay was a lot faster.

I don't see it complaining about pixel shaders.

ati 7870, 14.3beta here.

I would say it's fixed for me.

Revision history for this message
In , T-artem (t-artem) wrote :

(In reply to Wylda from comment #73)
> >
> > 3DMark06 no longer whines about missing shaders 2.0 support...
>
> I can't confirm that. I still see the problem even in wine-1.7.11 NVIDIA
> binary.

What's your GPU? Have you tried the latest NVIDIA drivers?

Revision history for this message
In , Jarkko Korpi (jarkko-korpi-t) wrote :

I want to add that I went into appdb, searched 3dmark06 and saw that you should override 2 files, dx9_something_36 and something_28.

Don't remember the exact names. And also use -nosysteminfo parameter.

Well I overrun those files, but I didnt use nosysteminfo parameter and I could succefully run hole 3dmark test.

The fps was maximum 40-50, lowest around 10 when using gpu tests.

I couldnt upload the result into 3dmark server...

But it feels that this program isnt far from working exactly like it should.

Revision history for this message
In , T-artem (t-artem) wrote :

(In reply to Jarkko K from comment #76)
>
> I couldn't upload the result into 3dmark server...
>

In order to submit results 3DMark needs to know your system characteristics using systeminfo.

However the systeminfo part of 3DMark 06 doesn't work under Wine because it tries to load and use a low level device driver which polls the system. I guess this kind of functionality will never be supported in Wine (such Windows drivers poll various PCI registers and read different RAM regions directly and in every OS under the sun such an examination requires superuser privileges).

Revision history for this message
In , Hanska2 (hanska2) wrote :

I installed 3dmark06 and tried to run it, it feels to get stuck on 1st run. Second run goes into the program.

Then I tried to run it without dll overrides and I saw it complaning about shaders.

Installed 1st the other dll and then the other which are mentioned wine database.

After those overrides I couldnt get the 3dmark run at all.

Can you confirm?

But I don't see that pixelshader error which some are seeing.

wine 1.7.22

Revision history for this message
In , Wylda (wylda) wrote :

> (In reply to Wylda from comment #73)
> > >
> > > 3DMark06 no longer whines about missing shaders 2.0 support...
> >
> > I can't confirm that. I still see the problem even in wine-1.7.11 NVIDIA
> > binary.
>
> What's your GPU? Have you tried the latest NVIDIA drivers?

Sorry Artem, i miss that. Well i no longer see that "Pixel Shader 2.0" pop-up anymore. Tested under wine-1.7.46-193-g8b566b1. But it's true, that i'm also running newer Nvidia binary: v340.65

It is also few times confirmed, that 3DMark06 no longer whines about missing shaders 2.0 support... Also this is bug report is already mixture of different probles. So let's close this and if anyone is affected, then open a new bug.

Revision history for this message
In , Alexandre Julliard (julliard) wrote :

Closing bugs fixed in 1.7.47.

Changed in wine:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.