Ubuntu

Regression: Lots of non ISO-8859-1 glyphs (Cyrillic, Lithuanian, etc. letters) are missing in built-in Tahoma font

Reported by Mantas Kriaučiūnas on 2008-02-02
4
Affects Status Importance Assigned to Milestone
Wine
Fix Released
Medium
wine (Baltix)
Undecided
Unassigned
wine (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: wine

There is important regression in Ubuntu Hardy (8.04) wine packages - lots of non ISO-8859-1 glyphs (Cyrillic, Lithuanian, etc. letters) are missing in built-in Tahoma font.
This causes displaying "::::::" instead of these letters in lots of applications, which uses Tahoma font (almost all installers uses this font).

This bug is known by upstream - look at http://bugs.winehq.org/show_bug.cgi?id=10025 , but it seems they don't have resources to fix this bug quickly.

I'm reporting this bug in Ubuntu, because Ubuntu is used by lots of people in various languages and this bug should be fixed before Ubuntu 8.04 LTS will be released.

There is a quick fix (workaround) for this bug - we should remove built-in tahoma font (it was included since wine 0.9.47) from wine package, then wine will use system fonts as replacement and these fonts has needed characters in most cases (because admin usually installs fonts, needed for users).

Another solution would be to use fonts from DejaVu project (http://dejavu.sf.net , most of them are already included in Ubuntu) - DejaVu fonts already has all symbols for most popular languages.

Changed in wine:
status: Unknown → Confirmed
Scott Ritchie (scottritchie) wrote :

Without a built in Tahoma font Wine will actually use no font at all - that's why steam was generating blank characters until people installed a (copied from Windows) Tahoma by hand. All removing Tahoma would do is break things for people who use Fonts that the built-in Tahoma has glyphs for.

On that note, Wine's Tahoma now has cyrillic glyphs, but it still needs Lithuanian, Greek, and probably a few others. See the upstream bug.

I'll probably post an email to ubuntu-devel-discuss asking for help with this.

Changed in wine:
status: New → Confirmed
Changed in wine:
status: Confirmed → Fix Released
Scott Ritchie (scottritchie) wrote :

Lithuanian glyphs are now also added upstream, although they won't come out until 0.9.59, which should be in time for Hardy. Are there any others still missing?

Stephan Adig (sadig) wrote :

I added the lithuanian glyphs to 0.9.58 now (when 0.9.59 won't make it to hardy anymore, this could happen because on the 10th april is hard freeze...and wine 0.9.59 will come on the 11th).

What's still missing? or can I "fix release" this bug now?

regards,

Stephan Adig (sadig) wrote :

wine is uploaded with the lithunian glyphs....
please reopen a new bug for other missing things

Changed in wine:
status: Confirmed → Fix Released
Changed in wine:
status: Fix Released → Confirmed
Changed in wine:
status: Confirmed → Fix Released
Changed in wine (Baltix):
status: New → Fix Released
Changed in wine:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.