package libwine-dev (not installed) failed to install/upgrade: trying to overwrite '/usr/lib/x86_64-linux-gnu/wine/libaclui.def', which is also in package wine1.8-amd64 1:1.8.6-0ubuntu1~17.04~ricotz1

Bug #1665573 reported by Leslie Jones on 2017-02-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
Undecided
Unassigned
wine (Ubuntu)
Undecided
Unassigned

Bug Description

The software center crashed and disappeared. I installed a new software center using synaptic package manager. I did not encounter any problems or bugs until I installed wine from the original software center. I am using ubuntu 17.04. It is a beautiful program to run a mini pc.

ProblemType: Package
DistroRelease: Ubuntu 17.04
Package: libwine-dev (not installed)
ProcVersionSignature: Ubuntu 4.9.0-11.12+IntelAtom-linuxium 4.9.0
Uname: Linux 4.9.0-11-linuxium x86_64
ApportVersion: 2.20.4-0ubuntu2
Architecture: amd64
Date: Fri Feb 17 00:18:38 2017
DuplicateSignature:
 package:libwine-dev:(not installed)
 Unpacking wine1.8 (1:1.8.6-0ubuntu1~17.04~ricotz1) ...
 dpkg: error processing archive /tmp/apt-dpkg-install-ggz2Nz/16-wine1.8_1%3a1.8.6-0ubuntu1~17.04~ricotz1_amd64.deb (--unpack):
  trying to overwrite '/usr/share/wine/fonts/coue1255.fon', which is also in package fonts-wine 1.8.6-3ubuntu2
ErrorMessage: trying to overwrite '/usr/lib/x86_64-linux-gnu/wine/libaclui.def', which is also in package wine1.8-amd64 1:1.8.6-0ubuntu1~17.04~ricotz1
InstallationDate: Installed on 2017-02-16 (0 days ago)
InstallationMedia: Ubuntu 17.04 "Zesty Zapus" Linuxium - Alpha Intel Atom (20161213)
RelatedPackageVersions:
 dpkg 1.18.10ubuntu1
 apt 1.4~beta4ubuntu1
SourcePackage: wine
Title: package libwine-dev (not installed) failed to install/upgrade: trying to overwrite '/usr/lib/x86_64-linux-gnu/wine/libaclui.def', which is also in package wine1.8-amd64 1:1.8.6-0ubuntu1~17.04~ricotz1
UpgradeStatus: No upgrade log present (probably fresh install)

Leslie Jones (lesjoneslitspec) wrote :
tags: removed: need-duplicate-check
jre (jre-phoenix) wrote :

GNOME Software Center should not crash because of an packaging error, therefore marking it as affected by this bug.

Background:
You already have Wine from the Ubuntu repositories installed (at least the (sub-)package fonts-wine which is used by the package suites src:wine and src:wine-development).

Now you're trying to install wine1.8 (1:1.8.6-0ubuntu1~17.04~ricotz1) from a PPA. This results in a file conflict, which is unfortunately not handled by an "Conflicts" in the packaging.

-> Please tell the maintainer of above PPA to at least add the "Conflicts: fonts-wine" to the packaging.

One might add a reverse conflicts also to the Wine packages in the packages in the Ubuntu repository, but imo we can't reasonably consider what single PPAs do. Personally I'd say this bug is "invalid" for wine (Ubuntu).

To clean up the situation for you I propose to uninstall all Wine packages from your system, and then start fresh again by installing only one version (only if you go for the packages in the Ubuntu repository you may coinstall two suites: src:wine and src:wine-development).

Graham Inggs (ginggs) on 2017-03-22
Changed in wine (Ubuntu):
status: New → Invalid
Robert Ancell (robert-ancell) wrote :

As noted the problem was caused by using a PPA. The GNOME Software crash will be better handled in errors.ubuntu.com. Thanks for your report.

Changed in gnome-software (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers