wine1.6 shows up as "Notepad" in Software Updater

Bug #1205390 reported by Matthew Paul Thomas on 2013-07-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
wine (Ubuntu)
Low
Scott Ritchie

Bug Description

As shown in <http://i.imgur.com/bNvoxql.png>, the wine1.6 package gets the name "Notepad".

It does contain Notepad, but that's not usually what you're interested in when seeing it.

This could be fixed in several ways.

Probably the most elegant would be add something to the wine1.6 package to tell the app-install-data-ubuntu script to ignore the Notepad .desktop file.

Alternatively, add a special case to the app-install-data-ubuntu script directly.

Or, add a "WINE Windows Compatibility Layer" .desktop file to the wine1.6 package, that gets prioritized over the Notepad one somehow.

[Originally reported in <http://www.reddit.com/r/Ubuntu/comments/1j35xa/can_we_please_fix_updates/>.]

tags: added: metadata
Jeremy Bicha (jbicha) wrote :

Or set notepad's .desktop to
NoDisplay=true;

How often do people consciously want to use notepad.exe over gedit?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in app-install-data-ubuntu (Ubuntu):
status: New → Confirmed
Changed in wine (Ubuntu):
status: New → Confirmed
Adolfo Jayme (fitojb) on 2013-07-28
Changed in wine (Ubuntu):
importance: Undecided → Low
Changed in wine (Ubuntu):
assignee: nobody → Scott Ritchie (scottritchie)
no longer affects: app-install-data-ubuntu (Ubuntu)
jre (jre-phoenix) wrote :

src:wine 1.8.6-3 and src:wine-developmentless 2.0~rc5-2 should fix this. They now provide AppStream metainfo.
Further these packages don't ship notepad.desktop.

Changed in wine (Ubuntu):
status: Confirmed → Fix Committed
jre (jre-phoenix) wrote :

This bug was fixed in the package wine - 1.8.6-3ubuntu1

---------------
wine (1.8.6-3ubuntu1) zesty; urgency=medium

  * Merge with Debian (LP: #1571816). Remaining changes:
    - Use unversioned sonames in debian/scripts/sonames2elf
      so that dpkg-shlibdeps can find libGL.so in Ubuntu (closes: #827770).
    - Rename package wine to wine-stable. Needed for the transition to a
      0-epoch in the version number.
      Necessary until after the transition is complete (18.04).

wine (1.8.6-3) unstable; urgency=medium

  * Fix AppStream metainfo file (closes: #848839).

wine (1.8.6-2) unstable; urgency=medium

  [ Jens Reyer ]
  * Cherrypick changes from master:
    - Reorganize patches and add some metadata.
    - Drop shlib-exit-calls.patch.
    - Drop openal.patch, fixed upstream.
    - Simplify the foreign-arch test in the wine script.
    - Let wine suggest winbind.
    - Change trigger interest to noawait (LP: 1652434).
    - Documentation updates.
    - Blacklist some extensions for native file type association
      (closes: #845334).
  * Sort packages in debian/control.in.
  * Drop obsolete entries from d/clean.
  * Check for invalid WINEARCH values (closes: #838474).
  * Generate and install wine.svg icon.
  * Add initial AppStream metainfo file (closes: #848839).

 -- Jeremy Bicha <email address hidden> Mon, 23 Jan 2017 16:43:02 -0500

Changed in wine (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers