Ubuntu

Please add window reordering to window-picker-applet

Reported by Andrew Kerr on 2009-04-07
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
window-picker-applet
Wishlist
Lanoxx
window-picker-applet (Ubuntu)
Wishlist
Unassigned

Bug Description

The Gnome Window List allows dragging and dropping windows to reorder them in the list - this would be a nice feature for window-picker-applet.

Neil J. Patel (njpatel) on 2009-04-07
Changed in window-picker-applet:
importance: Undecided → Wishlist
milestone: none → 2.0
status: New → Confirmed
Paul Larson (pwlars) wrote :

Bug has been moved to Ubuntu distribution

Changed in window-picker-applet (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Changed in window-picker-applet:
status: Confirmed → Won't Fix
Paul Larson (pwlars) on 2009-05-27
tags: added: ubuntu-unr
Paul Larson (pwlars) on 2009-09-22
Changed in window-picker-applet:
status: Won't Fix → Triaged
Changed in window-picker-applet (Ubuntu):
status: Confirmed → Triaged
Chuck Money (chuckdmoney) wrote :

I really like this idea. As it is I am constantly having to close and reopen Firefox/Thunderbird to keep the icons in the order I'm used to because every time I click a link in Thunderbird or Pidgin it moves Firefox to the far right of my open windows! Any idea when this will be done? Maybe even an unofficial patch I can test to get this done sooner? I only code PHP but I'm happy to play lab rat on this one if anyone has a potential fix to try.

mr. Ed (mred) wrote :

this is a good idea

Lanoxx (lanoxx) wrote :

I have ported window-picker-applet to gtk+3 and added window reordering. The code is currently in my repository on github:

Window reordering is currently in the dragdrop branch it has some minor issues but so far its quite stable and can be used:
https://github.com/lanoxx/window-picker-applet/tree/dragdrop

A more stable version without window reordering is also in the master branch

I have tested this on oneiric and precise, so if anyone is still interested in this just have a look at the repository

Lanoxx (lanoxx) wrote :

Fix is in version 0.6.99 on my github repo: https://github.com/lanoxx/window-picker-applet/commits/master

Changed in window-picker-applet (Ubuntu):
status: Triaged → Fix Committed
Changed in window-picker-applet:
assignee: nobody → Lanoxx (lanoxx)
status: Triaged → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers