Windows cannot be minimized and un-minimized by clicking their entry in the applet.

Bug #288812 reported by ethana2 on 2008-10-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
window-picker-applet
Undecided
Neil J. Patel
window-picker-applet (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: window-picker-applet

http://i34.tinypic.com/24lsy38.png

Unlike with the window list applet, the window picker applet does not currently allow the user to minimize the window currently in focus by clicking its entry in the applet. This may be due to the fact that this applet was originally designed for netbooks, or just that it's still under heavy development and isn't complete yet. In any case, I'm left to use alt-F9 until this is resolved.

While I'm here I'd like to suck up to and encourage the window-picker-applet developers. You have developed something amazing. This is the first approach to the desktop I've seen that surpasses that of OSX with innovation. Keep up the amazing work.

I don't know if this can get into Ubuntu 8.10 with feature freeze and all, but I was using this applet with PPAs with 8.04.1 for quite some time, and I can certainly do that again. Please let me know if/when I should add ubuntu netbook PPAs to my 8.10 sources list.

James Westby (james-w) on 2008-10-24
Changed in window-picker-applet:
importance: Undecided → Wishlist
status: New → Triaged
ethana2 (ethana2) wrote :

James marked this wishlist bug as also affecting netbook-remix. While this behavior could be verified on netbook remix, said ubuntu derivative ships with maximus and this bug is going to be irrelevant to its usage.

I tried maximus for a while, but the DarkHuman theme allows for this more elegant solution. Maximus may have worked better as a metacity modification than as a daemon, but I'll digress as that's not what this bug is about.

I hope there's a version of Human soon that has decent looking grab ('title') bars.

On Fri, 2008-10-24 at 18:22 +0000, ethana2 wrote:
> James marked this wishlist bug as also affecting netbook-remix. While
> this behavior could be verified on netbook remix, said ubuntu derivative
> ships with maximus and this bug is going to be irrelevant to its usage.

I added the project as that is the project where bugs in
window-list-applet are tracked, and so the right people will see it.

Thanks,

James

ethana2 (ethana2) wrote :

Ah, ok, sweet.

Thanks, James.

Neil J. Patel (njpatel) wrote :

window-picker-applet (0.4.5) hardy; urgency=low

  * Windows cannot be minimized and un-minimized by clicking their entry in the
    applet. (LP: #288812)
    - If window is already active, clicking on it will minimise it.

 -- Neil J. Patel <email address hidden> Tue, 28 Oct 2008 15:54:46 +0000

Changed in netbook-remix:
assignee: nobody → njpatel
milestone: none → 1.0.1
status: New → Fix Committed
ethana2 (ethana2) wrote :

Quick questions:
Will this applet be automatically updated to 1.0.1 on 8.10 installs,
and what is the general ETA of the 1.0.1 release?

Pete Goodall (pgoodall) wrote :

The 1.0.1 milestone is actually for Ubuntu Netbook Remix distributed on a device, such as the Slyvania Meso G or the Toshiba NB100. The Ubuntu Netbook Remix project actually encompasses a number of components, including ume-launcher (renamed to netbook-launcher in 8.10), window-picker-applet, go-home-applet and maximus.

As has been noted in other bugs, the majority of the work on the UNR components is done on 8.04. The move to 8.10 was a significant amount of work because of a new version of Clutter (the toolkit which ume-launcher uses). That being said, we hope to at least update the packages in the PPA to the latest code, and get the updates into 8.10 proper if we can. If you want to get the latest for 8.10 I recommend you add the PPA to your sources.

Hope this helps.

ethana2 (ethana2) wrote :

It does, thanks :)

Rock on!

Bill Filler (bfiller) on 2008-11-10
Changed in netbook-remix:
status: Fix Committed → Fix Released
Neil J. Patel (njpatel) on 2008-11-18
Changed in netbook-remix:
milestone: 1.0.1 → none
Neil J. Patel (njpatel) on 2009-02-18
Changed in window-picker-applet:
status: Triaged → Fix Released

I guess the bug came back. I'm running Netbook-release 10.04, and when I click an application's entry in the applet, nothing happens, which feels quite strange. This behaviour is different than in the desktop version.

The expected behaviour is to minimize the application, remove the application entry from the applet and grey out the application's icon, as with any other minimized application.

This behaviour also differs a little from the desktop version, in the desktop version the application's entry is not removed from the applet. In my opinion, this behaviour is consistent with the way apps minimize on the netbook version. It's the "not responding" when the entry is clicked that is counter intuitive.

In any case, great job! :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers