Locales don't get loaded - English always used

Bug #367181 reported by Nasenbaer on 2009-04-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Unknown
Unknown
widelands (Debian)
Fix Released
Unknown
widelands (Ubuntu)
Low
Unassigned
Declined for Jaunty by Andrew Starr-Bochicchio

Bug Description

Binary package hint: widelands

It seems as if some compilerflags are missing in the script for the ubuntu packjage.
This leads to the problem that Widelands can't find the locales (no translations) and that Build13 shows "UNKNOWN REVISION" as version in game.

a complete call to ./build-widelands.sh (or scons) would be:

./build-widelands.sh build=release build_id=Build13 install_prefix=/usr/share/games/widelands bindir=/usr/games/widelands datadir=/usr/share/games/widelands localedir=/usr/share/games/widelands/locale

The path in that flags are the ones used in Mandriva Linux. So it might be needed to fix them for Ubuntu.

Nasenbaer (nasenbaer) wrote :

A lot of people already mentioned this problem in our chat and our forums, so I now set it to confirmed myself.

Would be nice if someone would care for this bug - shouldn't be too hard to recompile a package with just some different compiler flags.

Changed in widelands (Ubuntu):
status: New → Confirmed
Changed in widelands (Ubuntu):
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
importance: Undecided → Low
status: Confirmed → In Progress
Changed in widelands (Debian):
status: Unknown → New

I came across this while fixing Bug #348896

I have an upload ready that uses:

 scons build_id=Build$(SRC_VERSION) \
  install_prefix=/usr/share/games/widelands \
  bindir=/usr/games \
  datadir=/usr/share/games/widelands \
  localedir=/usr/share/games/widelands/locale

But as I mentioned the upstream report I linked, Widelands still doesn't seem to respect this. Even using that flag, I
need to run widelands from /usr/share/games/widelands in order for language support to work correctly.

This does fix the "UNKNOWN REVISION" problem though. I going to investigate the locale issue some more before uploading. Hopefully we can kill this bug when I upload the fix for Bug #348896

summary: - compile flags missing in ubuntu deb package
+ Locales don't get loaded - English always used

I haven't been able to track this down. Linking both the upstream and Debian bugs on the locale issue, and un-assigning myself. I'm going to proceed to upload the fix for Bug #348896

Changed in widelands (Ubuntu):
status: In Progress → Confirmed
assignee: Andrew Starr-Bochicchio (andrewsomething) → nobody
Changed in widelands (Debian):
status: New → Fix Released

I'm going to dupe this to upstream bug #563285. As we correctly set the localedir flag, I imagine that this must be the issue people are seeing.

SirVer (sirver) wrote :

we are at a bit of loss ourselves; we know that the problems come from those @ appendixes and the problem seems to be only appearing on ubuntu. We could need the help of a gettext guru that could help fixing this issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.