wicd will not work when network-manager is purged

Bug #644175 reported by PrebenR on 2010-09-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
wicd (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: wicd

I prefer wicd over network-manager mainly because I use dwm and not gnome etc... Network-manager seem to only have an applet program to control the network connections, which don't work so well in dwm.

I did a complete reinstall of Lucid (not upgrade), I installed wicd, wicd-daemon etc... and removed all network-manager and also purged the network-manager packages. After doing this I no longer seemed to have a wireless device in the computer. My computer is an Asus Eee 1000H. I could not find the device with ifconfig and no wireless networks where found (obviously). I then installed network-manager again and it found the device and networks. I then just removed network-manager but didn't purge it. And now wicd can find the wireless device.

My point is that wicd should be self-sufficient. It should not relay on that you have uninstalled network-manager but not purged it...

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: wicd-daemon 1.7.0+ds1-2
ProcVersionSignature: Ubuntu 2.6.32-24.43-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic i686
Architecture: i386
Date: Tue Sep 21 10:00:22 2010
InstallationMedia: Xubuntu 10.04 "Lucid Lynx" - Release i386 (20100429)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: wicd

PrebenR (randhol) wrote :
PaJoe (flhtcu) wrote :

My wife's Dell 1420N was working well with Wicd for a couple years .Two days ago when we had the normal Kubuntu 10.04 updates, it's using wicd-daemon 1.7.0+ds1-2 + linux-image-2.6.32.24-generic it stopped working with the "bad password" error.

We tried totally removing everything associated with the knetwork manager and network manager and reinstalled wicd but we still get the "bad password" error. It is interesting because removing everything related to network manger fixed it before. In the end we needed to use the gnome network manager and run nm-applet at the KDE startup in order to use the wireless.

Charlie Kravetz (charlie-tca) wrote :

@PaJoe: Please file a new bug report for that issue. This report is filed because completely purging network-manager causes wi-cd to not be able to be used. It does not address the "wi-cd quit working with updates" issue at all. Thanks.

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

bug 663352 is related to this issue.

Changed in wicd (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Tof (tof-demzcur) wrote :

Hi all,
after upgrading to Lucid yesterday I realised that wicd was behaving strangely and refused to associate, ending in a 'Wrong password' error message.
So after a little research I realised that network-manager was also installed on my system. As far as I know, the wicd and network-manager packages had so far always been marked as conflicting with each other. But this is not the case with Lucid.
Removing and purging both packages, then reinstalling wicd fixed the problem.
I think the real problem lies in the packages not being marked as conflicting.
Hope that helps...

Chris Wilson (notgary) wrote :

I am marking this as invalid for the paper cuts project as a paper cut should be a minor design flaw in a package that is included in a Ubuntu installation, rather than a problem with installing a new one. This is simply a normal bug.

Changed in hundredpapercuts:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers