Ubuntu

wicd connect to wpa2 wireless network bad password

Reported by Toby Maxwell-Lyte on 2010-03-17
166
This bug affects 35 people
Affects Status Importance Assigned to Milestone
wicd (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: wicd

lsb_release -rd
Description: Ubuntu lucid (development branch)
Release: 10.04

apt-cache policy wicd
wicd:
  Installed: 1.7.0-2
  Candidate: 1.7.0-2
  Version table:
 *** 1.7.0-2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ lucid/universe Packages
        100 /var/lib/dpkg/status

Expected result
Able to connect to hidden wpa2 wireless network

Actual result
Following a software update, wicd stopped connecting to my wpa2 hidden network. It is able to find the hidden network but fails to connect with the error message "Bad Password". The password I am using hasn't changed.

Here is the extract from /var/log/wicd/wicd.log

2010/03/17 06:48:02 :: Connecting to wireless network *******************
2010/03/17 06:48:02 :: attempting to set hostname with dhclient
2010/03/17 06:48:02 :: using dhcpcd or another supported client may work better
2010/03/17 06:48:02 :: attempting to set hostname with dhclient
2010/03/17 06:48:02 :: using dhcpcd or another supported client may work better
2010/03/17 06:48:03 :: Putting interface down
2010/03/17 06:48:03 :: Releasing DHCP leases...
2010/03/17 06:48:03 :: attempting to set hostname with dhclient
2010/03/17 06:48:03 :: using dhcpcd or another supported client may work better
2010/03/17 06:48:03 :: Setting false IP...
2010/03/17 06:48:03 :: Stopping wpa_supplicant
2010/03/17 06:48:03 :: Flushing the routing table...
2010/03/17 06:48:03 :: Putting interface up...
2010/03/17 06:48:05 :: Generating psk...
2010/03/17 06:48:05 :: Attempting to authenticate...
2010/03/17 06:48:41 :: wpa_supplicant authentication may have failed.
2010/03/17 06:48:41 :: connect result is Failed
2010/03/17 06:48:41 :: exiting connection thread
2010/03/17 06:48:41 :: Sending connection attempt result bad_pass
2010/03/17 06:48:41 :: attempting to set hostname with dhclient
2010/03/17 06:48:41 :: using dhcpcd or another supported client may work better
2010/03/17 06:48:41 :: attempting to set hostname with dhclient
2010/03/17 06:48:41 :: using dhcpcd or another supported client may work better

In the gui it displays messages that begin along the lines of
-\x13^\xD2\x14<\x86\xEC\xBB}\x816\...

It works fine with a wired connection.

ProblemType: Bug
Architecture: i386
Date: Wed Mar 17 06:39:36 2010
DistroRelease: Ubuntu 10.04
Package: wicd-gtk 1.7.0-2
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: wicd
Uname: Linux 2.6.32-16-generic i686

imayoda (rateava) wrote :

I have the same bad password error with my private WPA access point.. can't test other wireless connections right now

Changed in wicd (Ubuntu):
status: New → In Progress

This problem still occurs if the access point is not hidden. It seems to relate to the wpa2 key communication.

summary: - wicd connect to hidden wireless network bad password
+ wicd connect to wpa2 wireless network bad password
Michalxo (michalxo) wrote :

Same problem here after upgrading from 9.10. Unable to connect to WPA2 network :-/

apinunt (apinunt) wrote :

I'm not having a problem with wicd, but am when connecting to a network drive. I'm asked for a keyring password, but then fail to ever make a connection. Could both of these problems have something to do with the keyring?

Michalxo (michalxo) wrote :

No, I have found that problem is in wicd-1.7 package. For me, wicd 1.6 works pretty well.
With
python-urwid: 0.9.9.1-1
wicd: Installed: 1.6.1-3ubuntu1 Candidate: 1.7.0+ds1-2 all ok :-)
I am on Lucid btw ;-)

Michalxo (michalxo) wrote :

Today after all updates my wicd works either with 1.6.1 or 1.7 version.

All updates installed. Still says "bad password" when the password's fine. 1.7

I have managed to downgrade to 1.6.1-3ubuntu1. This has solved the issue for me. Not really a fix though.

To downgrade: -
edit /etc/apt/sources.list and added links to the karmic repositories for the universe group.
Did a software update.
Opened synaptic package manager
Searched for wicd.
Select package -> force version.
Selected version 1.6.1-3.
Applied the update. It downgraded successfully and resolved the relevant dependencies.
I then selected package -> lock version.
I edited /etc/apt/sources.list and removed the karmic entries I'd just added.

Shane Rice (shane2peru) wrote :

This bug also affects me, even after all updates, purging my wicd installation I'm not able to get it working. I'm going to downgrade as described in the above post and hopefully that will get me working again.

Shane

Shane Rice (shane2peru) wrote :

Ok, downgrading to the previous version 1.6xx worked fine! Got my wireless back! Hope this gets fixed soon.

Shane

dibson (dibson-hoffweiler) wrote :

I installed Lucid on April 8, wicd was working for me until I did an update the evening of April 12. At that point I began getting the behavior described in the bug description. nm-applet works for me. Running the two concurrently is a bit funky, so I'm using only network-manager-gnome right now.

dibson (dibson-hoffweiler) wrote :

april 15 - without changing any settings, wicd works for me again. I'm running a ThinkPad X60s. I try suspend out - on resume I get the broken wicd behavior again. Neither a reboot nor a cold boot get it working again.

Adam Wolfe Gordon (awg) wrote :

I noticed this problem after upgrading to Lucid. After removing wicd, I went to try network-manager, and discovered it was already installed and running. After removing network-manager, and re-installing wicd, it works fine. Perhaps the problem is that installing Lucid's wicd package doesn't uninstall network-manager, and they have a race to see who controls the wireless.

This problem seems to have been fixed in wicd 1.7.0+ds1-2

manwithastick (manwithastick) wrote :

Installed lucid today and had the same issue. Removed network-manager and tried immediately without trying to reinstall wicd (1.7.0) or a reboot and password error now works.

Al Hasan (hasanmd-al) wrote :

I have the problem discussed here. I tried to downgrade to wicd 1.6 by doing below but was unsuccessful, could you help please:

Added the following 4 lines in /etc/apt/sources.list

1.
# karmic universe
deb http://gb.archive.ubuntu.com/ubuntu/ karmic universe
deb-src http://gb.archive.ubuntu.com/ubuntu/ karmic universe
deb http://gb.archive.ubuntu.com/ubuntu/ karmic-updates universe
deb-src http://gb.archive.ubuntu.com/ubuntu/ karmic-updates universe

2.
sudo apt-get update

3.
search wicd in synaptic but only version 1.7 shows up, could not
see 1.6 to install.

4.
selected 1.7, and clicked package --> force version. 1.6 and 1.7 both
shows up in pop up selection menu; but choosing 1.6 causes the apply
button to disable. so apply does not work.

How exactly should I do it. Sorry if I am doing something silly, but never
did a downgrade like this.

What's I am doing wrong?

Donjan Rodic (bryonak) wrote :

Got bitten by this bug (bad password) after upgrading a machine from Ubuntu 9.10 to 10.04. It reinstalls network-manager.

Steps to fix in a terminal:
sudo aptitude remove network-manager
sudo /etc/init.d/wicd restart

Hit the tray icon and connect to a wpa2 network of your choice.

I can confirm that #18's suggestion fixed it for me, but I had to reboot after removing network-manager for some reason.

zeusOne (vaudano) wrote :

Me too, #18 solved the problem. Thanks

Al Hasan (hasanmd-al) wrote :

me too, #18 solved the problem. Thank you!

hugmys0ul (embrace-s0ul) wrote :

Thanks to Donjan Rodic
#18 (plus a reboot) solved it for me

I have a follow-up question:
WICD does not appear to allow both interfaces (wired and wireless) to be active simultaneously.
Is this by design?

Stephen Tobin (usmcusma2004) wrote :

#18 worked for me too. I have a Dell XPS M1730 laptop with an Intel 4965 WLAN Mini Card. Wireless worked with Karmic Koala but stopped working when I upgraded to Lucid Lynx. I didn't have to reboot. I'm connected via the wireless card now.

kajhaul (kaj-haulrich) wrote :

The procedure described above in #9 worked flawlessly for me.

The upgrade - followed by re-install x3 - broke my wireless completely, wicd as well as network-manager. Everything appeared OK undtil I tried to connect via WPA personal. Then it kept going like this: "Bad password" (it wasn't). My network was visible enough, but no go. I tried several laptops (Medion Akoyas) with RT2860STA cards - without ever getting them to connect. (Bad password). I even tried to install Kubuntu, Kubuntu Netbook Remix, vanilla Gnome and Gnome Netbook Remix - all failed to connect.

After the downgrade to karmic all is well with wicd. Tanks, Toby.

huntz (p-conti-dev) wrote :

I agree with post #18, removing network-manager fixed the "Bad password" problem.

Remove network-manager must be into wicd package dependencies.

Bye

marek (marek-greenburg) wrote :

- #9 worked for me
- #18 did not work for me

Clean installed lucid ubuntu, network manager worked OOTB on several different networks. Formatted same day (June 09) and clean installed Xubuntu, only to find that NM was only working some of the time. Completely uninstalled & purged NM in favor of wicd, same problem. Weird thing is, all 3 of my tested networks are configured exactly the same as far as I remember (all are running the same hardware as well . . . unless something changed internally). Before the fix, I could only connect to one of the 3 – other 2 produced the "CF: bad password" error. After locking wicd at 1.6.whatever-is-in-karmic-universe, I'm up and running on all 3. Woo!

Worst part is, I saw that there are no planned updates to wicd at any time "in the near future." Looks as though we'll all be at 1.6 for a while yet.

Thanks Toby!

marek (marek-greenburg) wrote :

Quick Update:

After I was initially able to connect following #9, I was SOL soon thereafter. I checked all of the networks -- turns out I couldn't connect because the two that were giving me trouble had mixed WPA/WPA2 security settings. Changing them to just WPA2 fixed my issues. Anyone know how to get mixed security networks working? It'd be nice to have the ability to connect to any wifi network if I, you know, travel with my netbook, or something crazy like that.

Roy Williams (roy-williams46) wrote :

After applying instructions from #18, my connection problems disappeared and has continued to work for about 6 weeks. Yesterday the "bad password" problem returned. I fixed it by changing to a different driver in Preferences ->Advanced tab from wext to nl80211. My system is running on a Dell laptop MT6821.

wraithmonk (gmfitton) wrote :

I have the same "Bad Password" problem with wicd-1.7.0+dsl-2 on a fresh desktop installation of 64-bit Kubuntu Lucid. The access-point is not hidden, & only using WPA2. Downgrading to 1.6.1-3ubuntu1 (as per entry #9) fixed the problem.

Duong H. Nguyen (cmpitg) on 2010-07-07
Changed in wicd (Ubuntu):
status: In Progress → Confirmed
Bob McGowan (bob-bnlmcgowan) wrote :

As mentioned by others before me, this problem happened on dist upgrade form Kubuntu 9.10 to 10.4. I also see that both network manager and wicd are running, so I will try removing nm first, then downgrade wice if needed, and report back.

Bob McGowan (bob-bnlmcgowan) wrote :

Removed all network-manager related packages (remove+config) and rebooted. wicd successfully made connection to my AP. The problem must be that the packages are no longer configured as conflicting and so both can be installed together. It may be there is a problem determinging conflicts when wicd is installed before the upgrade and the upgrade wants to install network manager.

dardack (dardack) wrote :

Yea i kept only removing network-manager-gnome and kept getting bad password. Once i saw commet 18, i didn't know there was a generic network-manager, that fixed the problem.

Piotr Jankowski (pjankows) wrote :

Got a similar problem but ONLY on mixed mode network. When network is set to G-only (on my wireless router) wicd works fine. When I set the network to NG-Mixed mode wicd is unable to connect - bad password. Network-manager works fine so this is a problem with wicd. Hardware is Intel ipw3945 and using WPA2 AES Encryption.

Anton Anikin (anton-anikin) wrote :

I have the same problem on Ubuntu 10.10 x86_64

Paul Abrahams (abrahams) wrote :

I had the problem after upgrading from 10.04 to 10.10. In my case I got past it by dumping wicd and going over to knetworkmanager, even though in the past I've done better with wicd.

This is a particularly irksome bug (in the latest wicd, I assume) since there's no way to verify absolutely that the Bad Password complaint is bogus. Seeing that many others have the same problem is reassuring.

petipe (p-petipe) wrote :

#18 comment solved the problem for me too, just remove network manager with synaptic and restart wicd. Thank you guys!

Anton Anikin (anton-anikin) wrote :

#18 comment solution not works for me...
wicd.log:

2010/10/23 17:03:18 :: Generating psk...
2010/10/23 17:03:18 :: Attempting to authenticate...
2010/10/23 17:03:26 :: wpa_supplicant rescan forced...
2010/10/23 17:03:59 :: wpa_supplicant authentication may have failed.
2010/10/23 17:03:59 :: connect result is Failed
2010/10/23 17:03:59 :: exiting connection thread
2010/10/23 17:03:59 :: Sending connection attempt result bad_pass

Anton Anikin (anton-anikin) wrote :

Switching the router to G-only mode not helps too

Anton Anikin (anton-anikin) wrote :

I have found I have also connman package installed.
After removing it, wicd works fine

justfor (justfor) wrote :

#18 works fine on Mint Isadora 9

thx!

Jeeks (tanjeekhiumssg) wrote :

First, uninstall network-manager using SPM.
Make sure your computer is not connected to the internet.

Then, run wicd and connect to hidden wireless network.

This should work if you can't downgrade to 1.6.

jerry_tota (kagiza) wrote :

#22 worked fine for me, un-plug the wired cable and test wireless everything is OK (FC 13)

Jane Atkinson (irihapeti) wrote :

I've had problems with wicd being flaky in connecting to my hidden WPA2 network. I sort of fixed it by writing a template that scanned for the hidden ESSID and then used the passphrase that was entered in the Properties dialogue.

This evening I decided to upgrade the passphrase from 30 to 63 characters, and the "bad password" complaint is back again. My Nokia E63 cellphone handles the new passphrase with no problem, and I can connect successfully from the laptop using wpa_supplicant in a script.

Wicd version is 1.7.0. The laptop (EeePC 900) is running Lucid with openbox. The system was built up from a command line install and network manager has never been part of it.

I may try an earlier version of wicd and see what happens. If that doesn't work, I still have the script to fall back on.

Cerin (chrisspen) wrote :

This bug essentially renders laptops useless. I'd say its importance is critical.

Cerin (chrisspen) wrote :

Everything was working perfectly for me using Wicd. However, I wanted to test connecting to an ad hoc network, which Wicd has a known inability to do (https://bugs.launchpad.net/wicd/+bug/129608), so I purged Wicd and re-installed Network Manager. NM was perfectly able to connect to the ad hoc network, but gave me a "bad password" error when I tried to connect to my normal WPA2 network. So using a wired connection, I purged NM and reinstalled Wicd. However, now Wicd gives me the same "bad password" error. Trying #9 and #18 have both failed to fix the problem for me. This is very frustrating.

I have tried almost all the options...Reinstalled ubuntu twice..Unable resolve the issue...
root@ashok:~# wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf
Trying to associate with 00:25:5e:c3:97:b0 (SSID='Ashok' freq=2412 MHz)

Authentication with 00:25:5e:c3:97:b0 timed out.
Trying to associate with 00:25:5e:c3:97:b0 (SSID='Ashok' freq=2412 MHz)
Authentication with 00:25:5e:c3:97:b0 timed out.
Trying to associate with 00:25:5e:c3:97:b0 (SSID='Ashok' freq=2412 MHz)
Authentication with 00:25:5e:c3:97:b0 timed out.
Trying to associate with 00:25:5e:c3:97:b0 (SSID='Ashok' freq=2412 MHz)
Authentication with 00:25:5e:c3:97:b0 timed out.

qma (cumanacr) wrote :

I use #18 don't works but after #28 it works for me on Dell Vostro 1500 with Kubuntu 10.10, thanks

Zach Leigh (zachleigh) wrote :

Nearly a year and no progress. My laptop is as useful to me as a doorstop.

#9 - Doesnt work.
#18 - Works for about a week, then the "bad password" message comes back
#28 - Didnt work

The only way I can get wireless to work is to reinstall Ubuntu. Its kind of silly to have to reinstall the OS to connect to the internet....

Fixing Wicd or getting Network Manager to hold a wireless connection for more than a minute seems like it would be high priority to me.... No wireless=No Ubuntu.

Ahz The Cat (ahzthecat) wrote :

#18's fix worked for me too. Thanks so much...that has helped me move completely to Openbox on 11.04!

Peter Nau (beherenau) wrote :

Echo in the room? #18 worked for me, too.

I had two different computers with this problem, both running 10.04 LTS, one an old 32-bit Ubuntu, and the other a 64-bit Kubuntu. #18 fixed them both.

Thank you!

BTW, I agree that this is a serious problem for Ubuntu. Wicd appears to be the preferred, maybe superior, network/wireless manager, not network-manager, so, perhaps when wicd gets installed, it should automatically remove the (interfering) network-manager stuff.

pentatonic (gibsound) wrote :

I have the problem too (Dell Inspiron 9400) but could found a workaround to live with the bug
#18
and #28 did not help
For Cerin: my workaround is
1) Menu Network/Find a hidden network and put the SSID (I have WPA2 and no broadcast of SSID)
Instead of displaying only a serie of \x00 (same length as the length of the SSID), the correct SSID is then displayed, click then on "Connect"
2) Once the connection is established, it will be kept after a "Hibernate" but will be lost after a shutdown (it is logic)

I have to try #9 (downgrade) some day...

STEELBAS (steelbas) wrote :

May not be related, but I had similar error messages which were fixed by using the (admittedly flaky) script posted here: https://bbs.archlinux.org/viewtopic.php?pid=729757#p729757 . This involves unloading and then reloading the ath5k module before connecting.

Shane H (shane.h) wrote :

#18 works

My company uses Cisco 802.11n and my Lenovo W500 laptop has an Intel WiFi Link 5300. Our auth method is WPA2, PEAP with TKIP/MSCHAPV2 My laptop is running Ubuntu 10.04. I was able to force downgrade my WiCd adding the PPA using http://apt.wicd.net karmic all. Then use synaptic to force the version of the wicd package and lock it. Now I am able to get past the "bad password". Solved, NO, I now get "Unable to obtain an IP" This leaves me with no working connection at all. So back to network-manager I go, but using it in the same work WiFi setup I am subject to bug: https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/630748

Jeff Lambert (jl-newtraxtech) wrote :

Thank you #18, this has been nagging me for months!

Mrawhimskell (uduogah-gmail) wrote :

You guys wouldn't believe this but in Wicd, i elected for PEAP with GTC and it connected successfully after having tried all other options listed here.

My school network uses WPA2 Enterprise with Cisco access points so that may explain why it worked with that.

dafakam (damien-ameuil) wrote :

#18 solve my problem
Debian i386 on xfce with Realtek RT8291 wifi card. Wicd 1.7.2.4

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers