[karmic] wicd doesn't find networks after inserting hidden essid

Bug #473817 reported by atoms.h on 2009-11-04
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
wicd (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: wicd

After an upgrade to 9.10 wicd detects non-hidden networks, but after trying to connect to a hidden network it shows "No wireless networks found". At this point I cannot connect to my network at all. If I restart the wicd-demon I get the non-hidden networks again and start from the top.

wicd 1.6.1

$ uname -r
2.6.31-14-generic

$lspci -v
03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)
        Subsystem: Intel Corporation Device 1011
        Flags: bus master, fast devsel, latency 0, IRQ 29
        Memory at f7f00000 (64-bit, non-prefetchable) [size=8K]
        Capabilities: <access denied>
        Kernel driver in use: iwlagn
        Kernel modules: iwlagn

atoms.h (thomas-pflueger) wrote :

If I broadcast my wireless ssid everything works as expected.

Ralph E. (infomails) wrote :

Ack ! I have exactly the same problem after upgrading from Jaunty. Broadcasting the ssid solves the problem. But I'm not happy with the solution and would be glad to see this bug solved.

Tom Bell (cbell44) wrote :

I have the identical problem with KNetwork Manager. Currently I only have the MAC list to defend my router, because I can't get the laptop to connect without transmitting the SSID.
I consider this a CRITICAL problem that was broken by upgrading to kubuntu 9.10, Karmic Koala.

Frank DeGilio (degilio) wrote :

I also tried to connect to a hidden wireless network. I don't own the network so I can not just start broadcasting the SSID. The hidden network uses LEAP and WICD wouldn't let me set any of this up (presumably cause it couldn't find the network in the first place).

I went to WICD because it was supposed to be better at this kind of thing than network manager.

Kent57 (kent5700) wrote :

Plasma-widget-networkmanager was working with hidden ssid but recently has broken. I switched back to WICD and it's broken now too. Can not find or log on to my hidden network with either. The network is working fine as I can use the hidden network if I boot Windoz.

x64banana (x64banana) wrote :

I've got the same problem with hidden networks. anyone have a solution??
wicd also seems to be only supporting WEP for ad-hoc networks isn't that way too unsecure???

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers