[raring] wicd-daemon fails to start

Bug #1170589 reported by Thomas Karl Pietrowski on 2013-04-19
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
wicd
Undecided
Unassigned
wicd (Ubuntu)
Undecided
Unassigned

Bug Description

When starting wicd via "sudo wicd -foe", I noticed that the daemon does not find the backup symlink in it's backup_location.

Replacing line 1705 in wicd-daemon.py with:
        if not (os.path.exists(backup_location) or os.path.lexists(backup_location)):

Fixes the problem as it is checking now whether a backup file and backup symlink is existing.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: wicd-daemon 1.7.2.4-4 [modified: usr/share/wicd/daemon/wicd-daemon.py]
ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
Uname: Linux 3.8.0-19-generic x86_64
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
Date: Fri Apr 19 08:53:03 2013
InstallationDate: Installed on 2013-02-10 (67 days ago)
InstallationMedia: Kubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.1)
MarkForUpload: True
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=
 TERM=xterm
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: wicd
UpgradeStatus: Upgraded to raring on 2013-02-10 (67 days ago)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wicd (Ubuntu):
status: New → Confirmed
taiebot65 (taiebot65) wrote :

Hi this bug affected me. The work around worked also.

superboot (greasecar) wrote :

I get this same error when I run any of:
wicd
/etc/init.d/wicd start

@taiebot65, What work around are you talking about?

He is talking about the workaround I suggested in my bug-description.
Just take an editor and superuser rights to edit the wicd-daemon.py at /usr/share/wicd/daemon .
If nothing changed so far in the source code, you'll need to edit the line 1705 into:
        if not (os.path.exists(backup_location) or os.path.lexists(backup_location)):

NOTICE: As we are editing Python source code the spaces before the "if" are needed!

As I have got saucy now here running, I'm not sure about that, but is that bug not fixed at the moment? I remember there was a update some weeks after I reported this bug.

Can someone comfirm this?

Bill Gjestvang (bgjestvang) wrote :

The nature of the problem is that the existing resolv.conf backup code doesn't handle relative symlinks well. Copied to a different directory, a relative link becomes a broken link. os.path.exists() returns false for a broken link.

Thomas-Karl's fix (and the patch I've provided for it) handle it correctly.

I have this problem in Ubuntu 13.04, but not in 12.04.

The attachment "A patch for the solution provided in the original description" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Chip Rosenthal (chip+launchpad) wrote :

Confirm this problem and the fix. Installed wicd on top of kubuntu 13.10.

Bluppie (benhyper) wrote :

De wicd-daemon is gestopt. De gebruikersinterface zal niet goed werken totdat de daemon weer is gestart.

How to use the patch?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers