whoopsie can start before network-manager during boot

Bug #1706195 reported by Brian Murray on 2017-07-24
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
whoopsie (Ubuntu)
High
Brian Murray
Xenial
High
Brian Murray
Zesty
High
Brian Murray

Bug Description

[Impact]
whoopsie can start before network-manager and then will only work when a networking device state changes, however since it started before n-m it should notice the connection come on-line. This is upload is just in case there are some corner cases out there where whoopsie isn't working and uploading the crashes to the Error Tracker.

[Test Case]
1) Boot a system with the old version of whoopsie
2) Run 'systemctl status whoopsie'
3) Observe:
Jul 25 11:07:01 clean-zesty-amd64 systemd[1]: Started crash report submission daemon.
Jul 25 11:07:01 clean-zesty-amd64 whoopsie[446]: [11:07:01] Using lock path: /var/lock/whoopsie/lock
Jul 25 11:07:01 clean-zesty-amd64 whoopsie[446]: [11:07:01] Could not get the Network Manager state:
Jul 25 11:07:01 clean-zesty-amd64 whoopsie[446]: [11:07:01] GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files
Jul 25 11:07:02 clean-zesty-amd64 whoopsie[446]: [11:07:02] offline

With the version of whoopsie in -proposed you'll see the following:

Jul 25 11:10:33 clean-zesty-amd64 systemd[1]: Started crash report submission daemon.
Jul 25 11:10:33 clean-zesty-amd64 whoopsie[1192]: [11:10:33] Using lock path: /var/lock/whoopsie/lock
Jul 25 11:10:33 clean-zesty-amd64 whoopsie[1192]: [11:10:33] The default IPv4 route is: /org/freedesktop/NetworkManager/ActiveConnection/0
Jul 25 11:10:33 clean-zesty-amd64 whoopsie[1192]: [11:10:33] Not a paid data plan: /org/freedesktop/NetworkManager/ActiveConnection/0
Jul 25 11:10:33 clean-zesty-amd64 whoopsie[1192]: [11:10:33] Found usable connection: /org/freedesktop/NetworkManager/ActiveConnection/0

[Regression Potential]
If whoopsie is working properly when it wasn't, this shouldn't be the case because whoopsie would start working when the network connection changed, then people might be surprised by additional network activity (uploading of crashes) and the Error Tracker may receive more crash reports.

Original Description
--------------------
whoopsie's systemd service file does not start after networking which is incorrect since it initially needs to query network-manager's state. A fix was attempted by changing the service file to include "After=network-online.target" but this was insufficient. The following messages demonstrate the failure, if whoopsie were to start after network-manager we would not see them:

Jul 17 06:46:47 speedy whoopsie[1156]: [06:46:47] Could not get the Network Manager state:
Jul 17 06:46:47 speedy whoopsie[1156]: [06:46:47] GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files

tags: added: artful
Changed in whoopsie (Ubuntu):
status: New → Triaged
importance: Undecided → High
description: updated
Changed in whoopsie (Ubuntu Xenial):
assignee: nobody → Brian Murray (brian-murray)
importance: Undecided → High
status: New → Triaged
Changed in whoopsie (Ubuntu Zesty):
status: New → Triaged
importance: Undecided → High
tags: added: xenial
tags: added: zesty
Changed in whoopsie (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
Changed in whoopsie (Ubuntu Zesty):
assignee: nobody → Brian Murray (brian-murray)
Changed in whoopsie (Ubuntu):
status: Triaged → In Progress
Changed in whoopsie (Ubuntu Xenial):
status: Triaged → In Progress
Changed in whoopsie (Ubuntu Zesty):
status: Triaged → In Progress
description: updated
Brian Murray (brian-murray) wrote :

And I forgot to reference the bug number in the changelog uploaded to Artful.

whoopsie (0.2.58) artful; urgency=medium

  * Modify the whoopsie service file to wants=networking-online.target too.

Changed in whoopsie (Ubuntu):
status: In Progress → Fix Released

Hello Brian, or anyone else affected,

Accepted whoopsie into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/whoopsie/0.2.52.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in whoopsie (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Changed in whoopsie (Ubuntu Zesty):
status: In Progress → Fix Committed
tags: added: verification-needed-zesty
Adam Conrad (adconrad) wrote :

Hello Brian, or anyone else affected,

Accepted whoopsie into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/whoopsie/0.2.55.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Brian Murray (brian-murray) wrote :

Verification done on zesty:

bdmurray@clean-zesty-amd64:~$ systemctl status whoopsie
● whoopsie.service - crash report submission daemon
   Loaded: loaded (/lib/systemd/system/whoopsie.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2017-07-28 10:21:50 PDT; 1s ago
 Main PID: 1197 (whoopsie)
   CGroup: /system.slice/whoopsie.service
           └─1197 /usr/bin/whoopsie -f

Jul 28 10:21:50 clean-zesty-amd64 systemd[1]: Started crash report submission daemon.
Jul 28 10:21:50 clean-zesty-amd64 whoopsie[1197]: [10:21:50] Using lock path: /var/lock/whoopsie/lock
Jul 28 10:21:50 clean-zesty-amd64 whoopsie[1197]: [10:21:50] The default IPv4 route is: /org/freedesktop/NetworkManager/ActiveConnection/0
Jul 28 10:21:50 clean-zesty-amd64 whoopsie[1197]: [10:21:50] Not a paid data plan: /org/freedesktop/NetworkManager/ActiveConnection/0
Jul 28 10:21:50 clean-zesty-amd64 whoopsie[1197]: [10:21:50] Found usable connection: /org/freedesktop/NetworkManager/ActiveConnection/0
bdmurray@clean-zesty-amd64:~$ apt-cache policy whoopsie
whoopsie:
  Installed: 0.2.55.2
  Candidate: 0.2.55.2
  Version table:
 *** 0.2.55.2 500
        500 http://archive.ubuntu.com/ubuntu zesty-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     0.2.55.1 500
        500 http://192.168.10.7/ubuntu zesty-updates/main amd64 Packages
     0.2.55 500
        500 http://192.168.10.7/ubuntu zesty/main amd64 Packages

Brian Murray (brian-murray) wrote :

And verification done on xenial:

bdmurray@clean-xenial-amd64:~$ systemctl status whoopsie
● whoopsie.service - crash report submission daemon
   Loaded: loaded (/lib/systemd/system/whoopsie.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2017-07-28 10:26:50 PDT; 33s ago
 Main PID: 1111 (whoopsie)
   CGroup: /system.slice/whoopsie.service
           └─1111 /usr/bin/whoopsie -f

Jul 28 10:26:50 clean-xenial-amd64 systemd[1]: Started crash report submission daemon.
Jul 28 10:26:50 clean-xenial-amd64 whoopsie[1111]: [10:26:50] Using lock path: /var/lock/whoopsie/lock
Jul 28 10:26:50 clean-xenial-amd64 whoopsie[1111]: [10:26:50] The default IPv4 route is: /org/freedesktop/NetworkManager/ActiveConnection/0
Jul 28 10:26:50 clean-xenial-amd64 whoopsie[1111]: [10:26:50] Not a paid data plan: /org/freedesktop/NetworkManager/ActiveConnection/0
Jul 28 10:26:50 clean-xenial-amd64 whoopsie[1111]: [10:26:50] Found usable connection: /org/freedesktop/NetworkManager/ActiveConnection/0
bdmurray@clean-xenial-amd64:~$ apt-cache policy whoopsie
whoopsie:
  Installed: 0.2.52.5
  Candidate: 0.2.52.5
  Version table:
 *** 0.2.52.5 500
        500 http://archive.ubuntu.com/ubuntu xenial-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     0.2.52.4 500
        500 http://192.168.10.7/ubuntu xenial-updates/main amd64 Packages
     0.2.52 500
        500 http://192.168.10.7/ubuntu xenial/main amd64 Packages

tags: added: verification-done-xenial verification-done-zesty
removed: verification-needed-xenial verification-needed-zesty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package whoopsie - 0.2.52.5

---------------
whoopsie (0.2.52.5) xenial-proposed; urgency=medium

  * Modify the whoopsie service file to wants=networking-online.target too.
    (LP: #1706195)

 -- Brian Murray <email address hidden> Tue, 25 Jul 2017 13:08:46 -0700

Changed in whoopsie (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for whoopsie has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package whoopsie - 0.2.55.2

---------------
whoopsie (0.2.55.2) zesty-proposed; urgency=medium

  * Modify the whoopsie service file to wants=networking-online.target too.
    (LP: #1706195)

 -- Brian Murray <email address hidden> Tue, 25 Jul 2017 13:01:28 -0700

Changed in whoopsie (Ubuntu Zesty):
status: Fix Committed → Fix Released
tags: added: id-59761bfbcfbdd79f928c8806
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers