whoopsie does not send fields from some package management application crashes

Bug #1616517 reported by Brian Murray on 2016-08-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
whoopsie (Ubuntu)
Medium
Unassigned
Trusty
High
Brian Murray
Xenial
Medium
Brian Murray

Bug Description

The package hook for update-manager and aptdaemon add information like /var/log/apt/term.log and /var/log/apt/history.log that would be useful in debugging crashes from those applications. However, those files can be larger than 1 KB so whoopsie does not send them to the Error Tracker. We should be sending those fields along.

Test Case
---------
1) launch update-manager
2) kill -11 the update-manager process
3) locate the update-manager .crash file and observe DpkgHistoryLog.txt in it
4) send crash report to Error Tracker (look for .uploaded file)
5) view crash report in Error Tracker (find OOPS ID by looking at syslog / whoopsie status)
6) observe DpkgHistoryLog.txt not in it

With the version of the package from -proposed DpkgHistoryLog.txt should appear on the OOPS page for the crash that was sent.

Related branches

Changed in whoopsie (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in whoopsie (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → High
Changed in whoopsie (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Medium
summary: - whoopsie does not allow fields from some package management application
+ whoopsie does not send fields from some package management application
crashes
Changed in whoopsie (Ubuntu Trusty):
assignee: nobody → Brian Murray (brian-murray)
description: updated

Hello Brian, or anyone else affected,

Accepted whoopsie into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/whoopsie/0.2.24.6ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in whoopsie (Ubuntu Trusty):
status: Triaged → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

bdmurray@upgrade-trusty-amd64:~$ grep whoopsie /var/log/syslog
Aug 24 12:04:55 upgrade-trusty-amd64 whoopsie[4310]: whoopsie 0.2.24.6ubuntu3 starting up.
Aug 24 12:04:55 upgrade-trusty-amd64 whoopsie[4310]: Using lock path: /var/lock/whoopsie/lock
Aug 24 12:07:46 upgrade-trusty-amd64 whoopsie[4311]: Parsing /var/crash/_usr_bin_update-manager.1000.crash.
Aug 24 12:07:46 upgrade-trusty-amd64 whoopsie[4311]: Uploading /var/crash/_usr_bin_update-manager.1000.crash.
Aug 24 12:07:48 upgrade-trusty-amd64 whoopsie[4311]: Sent; server replied with: No error
Aug 24 12:07:48 upgrade-trusty-amd64 whoopsie[4311]: Response code: 200
Aug 24 12:07:48 upgrade-trusty-amd64 whoopsie[4311]: Reported OOPS ID 0b455ae8-6a2e-11e6-a26a-fa163e30221b
Aug 24 12:08:11 upgrade-trusty-amd64 whoopsie[4311]: Sent; server replied with: No error
Aug 24 12:08:11 upgrade-trusty-amd64 whoopsie[4311]: Response code: 200

https://errors.ubuntu.com/oops/0b455ae8-6a2e-11e6-a26a-fa163e30221b

That OOPS contains DpkgTerminalLog.txt setting to verification-done.

tags: added: verification-done
removed: verification-needed
Changed in whoopsie (Ubuntu Xenial):
assignee: nobody → Brian Murray (brian-murray)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package whoopsie - 0.2.24.6ubuntu3

---------------
whoopsie (0.2.24.6ubuntu3) trusty-proposed; urgency=medium

  * Allow uploading of any field with data less than 1KB, creating a whitelist
    of fields with large data, and a blacklist of fields we don't want in the
    Error Tracker. (LP: #1616559)
  * src/whoopsie.c: Add fields from package management applications that can
    be larger than 1KB to the list of accepted fields. (LP: #1616517)

 -- Brian Murray <email address hidden> Tue, 23 Aug 2016 17:17:02 -0700

Changed in whoopsie (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for whoopsie has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in whoopsie (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: removed: verification-done
tags: added: verification-needed

Hello Brian, or anyone else affected,

Accepted whoopsie into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/whoopsie/0.2.52.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package whoopsie - 0.2.54

---------------
whoopsie (0.2.54) yakkety; urgency=medium

  * src/whoopsie.c: Add fields from package management applications that can
    be larger than 1KB to the list of accepted fields. (LP: #1616517)

 -- Brian Murray <email address hidden> Fri, 09 Sep 2016 09:47:58 -0700

Changed in whoopsie (Ubuntu):
status: Triaged → Fix Released
Sebastien Bacher (seb128) wrote :

Brian, do you think you could verify the xenial SRU?

Brian Murray (brian-murray) wrote :

Here's a crash report in the Error Tracker w/ AptOrdering which is one of the fields that was added.

https://errors.ubuntu.com/oops/2533828c-a0b5-11e6-b4ea-fa163ebeb28a

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package whoopsie - 0.2.52.2

---------------
whoopsie (0.2.52.2) xenial-proposed; urgency=medium

  * src/whoopsie.c: Add fields from package management applications that can
    be larger than 1KB to the list of accepted fields. (LP: #1616517)

 -- Brian Murray <email address hidden> Wed, 24 Aug 2016 12:26:10 -0700

Changed in whoopsie (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers