whoopsie spams the log with "online" messages

Bug #1217407 reported by C de-Avillez on 2013-08-27
356
This bug affects 75 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
Whoopsie
Medium
Brian Murray
whoopsie (Ubuntu)
Low
Brian Murray
Trusty
Low
Brian Murray
Utopic
Low
Brian Murray

Bug Description

Test Case
---------
In the event your system's install of whoopsie isn't spamming syslog (or /var/log/upstart/whoopsie.log) with online messages you can recreate the situation via the following.
1) sudo route add -net 10.0.3.0/24 gw 192.168.10.1 dev wlan0
2) sudo route del -net 10.0.3.0/24 gw 192.168.10.1 dev wlan0

The adding and removing of routes should for force whoopsie to log that it is online. With the version of the package from the -proposed repository you should no longer see the online messages due to a route change.

Original Description
--------------------
It is mostly the "online" messages:

$ grep whoopsie /var/log/syslog
Aug 27 07:42:21 xango3 whoopsie[1832]: online
Aug 27 07:42:27 xango3 whoopsie[1832]: online
Aug 27 07:43:32 whoopsie[1832]: last message repeated 18 times
Aug 27 07:44:50 whoopsie[1832]: last message repeated 17 times
Aug 27 07:45:50 whoopsie[1832]: last message repeated 16 times
Aug 27 07:46:50 whoopsie[1832]: last message repeated 16 times

ProblemType: BugDistroRelease: Ubuntu 13.10
Package: whoopsie 0.2.23
ProcVersionSignature: Ubuntu 3.11.0-4.9-generic 3.11.0-rc7
Uname: Linux 3.11.0-4-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.12.1-0ubuntu2
Architecture: amd64
CrashReports:
 640:109:135:1442457:2013-08-24 15:45:54.414105810 -0500:2013-08-24 15:45:52.882072686 -0500:/var/crash/_usr_bin_nm-applet.109.crash
 640:1000:135:5451572:2013-08-23 10:46:16.804771591 -0500:2013-08-23 10:46:13.688702452 -0500:/var/crash/_usr_share_apport_apport-kde.1000.crash
 640:109:135:3258098:2013-08-24 15:45:52.826071475 -0500:2013-08-24 15:45:50.822028146 -0500:/var/crash/_usr_sbin_unity-greeter.109.crash
 644:0:135:14684:2013-08-27 08:26:39.114007907 -0500:2013-08-19 19:15:13.128538279 -0500:/var/crash/lttng-modules-dkms.0.crash
 640:1000:135:28058162:2013-08-23 11:45:22.587948069 -0500:2013-08-23 11:45:04.267536872 -0500:/var/crash/_usr_bin_calibre.1000.crash
Date: Tue Aug 27 09:53:16 2013
EcryptfsInUse: Yes
InstallationDate: Installed on 2013-02-10 (197 days ago)
InstallationMedia: Kubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130209)
MarkForUpload: TrueSourcePackage: whoopsie
UpgradeStatus: Upgraded to saucy on 2013-06-25 (62 days ago)

C de-Avillez (hggdh2) wrote :
C de-Avillez (hggdh2) on 2013-08-27
summary: - whoopise spams the log with "online" messages
+ whoopsie spams the log with "online" messages
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in whoopsie (Ubuntu):
status: New → Confirmed
Franck (alci) wrote :

Not sure it is related, but I also happen to lose the dns from time to time... something weird is happening with my networking stack since I switched to saucy.

Ryan Tandy (rtandy) wrote :

I wonder whether this is related to (or even a duplicate of) bug 991481?

Changed in whoopsie (Ubuntu):
importance: Undecided → Low

I really do not see why this is a duplicate... maybe bug #991481 is the reason that makes whoopsie check its status so often; but the fact that it is printing a completely useless message is still here. You should say you're online only if you were offline before... this is like saying "nothing happening" all the time...

Changed in whoopsie:
status: New → Confirmed
Brian Murray (brian-murray) wrote :

What one should see is something like this in the log:

Jan 28 23:44:37 localhost whoopsie[29806]: online
Jan 29 00:01:34 localhost whoopsie[29806]: message repeated 163 times: [ online]
Jan 29 00:01:34 localhost whoopsie[29806]: offline

This seems to be system or networking configuration dependent as I see this on one system and not another.

Changed in whoopsie (Ubuntu):
importance: Low → Medium
tags: added: trusty

@Brian: this is what you see if whoopsie is the only thing reporting on syslog. If any other thing report something, it breaks the "repeated" logic of the syslog daemon and you ends up with the thing reported here.

What should happen is that whoopsie should log the "online" message only when it is BACK online (from offline or other statuses), not every few seconds of so. The logic would be something like (pseudo code).

if status==ONLINE and last_syslog_message==ONLINE then
    do nothing
else
    log ONLINE
fi

Meanwhile, a workaround is offered here: http://askubuntu.com/a/407935/16395:

you can add this in /etc/rsyslog.d/00-whoopsie.conf and the messages won't be logged anymore:

  # whoopsie generates a lot of messages of "online"
  # these are worthless and can be filtered
  if $programname == 'whoopsie' and $msg == ' online' then ~

but that way you do not see even the first "online" which is arguably worth to be logged.

Huh. For me, it started happening immediately with a fresh install of
13.10. Networking is also vanilla -- just using the default "Wired
connection" profile, DHCP everything.

Nathan Dorfman (ndorf) wrote :
Download full text (8.8 KiB)

Eh, my workaround was apt-get purge whoopsie. Very effective. :) I'd
like to be a good citizen, though, so I'll reinstall it once I see it
marked fixed.

On Wed, Jan 29, 2014 at 12:01 PM, Romano Giannetti
<email address hidden> wrote:
> @Brian: this is what you see if whoopsie is the only thing reporting on
> syslog. If any other thing report something, it breaks the "repeated"
> logic of the syslog daemon and you ends up with the thing reported here.
>
> What should happen is that whoopsie should log the "online" message only
> when it is BACK online (from offline or other statuses), not every few
> seconds of so. The logic would be something like (pseudo code).
>
> if status==ONLINE and last_syslog_message==ONLINE then
> do nothing
> else
> log ONLINE
> fi
>
> Meanwhile, a workaround is offered here:
> http://askubuntu.com/a/407935/16395:
>
> you can add this in /etc/rsyslog.d/00-whoopsie.conf and the messages
> won't be logged anymore:
>
> # whoopsie generates a lot of messages of "online"
> # these are worthless and can be filtered
> if $programname == 'whoopsie' and $msg == ' online' then ~
>
> but that way you do not see even the first "online" which is arguably
> worth to be logged.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1264798).
> https://bugs.launchpad.net/bugs/1217407
>
> Title:
> whoopsie spams the log with "online" messages
>
> Status in Ubuntu error tracker client (whoopsie):
> Confirmed
> Status in “whoopsie” package in Ubuntu:
> Confirmed
>
> Bug description:
> It is mostly the "online" messages:
>
> $ grep whoopsie /var/log/syslog
> Aug 27 07:42:21 xango3 whoopsie[1832]: online
> Aug 27 07:42:27 xango3 whoopsie[1832]: online
> Aug 27 07:43:32 whoopsie[1832]: last message repeated 18 times
> Aug 27 07:44:50 whoopsie[1832]: last message repeated 17 times
> Aug 27 07:45:50 whoopsie[1832]: last message repeated 16 times
> Aug 27 07:46:50 whoopsie[1832]: last message repeated 16 times
> Aug 27 07:47:50 whoopsie[1832]: last message repeated 18 times
> Aug 27 07:48:50 whoopsie[1832]: last message repeated 15 times
> Aug 27 07:49:50 whoopsie[1832]: last message repeated 16 times
> Aug 27 07:50:50 whoopsie[1832]: last message repeated 21 times
> Aug 27 07:51:50 whoopsie[1832]: last message repeated 18 times
> Aug 27 07:52:50 whoopsie[1832]: last message repeated 20 times
> Aug 27 07:53:50 whoopsie[1832]: last message repeated 22 times
> Aug 27 07:54:50 whoopsie[1832]: last message repeated 15 times
> Aug 27 07:55:50 whoopsie[1832]: last message repeated 22 times
> Aug 27 07:56:50 whoopsie[1832]: last message repeated 20 times
> Aug 27 07:57:50 whoopsie[1832]: last message repeated 18 times
> Aug 27 07:58:51 whoopsie[1832]: last message repeated 16 times
> Aug 27 07:59:46 whoopsie[1832]: last message repeated 17 times
> Aug 27 07:59:47 xango3 whoopsie[1832]: online
> Aug 27 08:00:51 whoopsie[1832]: last message repeated 24 times
> Aug 27 08:01:51 whoopsie[1832]: last message repeated 24 times
> Aug 27 08:02:51 whoopsie[1832]: last message repeated 19 times
> Aug 27 08:03:51 who...

Read more...

Nathan Dorfman (ndorf) wrote :

Well, I guess it's a little better than before. Fresh install of 14.04:

Jul 26 00:18:18 vane whoopsie[996]: whoopsie 0.2.24.6 starting up.
Jul 26 00:18:18 vane whoopsie[996]: Using lock path: /var/lock/whoopsie/lock
Jul 26 00:18:18 vane whoopsie[1041]: offline
Jul 26 00:18:22 vane whoopsie[1041]: message repeated 2 times: [ offline]
Jul 26 00:18:22 vane whoopsie[1041]: online
Jul 26 00:35:38 vane whoopsie[1041]: message repeated 6 times: [ online]

If you are still experiencing this bug, please:

 1. Write the affected Ubuntu release name into the tag list.
 2. Set this bug report status back to "confirmed".

Changed in hundredpapercuts:
importance: Undecided → Medium
status: New → Confirmed
no longer affects: hundredpapercuts/trusty
Changed in hundredpapercuts:
status: Confirmed → Incomplete
Changed in whoopsie:
status: Confirmed → Incomplete
Changed in whoopsie (Ubuntu):
status: Confirmed → Incomplete
Nathan Dorfman (ndorf) wrote :

On an up to date 14.04 LTS system, I have what I guess is a mild remnant of the original bug?

syslog.1:Nov 23 14:45:36 vane whoopsie[1280]: message repeated 73 times: [ offline]
syslog.1:Nov 24 08:33:59 vane whoopsie[1280]: online
syslog.1:Nov 24 08:34:01 vane whoopsie[1280]: message repeated 3 times: [ online]
syslog.1:Nov 24 08:56:55 vane whoopsie[1280]: offline
syslog.1:Nov 24 20:09:37 vane whoopsie[1280]: message repeated 3 times: [ offline]
syslog.1:Nov 24 20:09:37 vane whoopsie[1280]: online

No more log messages as of now, Tue Nov 25 11:46:47 EST, which is nice. The 73 redundant "offline" messages would seem to satisfy the definition of "spamming syslog." I personally couldn't stomach reopening this bug myself though, at least not without the ability to also change importance to low.

Bryan Quigley (bryanquigley) wrote :

I can confirm this running Vivid using systemd as the init system.

Whoopsie Toal $ sudo journalctl | grep whoopsie | wc -l
4498
Just telling me it's online $ sudo journalctl | grep whoopsie | grep online | wc -l
4470
Total log $ sudo journalctl | wc -l
36838

This is for 1 day of use...

Changed in hundredpapercuts:
status: Incomplete → Invalid
Changed in whoopsie (Ubuntu):
status: Incomplete → Confirmed
Changed in whoopsie:
status: Incomplete → Confirmed
Changed in whoopsie (Ubuntu):
importance: Medium → Low
Bryan Quigley (bryanquigley) wrote :

Simple check to see if the state has changed before printing.

tags: added: vivid

The attachment "only_log_when_changed.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
description: updated
Changed in whoopsie (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
Changed in whoopsie:
assignee: nobody → Brian Murray (brian-murray)
importance: Undecided → Medium
status: Confirmed → Fix Released
Changed in whoopsie (Ubuntu):
status: Confirmed → In Progress
Changed in whoopsie (Ubuntu Trusty):
assignee: nobody → Brian Murray (brian-murray)
Changed in whoopsie (Ubuntu Utopic):
assignee: nobody → Brian Murray (brian-murray)
Changed in whoopsie (Ubuntu Trusty):
importance: Undecided → Low
Changed in whoopsie (Ubuntu Utopic):
importance: Undecided → Low
Changed in whoopsie (Ubuntu Trusty):
status: New → In Progress
Changed in whoopsie (Ubuntu Utopic):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package whoopsie - 0.2.45

---------------
whoopsie (0.2.45) vivid; urgency=medium

  * Merge patch from Bryan Quigley to only log when whoopsie's state changes.
    (LP: #1217407)
 -- Brian Murray <email address hidden> Mon, 02 Feb 2015 13:54:58 -0800

Changed in whoopsie (Ubuntu):
status: In Progress → Fix Released

Hello C, or anyone else affected,

Accepted whoopsie into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/whoopsie/0.2.24.6ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in whoopsie (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in whoopsie (Ubuntu Utopic):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello C, or anyone else affected,

Accepted whoopsie into utopic-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/whoopsie/0.2.39ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in hundredpapercuts:
status: Invalid → Fix Released
Brian Murray (brian-murray) wrote :

I've done the verification in Utopic and it passed the test case.

tags: added: verification-done-utopic
Brian Murray (brian-murray) wrote :

I was unable to recreate the bug given the test case provided with Trusty so it'd be useful if someone affected by the bug were to verify the package from -proposed for Trusty.

tags: added: verification-needed-trusty
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package whoopsie - 0.2.39ubuntu0.2

---------------
whoopsie (0.2.39ubuntu0.2) utopic-proposed; urgency=medium

  * Merge patch from Bryan Quigley to only log when whoopsie's state changes.
    (LP: #1217407)
 -- Brian Murray <email address hidden> Mon, 02 Feb 2015 14:18:29 -0800

Changed in whoopsie (Ubuntu Utopic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for whoopsie has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Rolf Leggewie (r0lf) wrote :

I tried to reproduce this problem in two trusty machines but I was unable to. syslog did not contain a single line from whoopsie on 1 machine and only about a dozen entries on the other. I checked syslog.1, too, to be sure.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package whoopsie - 0.2.24.6ubuntu2

---------------
whoopsie (0.2.24.6ubuntu2) trusty-proposed; urgency=medium

  * src/whoopsie.c: Send UnreportableReason to the Error Tracker that way we
    know apport's opinion of the crash. (LP: #1382233)

 -- Brian Murray <email address hidden> Mon, 09 Nov 2015 13:24:00 -0800

Changed in whoopsie (Ubuntu Trusty):
status: Fix Committed → Fix Released
tags: removed: verification-needed-trusty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers