Thread creation failed: pthread_create returned 11 at /usr/bin/whohas line 1055.

Bug #690796 reported by Martin-Éric Racine on 2010-12-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
whohas (Debian)
Fix Released
Unknown
whohas (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: whohas

'whohas' often runs into an endless spin trying to create multiple threads and brings the system on which its runs down to its knees, making it entirely unresponsive to any user interaction. For example:

$ LC_ALL=C whohas --strict xserver-xorg

Produces an endless series of these two debug messages in random permutations:

Thread creation failed: pthread_create returned 11 at /usr/bin/whohas line 377.
Thread creation failed: pthread_create returned 11 at /usr/bin/whohas line 1055.

This eventually results in the following line appearing at the end, before we are returned to the command line:

Out of memory!

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: whohas 0.24-2
ProcVersionSignature: Ubuntu 2.6.37-9.22-generic 2.6.37-rc5
Uname: Linux 2.6.37-9-generic i586
Architecture: i386
Date: Wed Dec 15 21:04:51 2010
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=fi_FI:fi:en_US:en
 PATH=(custom, user)
 LANG=fi_FI.UTF-8
 SHELL=/bin/bash
SourcePackage: whohas

Related branches

Martin-Éric Racine (q-funk) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in whohas (Ubuntu):
status: New → Confirmed

Use the --no-threads flag as a workaround [1] until this problem is fixed properly upstream.

1: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=523497#10

Changed in whohas (Ubuntu):
importance: Undecided → Medium
Changed in whohas (Debian):
status: Unknown → New
Changed in whohas (Debian):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package whohas - 0.29.1-1

---------------
whohas (0.29.1-1) unstable; urgency=low

  * New upstream release (Closes: #783915)
    - Fixes memory issue using forks module (Closes: #523497, LP: #690796)
    - Fixes all existing distro support
      (Closes: #766473, #774271, #619992, #676471)
    - Fixes FreeBSD URLs (Closes: #626138)
    - Adds links for Fedora packages (Closes: #515510)
    - Adds config file for distro selection/versions (Closes: #632976)
  * New maintainers (Closes: #697137)
  * Move git repository to collab-maint
  * Drop quilt build-dep since it isn't needed with dpkg-source v3
  * Add new forks dependency
  * Adapt packaging to new upstream build system
  * Bump package to debhelper 9
  * Update description to match supported sites
  * Recommend libsys-cpu-perl for auto-job-count
  * Adapt watch file to new upstream git repo
  * Check new upstream OpenPGP signatures
  * Add some DEP-12 upstream metadata
  * Use https and cgit for Vcs-* headers
  * Bump Standards-Version, no changes needed
  * Remove merged and superseded patches
  * Switch to Priority optional
  * 40-improve-fetchdoc:
    - update for new paths
    - disable at request of upstream
  * Re-write debian/copyright in machine-readable form
  * Remove unneeded libxml-simple-perl dep
  * Add build-dependencies for the tests

 -- Paul Wise <email address hidden> Mon, 25 May 2015 18:57:19 +0800

Changed in whohas (Ubuntu):
status: Confirmed → Fix Released
Changed in whohas (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.