wesnoth toggles from fullscreen to windowed randomly

Bug #367465 reported by Darren Couch on 2009-04-26
6
Affects Status Importance Assigned to Milestone
wesnoth (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: wesnoth

Description: Ubuntu 9.04
Release: 9.04
wesnoth:
  Installed: 1:1.6a-3ubuntu1
  Candidate: 1:1.6a-3ubuntu1
  Version table:
 *** 1:1.6a-3ubuntu1 0
        500 http://ubuntu.osuosl.org jaunty/universe Packages
        100 /var/lib/dpkg/status

During play on any campaign scenario, wesnoth will occasionally toggle itself from fullscreen to windowed mode.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: wesnoth 1:1.6a-3ubuntu1
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: wesnoth
Uname: Linux 2.6.28-11-generic x86_64

Darren Couch (dcouch) wrote :

* Darren Couch <email address hidden> [2009-04-26 20:01:31 CEST]:
> During play on any campaign scenario, wesnoth will occasionally toggle
> itself from fullscreen to windowed mode.

 Can you try disabling your screensaver and see wether the problem still
occurs to you? A similar report popped up in the wesnoth forums about
year ago and it was narrowed down to have been a screensaver issue:
<http://wesnoth.org/forum/viewtopic.php?f=4&t=20183>

 Thanks,
Rhonda

Darren Couch (dcouch) wrote :

I will give that a try.

On Mon, 2009-04-27 at 08:05 +0000, Gerfried Fuchs wrote:
> * Darren Couch <email address hidden> [2009-04-26 20:01:31 CEST]:
> > During play on any campaign scenario, wesnoth will occasionally toggle
> > itself from fullscreen to windowed mode.
>
> Can you try disabling your screensaver and see wether the problem still
> occurs to you? A similar report popped up in the wesnoth forums about
> year ago and it was narrowed down to have been a screensaver issue:
> <http://wesnoth.org/forum/viewtopic.php?f=4&t=20183>
>
> Thanks,
> Rhonda
>

Darren Couch (dcouch) wrote :

Setting the screensaver to blank window seems to have done the trick!
Thanks a bunch.

On Mon, 2009-04-27 at 08:05 +0000, Gerfried Fuchs wrote:
> * Darren Couch <email address hidden> [2009-04-26 20:01:31 CEST]:
> > During play on any campaign scenario, wesnoth will occasionally toggle
> > itself from fullscreen to windowed mode.
>
> Can you try disabling your screensaver and see wether the problem still
> occurs to you? A similar report popped up in the wesnoth forums about
> year ago and it was narrowed down to have been a screensaver issue:
> <http://wesnoth.org/forum/viewtopic.php?f=4&t=20183>
>
> Thanks,
> Rhonda
>

Gerv (gerv) wrote :

Right, but "wesnoth and screensavers are incompatible" is not a reasonable 'solution' to this problem. Does this bug need to be passed upstream? Or is someone on the Ubuntu project responsible for it?

Gerv

I will have to check on both-currenty on the 32 bit desktop running 9.04 it
seems to be running fine, and I haven't checked on the 64bit laptop. I will
x2 check and let you know.

On Thu, Aug 27, 2009 at 2:18 PM, Gerv <email address hidden> wrote:

> Right, but "wesnoth and screensavers are incompatible" is not a
> reasonable 'solution' to this problem. Does this bug need to be passed
> upstream? Or is someone on the Ubuntu project responsible for it?
>
> Gerv
>
> --
> wesnoth toggles from fullscreen to windowed randomly
> https://bugs.launchpad.net/bugs/367465
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Darren R. Couch
<email address hidden>

Gabe Gorelick (gabegorelick) wrote :

Is this still an issue, or has it been resolved?

Changed in wesnoth (Ubuntu):
status: New → Incomplete
Darren Couch (dcouch) wrote :

oh wow. Not an issue. I'm onto 9.10 64 bit now, and it plays fine.

On Fri, Jan 15, 2010 at 1:38 AM, Gabe Gorelick <email address hidden>wrote:

> Is this still an issue, or has it been resolved?
>
> ** Changed in: wesnoth (Ubuntu)
> Status: New => Incomplete
>
> --
> wesnoth toggles from fullscreen to windowed randomly
> https://bugs.launchpad.net/bugs/367465
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Darren R. Couch
<email address hidden>

Changed in wesnoth (Ubuntu):
status: Incomplete → Invalid
Darren Couch (dcouch) wrote :

It wasn't invalid when I was on 9.04 32 bit, I just can't speak to
its validity anymore.

On Sat, Jan 16, 2010 at 3:23 PM, Gabe Gorelick <email address hidden>wrote:

> ** Changed in: wesnoth (Ubuntu)
> Status: Incomplete => Invalid
>
> --
> wesnoth toggles from fullscreen to windowed randomly
> https://bugs.launchpad.net/bugs/367465
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Darren R. Couch
<email address hidden>

Gabe Gorelick (gabegorelick) wrote :

@Darren if you, or anyone, can reproduce this bug, then feel free to reopen it. It's just that if it is working on 9.10 then there really isn't a problem anymore.

No that's fine. I'm not desiring to keep it open, I was objecting to
the immaterial label. Closed I thought would be more appropriate.

On Jan 18, 2010, at 9:43 PM, Gabe Gorelick wrote:

> @Darren if you, or anyone, can reproduce this bug, then feel free to
> reopen it. It's just that if it is working on 9.10 then there really
> isn't a problem anymore.
>
> --
> wesnoth toggles from fullscreen to windowed randomly
> https://bugs.launchpad.net/bugs/367465
> You received this bug notification because you are a direct subscriber
> of the bug.

Rhonda D'Vine (rhonda) wrote :

* Gabe Gorelick <email address hidden> [2010-01-19 06:43:25 CET]:
> @Darren if you, or anyone, can reproduce this bug, then feel free to
> reopen it. It's just that if it is working on 9.10 then there really
> isn't a problem anymore.

 Gabe, the objection wasn't to that the problem doesn't exist anymore -
the objection was to setting the bug report to invalid, which it isn't.
Setting it to "Fix Released" sounds more appropriate (which I just did),
even though there wasn't changes in wesnoth for that happening.

 Thanks for looking after the bugs, though. :)
Rhonda

Changed in wesnoth (Ubuntu):
status: Invalid → Fix Released
Gabe Gorelick (gabegorelick) wrote :

No problem, this whole distinction between invalid and fixed released is all just semantics anyway. I thought it was more appropriate as invalid since it was never really fully confirmed, but it really doesn't matter. The important thing is that this bug is finally closed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers