Interface does not respont to mouse clicks (Lucid)

Bug #571162 reported by Prosthetic Head
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
wesnoth-1.8 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: wesnoth-1.8

On starting up wesnoth-1.8 the front page appears and music plays. When the mouse is hovered over any of the buttons on that screen they become highlighted but unfortunately don't respond to clicks. This makes it impossible to start a game or change preferences or use any of the other features of the interface making the program essentially useless.

The default Wesnoth (1.65) in lucid works fine on the same system.
This may be why 1.8 branch has to be specifically installed and is not the default Wesnoth branch?

Either way, 1.8 will be required to continue playing multi-player with others who have upgraded so it would be nice to get it working.

This problem can be duplicated on all 3 of my systems:
Pentium 4 based desktop with Radeon 9600 graphics card using open driver (Lucid 32bit)
Thinkpad T61p - Core2, nVidia card with proprietary driver (Lucid 64bit)
Thinkpad X60s - Core2, Intel GMA950 graphics (Lucid 64bit)

Revision history for this message
Rhonda D'Vine (rhonda) wrote :

wesnoth 1.8 is not the default because it is explicitly meant to be installable side-by-side with the wesnoth (1.6) branch. In the future the wesnoth package will depend on the latest branch version, currently this transition hasn't been done yet.

About this bug, it is a bug in SDL and it was said to be fixed in lucid-proposed after the lucid release. For the time being you can switch to fullscreen mode with ctrl-f and have the clicks work in there.

Enjoy!
Rhonda

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers