Ubuntu

FFe: Sync wesnoth-1.8 1:1.8-1 (universe) from Debian experimental (main)

Reported by zombiepig on 2010-04-07
68
This bug affects 13 people
Affects Status Importance Assigned to Milestone
wesnoth-1.8 (Ubuntu)
Wishlist
Unassigned
Lucid
Wishlist
Unassigned

Bug Description

Binary package hint: wesnoth

Wesnoth 1.8 has been recently released (http://www.wesnoth.org/start/1.8/) It looks like there's debian packages already built at http://packages.debian.org/experimental/wesnoth-1.8 . Can we get a sync from debian to this version to allow connection to the official servers again?

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: wesnoth 1:1.6.5-1build1
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
Architecture: amd64
Date: Thu Apr 8 08:53:06 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
PackageArchitecture: all
ProcEnviron:
 LANG=en_AU.utf8
 SHELL=/bin/bash
SourcePackage: wesnoth

zombiepig (nyall-zombiepigs) wrote :
Gerfried Fuchs (rhonda) wrote :

 There was major rework of the 1.8 package to make it possible to install it side-by-side with the former wesnoth packages (1.6 series) and potential future branches (upcoming 1.9 branch and later stable releases). This rework is mostly finished - but not complete with respect to offering alternative handling for being able to start "wesnoth" instead of explicitly have to start "wesnoth-1.8", which also requires to add dpkg-diverts for the former unversioned wesnoth packages.

 Also, the official server didn't drop the 1.6 clients yet and from what I know it isn't planned to do that too soon. If I'm not totally mistaken one can even still connect with 1.4 clients to the official server, so there is nothing to fear from that part.

Gerfried Fuchs (rhonda) wrote :

... alright, got confirmed by upstream that 1.4 can't connect anymore since a few days now and that 1.6 is expected to be supported (server-side) until the next stable release after that one comes out. As much as I appreciate the working speed of the wesnoth team I fear that they won't be able to make it earlier than the next Ubuntu release, so there really is nothing to fear here in that respect. ;)

 And if there would be need for having it running longer it can be discussed. The wesnoth developers are open in that respect to suggestions.

Gabriele Tozzi (gabriele-tozzi) wrote :

Sounds like "since 2.4 kernel series are still developed and supported, we don't need to include ubuntu 2.6 kernel in ubuntu".

Wesnoth 1.8 is out. It has new features, new graphics, and the majority of people migrated to it. Making ubuntu packages available should be a priority. Having the chance to install multiple versions of wesnoth may be a cool feature for developers, but it's completely useless for everyday users.

How can I expect to fix bug #1 if you don't ship new software asap?

 Hi!

* Gabriele Tozzi <email address hidden> [2010-04-08 23:54:51 CEST]:
> Sounds like "since 2.4 kernel series are still developed and supported,
> we don't need to include ubuntu 2.6 kernel in ubuntu".

 Erm, no, doesn't even remotely. wesnoth 1.8 was just released last
week, kernel 2.6 is pretty old already.

> Wesnoth 1.8 is out. It has new features, new graphics, and the majority
> of people migrated to it. Making ubuntu packages available should be a
> priority.

 I don't make the rules for the release schedule, I am just outlining
the facts - which includes correcting the false reasoning of the
original bug reporter that it wouldn't be possible to connect to the
official servers anymore with 1.6.

> Having the chance to install multiple versions of wesnoth may
> be a cool feature for developers, but it's completely useless for
> everyday users.

 That might be true, but it is a major difference in the packaging work
and thus a point that needs to get raised because of the way the release
works. If it will get ignored I'm fine with it, but I have been told at
the last ubuntu release that an update of wesnoth won't happen because
of major packaging changes.

> How can I expect to fix bug #1 if you don't ship new software asap?

 asap might sometimes be too early. Even the hypothetical "enemy" of bug
#1
is aware of that. Again, I'm not making the rules, I am just pointing
out the facts that there are rules in place that might hinder this wish.
There is always the option of going through the backports service - and
I do plan to offer backports for the former releases too, once I managed
to dig into the procedures for that enough.

 Thanks for understanding,
Rhonda

It's well after FeatureFreeze (see https://wiki.ubuntu.com/LucidReleaseSchedule), and new upstream versions including new features are not being accepted for lucid at this time. This will be available in maverick, and will be eligible for backport to lucid at that time.

Changed in wesnoth (Ubuntu Lucid):
importance: Undecided → Wishlist
status: New → Won't Fix
Gabe Gorelick (gabegorelick) wrote :

Also, there's always the option of packaging 1.8 via PPA.

* Gabe Gorelick <email address hidden> [2010-04-09 01:42:14 CEST]:
> Also, there's always the option of packaging 1.8 via PPA.

 Also, that option is also open to you. :)
Rhonda

Gerfried Fuchs (rhonda) on 2010-04-14
summary: - upgrade-request: version 1.8 released
+ FFe: Sync wesnoth-1.8 1:1.8-1 (universe) from Debian experimental (main)
Gerfried Fuchs (rhonda) wrote :

I got the information on #debian-motu that this package has the chance to get a FFe - thus changing the subject accordingly.

Scott Kitterman (kitterman) wrote :

Based on the IRC discussion, FFe approved. I will do the New review.. MOTU Ack.

Changed in wesnoth (Ubuntu Lucid):
status: Won't Fix → Confirmed
milestone: none → ubuntu-10.04
James Westby (james-w) wrote :

$ sync-source.py -b rhonda -S experimental wesnoth-1.8
Getting binaries for lucid...
[Updating] wesnoth-1.8 (None [Ubuntu] < 1:1.8-1 [Debian])
 * Trying to add wesnoth-1.8...
2010-04-14 20:47:32 INFO - <wesnoth-1.8_1.8-1.dsc: downloading from http://ftp.debian.org/debian/>
2010-04-14 20:47:32 INFO - <wesnoth-1.8_1.8.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
2010-04-14 20:48:47 INFO - <wesnoth-1.8_1.8-1.diff.gz: downloading from http://ftp.debian.org/debian/>

Changed in wesnoth (Ubuntu Lucid):
status: Confirmed → Fix Released
affects: wesnoth (Ubuntu Lucid) → wesnoth-1.8 (Ubuntu Lucid)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers