Incorrect SymLink causes build failures in other packages

Bug #1455275 reported by TJ on 2015-05-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
werken.xpath (Debian)
Fix Released
Unknown
werken.xpath (Ubuntu)
High
Unassigned
Precise
High
Unassigned
Trusty
High
Unassigned

Bug Description

[Impact]

Due to an incorrect symlink created in the package, using this Java library with another Java application (or, in this case, building Gradle) will fail.

[Test Case]

The simplest would be to use this library in some way. The only application that I personally know of that uses this library is Gradle. ("apt-cache rdepends libwerken.xpath-java" says that this library is also used in velocity.)

[Regression Potential]

Minimal. This is fixing a symlink created by the package, and (at least as of Vivid) this package is used in only one other package.

[Original Description]

This affects Trusty and possibly others. I hit it whilst backporting JavaFX (openjfx):

Execution failed for task ':graphics:classes'.
> Could not list contents of '/usr/share/java/werken.xpath.jar'.

The package installs an incorrect symbolic link when trying to alias the alternative hyphen and dot-separated names, causing packages looking for "/usr/share/java/werken.xpath.jar" to fail to build.

$ ls -l /usr/share/java/werken*
-rw-r--r-- 1 root root 76418 Jan 27 2012 /usr/share/java/werken-xpath-0.9.4.jar
lrwxrwxrwx 1 root root 22 Jan 27 2012 /usr/share/java/werken-xpath.jar -> werken-xpath-0.9.4.jar
lrwxrwxrwx 1 root root 22 Jan 27 2012 /usr/share/java/werken.xpath.jar -> werken.xpath-0.9.4.jar

The manual work-around is to fix the link:

$ sudo ln -fs /usr/share/java/werken-xpath-0.9.4.jar /usr/share/java/werken.xpath.jar

$ ls -l /usr/share/java/werken*
-rw-r--r-- 1 root root 76418 Jan 27 2012 /usr/share/java/werken-xpath-0.9.4.jar
lrwxrwxrwx 1 root root 22 Jan 27 2012 /usr/share/java/werken-xpath.jar -> werken-xpath-0.9.4.jar
lrwxrwxrwx 1 root root 38 May 15 00:42 /usr/share/java/werken.xpath.jar -> /usr/share/java/werken-xpath-0.9.4.jar

Related branches

TJ (tj) on 2015-05-15
description: updated
description: updated
Micah Gersten (micahg) on 2015-05-22
Changed in werken.xpath (Ubuntu):
status: New → Invalid
Changed in werken.xpath (Debian):
status: Unknown → Fix Released
Micah Gersten (micahg) on 2015-05-22
Changed in werken.xpath (Ubuntu Precise):
status: New → In Progress
assignee: nobody → Micah Gersten (micahg)
importance: Undecided → High
Changed in werken.xpath (Ubuntu Trusty):
importance: Undecided → High
assignee: nobody → Micah Gersten (micahg)
status: New → In Progress
Micah Gersten (micahg) wrote :

Uploaded to precise and trusty based on the merge requests

Changed in werken.xpath (Ubuntu Precise):
status: In Progress → Fix Committed
assignee: Micah Gersten (micahg) → nobody
Changed in werken.xpath (Ubuntu Trusty):
assignee: Micah Gersten (micahg) → nobody
status: In Progress → Fix Committed

Hello TJ, or anyone else affected,

Accepted werken.xpath into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/werken.xpath/0.9.4-14ubuntu0.14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Chris J Arges (arges) wrote :

Hello TJ, or anyone else affected,

Accepted werken.xpath into precise-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/werken.xpath/0.9.4-14ubuntu0.12.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Mathew Hodson (mathew-hodson) wrote :

Verified that the correct symlink is installed with libwerken.xpath-java 0.9.4-14ubuntu0.14.04.1 in trusty-proposed.

$ apt list libwerken.xpath-java
Listing... Done
libwerken.xpath-java/trusty-proposed,now 0.9.4-14ubuntu0.14.04.1 all [installed]
$ ls -l /usr/share/java/werken*
-rw-r--r-- 1 root root 76426 Jun 3 10:38 /usr/share/java/werken-xpath-0.9.4.jar
lrwxrwxrwx 1 root root 22 Jun 3 10:38 /usr/share/java/werken-xpath.jar -> werken-xpath-0.9.4.jar
lrwxrwxrwx 1 root root 22 Jun 3 10:38 /usr/share/java/werken.xpath.jar -> werken-xpath-0.9.4.jar

tags: added: verification-done-trusty verification-needed-precise
removed: verification-needed
Changed in werken.xpath (Ubuntu):
status: Invalid → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package werken.xpath - 0.9.4-14ubuntu0.14.04.1

---------------
werken.xpath (0.9.4-14ubuntu0.14.04.1) trusty; urgency=low

  * Fix symlink to werken.xpath.jar (LP: #1455275).

 -- Saikrishna Arcot <email address hidden> Fri, 15 May 2015 19:23:02 -0500

Changed in werken.xpath (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for werken.xpath has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in werken.xpath (Ubuntu):
importance: Undecided → High

The fix for this bug has been awaiting testing feedback in the -proposed repository for precise for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate

The version of werken.xpath in the proposed pocket of Precise that was purported to fix this bug report has been removed because the bugs that were to be fixed by the upload were not verified in a timely (105 days) fashion.

tags: removed: verification-needed-precise
Changed in werken.xpath (Ubuntu Precise):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.