websockify installs no importable python module

Bug #1060374 reported by Adam Gandelman on 2012-10-02
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
websockify (Ubuntu)
Undecided
Unassigned

Bug Description

The websockify's only purpose ATM is to serve as a dependency of nova's VNC services, specifically nova-novncproxy, however, it does not currently install any python module and the nova service fails to start because of an ImportError.

# apt-get -y install websockify ; python -c 'import websockify'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named websockify

Related branches

Adam Gandelman (gandelman-a) wrote :

Looks like the upstream source tree's use of setuptools is broken?

Neither websockify.py (which is a symlink to websockify binary in the source tree) or websocket.py end up in /usr/share/ after running setup.py.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in websockify (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package websockify - 0.2~20121002-0ubuntu1

---------------
websockify (0.2~20121002-0ubuntu1) quantal; urgency=low

  * New upstream release. (LP: #1060374)
 -- Chuck Short <email address hidden> Tue, 02 Oct 2012 13:39:54 -0500

Changed in websockify (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers