Please add webp loader to gdk-pixbuf

Bug #1864215 reported by Akkana Peck
106
This bug affects 23 people
Affects Status Importance Assigned to Milestone
gdk-pixbuf
Fix Released
Unknown
gdk-pixbuf (Baltix)
Triaged
Low
Unassigned
webp-pixbuf-loader (Debian)
Fix Released
Unknown
webp-pixbuf-loader (Ubuntu)
Fix Released
Wishlist
Unassigned

Bug Description

Attempting to load a webp image -- for instance,
  https://images.theweek.com/sites/default/files/styles/tw_image_9_4/public/FKK78W.jpg.webp
or
  https://cdn.vox-cdn.com/thumbor/2YtWB5zH7sPycyc0FYv3JSB6SFw=/60x0:1140x720/920x613/filters:focal(60x0:1140x720):format(webp)/cdn.vox-cdn.com/uploads/chorus_image/image/49663815/timburton.0.0.jpg
-- in a gdk-pixbuf app results in a "Couldn’t recognize the image file format" error.

Bug 1318327 covers this issue in eye of gnome, and bug 1407644 in libwebp, but isn't this really a gdk-pixbuf issue? If it really does belong to libwebp, my apologies, please dup this bug to 1407644 (I'm confident it doesn't belong to eog since I don't use that program; I have other programs that use libgdk-pixbuf).

You can probably use eog to test this, or run
/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders | grep -i webp
(I assume the loader would mention webp if there was a loader for it).

I have these packages installed in addition to libgdk-pixbuf2.0-0: libwebp-dev libwebp6 libwebpdemux2 libwebpmux3 webp. file recognizes the format:

$ file /tmp/FKK78W.jpg.webp
/tmp/FKK78W.jpg.webp: RIFF (little-endian) data, Web/P image, VP8 encoding, 1200x533, Scaling: [none]x[none], YUV color, decoders should clamp

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: libgdk-pixbuf2.0-0 2.40.0+dfsg-1build1
ProcVersionSignature: Ubuntu 5.3.0-40.32-generic 5.3.18
Uname: Linux 5.3.0-40-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu8.4
Architecture: amd64
Date: Fri Feb 21 08:48:36 2020
InstallationDate: Installed on 2019-10-10 (133 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Beta amd64 (20190926.1)
SourcePackage: gdk-pixbuf
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Akkana Peck (akkzilla) wrote :
Revision history for this message
Akkana Peck (akkzilla) wrote :

See also bug #1407644 (libwebp) and bug #1318327 (eog). Still a problem in focal fossa.

tags: added: focal
Changed in gdk-pixbuf (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdk-pixbuf (Ubuntu):
status: New → Confirmed
Changed in gdk-pixbuf (Baltix):
milestone: none → baltix-18.04
importance: Undecided → Low
status: New → Triaged
Changed in debian:
status: Unknown → New
Revision history for this message
tudo75 (tudo75) wrote :
Revision history for this message
Jonathan Yip (helkaluin) wrote :

In case you don't want to wait for aruiz's loader to be packaged in Debian (and then trickled down to Ubuntu), here's a PPA:
https://code.launchpad.net/~helkaluin/+archive/ubuntu/webp-pixbuf-loader

Changed in gdk-pixbuf:
status: Unknown → Fix Released
Revision history for this message
Marcos Alano (mhalano) wrote :

The correction was released? the pixbuf-loader was packaged in Ubuntu?

Revision history for this message
Vivien GUEANT (vivienfr) wrote :

The webp-pixbuf-loader package is still not available with Ubuntu 22.04 LTS. It is impossible to view a WebP image, except to open it with Firefox.

It is really important to add WebP format natively in Uuntu.

Revision history for this message
Sebastien Bacher (seb128) wrote :

No it's not fixed, the upstream gdk-pixbuf task got closed because they don't want to accept new loaders in source so it needs to be fixed in another component.

We should probably push to integrate it as a new package at some point but there hasn't been high demand for it so far and it's not frequent to find webp images yet which means it's still a low priority item.

Revision history for this message
Sebastien Bacher (seb128) wrote :

webp-pixbuf-loader is in the Debian new queue now, https://ftp-master.debian.org/new.html

tags: added: dt-394
Revision history for this message
Jeremy Bicha (jbicha) wrote :

webp-pixbuf-loader was just packaged for Ubuntu 22.10 (which will be released in October). If you install that package, you can open webp files in eog, etc.

affects: gdk-pixbuf (Ubuntu) → webp-pixbuf-loader (Ubuntu)
Changed in webp-pixbuf-loader (Ubuntu):
status: Confirmed → Fix Released
affects: debian → webp-pixbuf-loader (Debian)
Changed in webp-pixbuf-loader (Debian):
status: New → Fix Released
Revision history for this message
Sebastien Bacher (seb128) wrote :
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.