[SRU] New stable release 2.4.2

Bug #1313584 reported by Iain Lane on 2014-04-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
webkitgtk (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Iain Lane

Bug Description

[ Description ]

We should track the stable releases of webkitgtk to get upstream bug fixes

What's new in WebKitGTK+ 2.4.2?

  - Correctly handle TLS errors in case of a server redirection.
  - Fix a crash when submitting a form.
  - Fix several JavaScriptCore crashes when browsing facebook.
  - Fix a crash when closing a page with windowed plugins.
  - Fix a crash after getting web view context property with g_object_get.
  - Fix a new[] delete[] mismatch in SocketStreamHandleSoup.

What’s new in the WebKitGTK+ 2.4.1 release?

    Add CORS support for media elements to GStreamer media backend.
    Fix wrong flags used in fcntl call that failed in FreeBSD.
    Correctly handle HTTP authentication for cross-origin requests.
    Correctly handle cookies for cross-origin requests.
    Fix a crash in the plugin process with some plugins that redefine NPN functions.
    Fix acceletared video when the video format has an alpha component.
    Fix sites using geolocation after reloading when using Geoclue2.
    Append Safari version to UserAgent to fix redirections in www.globalforestwatch.org.

[ Development release ]

Identical (modulo changelog) package uploaded to U already.

[ QA ]

Test many reverse dependencies and verify they still work as before.

[ Regression Potential ]

One of the upstream fixes could introduce a bug. I'll be subscribed to the package so hopefully will notice.

Iain Lane (laney) on 2014-04-28
Changed in webkitgtk (Ubuntu):
status: New → Fix Released
Changed in webkitgtk (Ubuntu Trusty):
status: New → In Progress
assignee: nobody → Iain Lane (laney)
Iain Lane (laney) wrote :

There's a couple of new patches over Trusty in this SRU. They came from Debian and should be safe, but we can remove them if you'd prefer.

Iain Lane (laney) wrote :

I've just uploaded the next point release since the first was still in the queue. I did decide to remove the Debian patches that we don't need in Trusty, so there's just one changed patch which is a reworking of one we already had.

description: updated
summary: - [SRU] New stable release 2.40.1
+ [SRU] New stable release 2.4.2

Hello Iain, or anyone else affected,

Accepted webkitgtk into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/webkitgtk/2.4.2-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in webkitgtk (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

I've been using that version for some weeks without issue, changing to verification-done

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for webkitgtk has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webkitgtk - 2.4.2-1ubuntu0.1

---------------
webkitgtk (2.4.2-1ubuntu0.1) trusty; urgency=medium

  * SRU upstream bugfix release to Trusty (LP: #1313584)
  * Merge with Debian. Remaining changes:
    - Build for ppc64el and arm64
    - bugzilla_clear_surface.patch: Take patch to fix upstream bug#123480
      which was a crash affecting software-center in Ubuntu.
    - Don't use COMPARE_AND_SWAP and other snippets of asm on arm64; the
      compiler complains that they are invalid.
  * Reverted unwanted changes from unstable:
    - debian/control:
      + Require make 4.0, which is the version that can make parallel builds
        of webkitgtk.
    - debian/patches/x32_support.patch:
      + Fix FTBFS in x32
    - debian/patches/local-label-string-hurd.patch:
      + Fix FTBFS in hurd-i386.

webkitgtk (2.4.2-1) unstable; urgency=medium

  * New upstream release (Closes: #732095).
  * debian/rules:
    + Enable parallel builds again (Closes: #746959).
  * debian/control:
    + Require make 4.0, which is the version that can make parallel builds
      of webkitgtk.
  * debian/patches/fix-jsc-crash.patch:
    + Removed, this is already included in this release.

webkitgtk (2.4.1-2) unstable; urgency=medium

  * Release to unstable (Closes: #731229, #662081).
  * debian/gbp.conf:
    + Change debian-branch to unstable.
  * debian/patches/x32_support.patch:
    + Fix FTBFS in x32 (Closes: #700795).
  * debian/patches/fix-jsc-crash.patch:
    + Fix crash in JSC.
 -- Iain Lane <email address hidden> Wed, 14 May 2014 10:21:01 +0100

Changed in webkitgtk (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers