Please sync webkitgtk 2.0.4 from Debian

Bug #1186558 reported by Jeremy Bicha on 2013-06-01
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
webkit (Debian)
Fix Released
Unknown
webkitgtk (Ubuntu)
Wishlist
Iain Lane

Bug Description

WebKitGTK 2.0 is a dependency of Epiphany 3.8. The webkitgtk developers have now enabled webkit2 by default (and dropped the previous webkit api to maintenance mode). The Debian packaging enables both webkit and webkit2. Note that Debian has changed the source package name from webkit to webkitgtk to match upstream's name change.

http://ftp-master.metadata.debian.org/changelogs/main/w/webkitgtk/experimental_changelog

  * Dropped changes:
    - debian/control:
      + Explicitly BD on libxcomposite-dev and libxdamage-dev
    - debian/rules:
      + Disable jit on armhf too
      + use -Wl,--reduce-memory-overheads to fix LP builder timeout

* TODO: libwebp needs an approved MIR (LP: #1186553)
* TODO: Fix Software Center crash (LP: #1163886)

Available now in the GNOME 3 PPA for Raring or Saucy
Packaging at https://code.launchpad.net/~gnome3-team/gnome3/ubuntu

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: libwebkitgtk-1.0-0 1.10.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.9.0-2.7-generic 3.9.3
Uname: Linux 3.9.0-2-generic x86_64
ApportVersion: 2.10.2-0ubuntu1
Architecture: amd64
Date: Sat Jun 1 10:24:24 2013
MarkForUpload: True
SourcePackage: webkit
UpgradeStatus: Upgraded to saucy on 2013-05-07 (24 days ago)

Jeremy Bicha (jbicha) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in webkit (Ubuntu):
status: New → Confirmed
Adam Dingle (adam-yorba) wrote :

Should I mark the existing bug #1178769 as a duplicate of this one?

Sebastien Bacher (seb128) wrote :

Jeremy, your changelog snippet suggest you got that merge done somewhere, can you share it (the bug has no vcs, ppa or diff,

Jeremy Bicha (jbicha) wrote :

Seb, my latest is in https://launchpad.net/~jbicha/+archive/dev/
We were having trouble with getting the .symbols files right so I hadn't posted it to this bug yet.

Jeremy Bicha (jbicha) on 2013-06-22
summary: - Please merge webkitgtk 2.0.2 from Debian
+ Please merge webkitgtk 2.0.3 from Debian
description: updated
Jeremy Bicha (jbicha) on 2013-06-22
description: updated

Jeremy, what's the situation on that?

Jeremy Bicha (jbicha) wrote :

Seb, I think there are 3 remaining things to do:
1. Test-build on armhf
2. Approve the libwebp MIR (LP: #1186553)
3. Run for a few days in the ~ubuntu-desktop PPA to see if any of our core apps have issues with the new webkit

Jeremy Bicha (jbicha) on 2013-06-24
description: updated
Sebastien Bacher (seb128) wrote :

build on armhf works fine it seems (well, it failed on the ppa where I tried it due to dh_strip resources usage, http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=711750 ... but build was done), runtime seems fine on i386

Jeremy Bicha (jbicha) wrote :

Please note that I now believe the heavily-duplicated bug 1163886 is triggered by the WebKit update.

Jackson Doak (noskcaj) wrote :

2.1.3 is now out, should the bug be edited for it?

Changed in webkit (Debian):
status: Unknown → New
Jackson Doak (noskcaj) wrote :

Fixed in debian

Jackson Doak (noskcaj) wrote :

It has issues on some architectures though

Changed in webkit (Debian):
status: New → Fix Released
Jeremy Bicha (jbicha) on 2013-08-13
summary: - Please merge webkitgtk 2.0.3 from Debian
+ Please merge webkitgtk 2.0.4 from Debian
description: updated
Jeremy Bicha (jbicha) on 2013-08-13
description: updated

The latest Debian release (2.0.4-1) builds much better on the PPA builders (it built the first time instead of needing retries).

However, since I don't have powerpc hardware and the PPAs don't build for powerpc, there's no way I can guarantee that this version of webkit will build on Ubuntu (it fails on Debian). And I don't have enough porting experience to fix it if it does fail to build. I can't be sure that anyone else in Ubuntu will care enough to fix the build failure either. So unless the powerpc build is fixed in Debian soon, I think we'll have to wait until early in the 14.04 cycle to do this upload.

Jeremy Bicha (jbicha) wrote :

We can sync webkitgtk from Debian since the latest Debian release includes the last bit of diff Ubuntu was carrying. It also builds on powerpc now.

Bug 1163886 (Software Center crash) should probably be fixed first but dobey was having trouble duplicating it (the bug may not affect faster hardware) and may need help fixing it. libwebp needs a team subscribed to its bugs (bug 1186553).

summary: - Please merge webkitgtk 2.0.4 from Debian
+ Please sync webkitgtk 2.0.4 from Debian
description: updated
Iain Lane (laney) on 2013-10-28
Changed in webkit (Ubuntu):
assignee: nobody → Iain Lane (laney)
Iain Lane (laney) wrote :

Still needs work, but webkitgtk is in.

Changed in webkit (Ubuntu):
status: Confirmed → Fix Released
affects: webkit (Ubuntu) → webkitgtk (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.