libjavascriptcoregtk-4.0-dev: missing jsc/jsc.h

Bug #1795901 reported by Cody Garver
368
This bug affects 22 people
Affects Status Importance Assigned to Milestone
webkit2gtk (Debian)
Fix Released
Unknown
webkit2gtk (Ubuntu)
Fix Released
High
Unassigned
Bionic
Fix Released
High
Marc Deslauriers

Bug Description

2.22.2-0ubuntu0.18.04.1, just like https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=906519

/usr/include/webkitgtk-4.0/webkit2/WebKitJavascriptResult.h:28:10: fatal error: jsc/jsc.h: No such file or directory
 #include <jsc/jsc.h>
          ^~~~~~~~~~~

Cody Garver (codygarver)
description: updated
tags: added: bionic
Revision history for this message
minimalprocedure (zairik) wrote :

the same for me.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in webkit2gtk (Ubuntu):
status: New → Confirmed
Revision history for this message
Cesar A. Quiroz (cesar-quiroz) wrote :

Getting this while building emacs/master.

Revision history for this message
Matías Moreno (matonga) wrote :

Getting this while building komorebi from sources.

Revision history for this message
Anatoliy Kashkin (tkashkin) wrote :

Getting same error while building my app. I have tried some workarounds to build against older version, but nothing seems to work. https://launchpadlibrarian.net/391991612/buildlog_ubuntu-bionic-amd64.com.github.tkashkin.gamehub_0.11.3-5-dev~ubuntu18.04_BUILDING.txt.gz

Revision history for this message
Vlad Orlov (monsta) wrote :

Also it's impossible to build Atril, MATE's document viewer.

Revision history for this message
Max Mouratov (murmour) wrote :

I've hit this problem while trying to build Astroid (https://github.com/astroidmail/astroid).

Revision history for this message
Cassidy James Blaede (cassidyjames) wrote :

For what it's worth, this is breaking builds for several projects in elementary OS. It appears to be anything that depends on `libwebkit2gtk-4.0-dev`.

Revision history for this message
LiamG (liamg-uw) wrote :

Can't build Projucer 5.3.1 on Ubuntu because of this bug.

https://shop.juce.com/get-juce

Revision history for this message
Corentin Noël (tintou) wrote :

I can't build evolution-data-server because of this

Revision history for this message
Albrecht Dreß (albrecht-dress) wrote :

Rolling back to the previous version re-enables building applications w/ webkit (Balsa in my case):

sudo apt-get install libwebkit2gtk-4.0-dev=2.20.1-1 libwebkit2gtk-4.0-37=2.20.1-1 gir1.2-webkit2-4.0=2.20.1-1 libjavascriptcoregtk-4.0-dev=2.20.1-1 gir1.2-javascriptcoregtk-4.0=2.20.1-1 libjavascriptcoregtk-4.0-18=2.20.1-1

Revision history for this message
Siddhartha Das (bablu-boy) wrote :

Cannot build Bookworm on bionic as it depends on libwebkit2gtk-4.0-dev.
https://travis-ci.org/babluboy/bookworm/jobs/438368035#L3750

I hit this while trying to release Bookworm for Elementary OS Juno which is based on bionic.

Jeremy Bicha (jbicha)
information type: Public → Public Security
Changed in webkit2gtk (Ubuntu Bionic):
status: New → Confirmed
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in webkit2gtk (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webkit2gtk - 2.22.2-0ubuntu0.18.04.2

---------------
webkit2gtk (2.22.2-0ubuntu0.18.04.2) bionic-security; urgency=medium

  * Install missing headers (LP: #1795901)
    - debian/libjavascriptcoregtk-4.0-dev.install: install headers from
      usr/include/webkitgtk-4.0/jsc/.
  * Install missing documentation
    - debian/libwebkit2gtk-4.0-doc.doc-base.*
    - debian/libwebkit2gtk-4.0-doc.install
    - debian/libwebkit2gtk-4.0-doc.links
    - debian/rules: use dh_missing --fail-missing

 -- Marc Deslauriers <email address hidden> Tue, 09 Oct 2018 07:13:22 -0400

Changed in webkit2gtk (Ubuntu Bionic):
status: Confirmed → Fix Released
Revision history for this message
Vlad Orlov (monsta) wrote :

Thanks, Atril builds fine now.

Mathew Hodson (mhodson)
Changed in webkit2gtk (Ubuntu):
importance: Undecided → High
Changed in webkit2gtk (Ubuntu Bionic):
importance: Undecided → High
affects: webkit-open-source → ubuntu-translations
Changed in ubuntu-translations:
importance: Unknown → Undecided
status: Unknown → New
no longer affects: ubuntu-translations
Mathew Hodson (mhodson)
tags: added: packaging regression-update
Changed in webkit2gtk (Debian):
status: Unknown → Fix Released
Revision history for this message
Matías Moreno (matonga) wrote :

Got the libwebkit2gtk-4.0-dev:amd64=2.22.2-0ubuntu0.18.04.2 update and komorebi compiled successfuly. Thank you!

To post a comment you must log in.
This report contains Public Security information  
Everyone can see this security related information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.