GStreamer-WARNING **: wrong STREAM_LOCK count 0 after changing HTML5 video.src

Bug #906784 reported by Jason Gerard DeRose on 2011-12-20
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
PiTiVi
New
Undecided
Unassigned
Webkit
Fix Released
Medium
webkit (Ubuntu)
Undecided
Unassigned

Bug Description

I'm using WebKitGtk (with PyGI and Python3, although my hunch is that's irrelevant) for a video browser.

Playback using the <video> element works awesome, but when I switch from one video to the next by changing the video.src from the DOM with JavaScript, I get this error in the terminal:

GStreamer-WARNING **: wrong STREAM_LOCK count 0

Once this happens, the app freezes up. The next video doesn't play, and I can't do anything... not even close the app. After the timeout, I can force quite.

Haven't yet spotted a pattern to this. It doesn't happen every time... sometimes I can play, say 5 videos or so before this happens.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libwebkitgtk-3.0-0 1.6.1-5build1
ProcVersionSignature: Ubuntu 3.2.0-6.12-generic 3.2.0-rc6
Uname: Linux 3.2.0-6-generic x86_64
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
Date: Tue Dec 20 02:08:35 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.2)
SourcePackage: webkit
UpgradeStatus: Upgraded to precise on 2011-12-01 (18 days ago)

Jason Gerard DeRose (jderose) wrote :
Changed in webkit:
importance: Unknown → Medium
status: Unknown → New
Kamil Rowiński (spajderix) wrote :

Noticed this in exaile. If I fast forward in a track for a few times player freezes, and on a debug I get: GStreamer-WARNING **: wrong STREAM_LOCK count 0
Ubuntu 12.04 64bit
Exaile 0.3.2.2-2

Jacob Peddicord (jpeddicord) wrote :

To add to the above comment, I don't believe this is a bug in WebKit, but GStreamer. I've filed #941229, please add your thoughts there if you think it affects you.

Jason Gerard DeRose (jderose) wrote :

Yeah, this is starting to look like a GStreamer bug. Unless both WebKit and Exaile are doing something similar (and perhaps wrong) that's triggering this.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in webkit (Ubuntu):
status: New → Confirmed
Changed in webkit:
status: New → Fix Released
kaefert (kaefert) wrote :

I've repeatedly ran into this issue in the last few hours.
I'm running:
PiTiVi 0.15.2 (package "pitivi" version 0.15.2-0ubuntu1 )
Ubuntu 12.10 (Linux Mint 14)

kaefert (kaefert) wrote :

does "Fix Released" mean, that you need to build gstreamer from source to get the fix, or would upgrading to ubuntu 13.04 give me an updated binary package of it that contains the fix already?

Pavan (pavan42800) wrote :

I upgraded ubuntu to 13.10 and still the problem exists. So @kaefert upgrading doesn't help. Any other fix you could find?

kaefert (kaefert) wrote :

@Pavan I've found a solution for all my video editing that is better than everything else I've seen before (combined!) --> Avisynth (running though wine)
@everybody else: sorry for the off-topic comment

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.