Mark libwebkitgtk-1.0-common as "Multi-Arch: foreign"

Bug #1185771 reported by Simon K on 2013-05-30
104
This bug affects 23 people
Affects Status Importance Assigned to Milestone
webkit (Ubuntu)
Undecided
Unassigned

Bug Description

I have a 64bit System and wanted to install 32bit libwebkit-gtk-1.0-0.

To archive this libwebkitgtk-1.0-common has to be marked as "Multi-Arch: foreign", this packages contains JavaScript files and is one package for all architectures (Architecture: all)

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: libwebkitgtk-1.0-0:i386 (not installed)
Uname: Linux 3.8.8-030808-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
Date: Thu May 30 12:42:05 2013
EcryptfsInUse: Yes
InstallationDate: Installed on 2013-04-01 (59 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130328)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: webkit
UpgradeStatus: No upgrade log present (probably fresh install)

Simon K (octav14n) wrote :
Simon K (octav14n) on 2013-05-31
summary: - dependency on libwebkitgtk-1.0-common:i386
+ Mark libwebkitgtk-1.0-common as "Multi-Arch: foreign"
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in webkit (Ubuntu):
status: New → Confirmed
Andrey Dedikov (iamawesome-ndr) wrote :

Also affects 12.04

Artur Krysiak (ventharin) wrote :

also affects 13.10

AleksK (aleks-kaverin) wrote :

also affects 14.04 alpha1

James Lewis (james-fsck) wrote :

Also confirmed in 14.04 as of 1 March 2014.

James Lewis (james-fsck) wrote :

Note that this prevents the installation of the Citrix receiver client on Ubuntu.... since Citrix have not seen fit to grace us with a real 64 bit pacakge, and so their software requires the package described above.

My workaround for the Citrix receiver was to install the 32bit version, as the 64bit package is just the same 32bit software with different requirements.
I also had to rebuild libwebkitgtk and libwebkitgtk-common with a different control file.

Yeah, if you don't need the UI, but go through a citrix web frontend, then you can ignore that dependency, still it would be preferred to see it fixed as it looks mildly useful.

Note that the 64bit Citrix package is a joke as it doesn't declare any of its (32bit) dependencies. Still their packaging has come a long way, so see it fail due to a ubuntu bug is unfortunate.

Sidenote: for us this affects >1000 users and we have to work around by repackaging the binary and removing that dependency and functionality.

James Lewis (james-fsck) wrote :

Thomas, can you help us understand what the functionality issue is, my interpretation of the OP's description is that it's a packaging issue which simply needs a flag changed in the package. What have I missed?

I think we've drifted too much into the Citrix specifics in the recent comments (as their packages are affected by this bug).

Yes, it's just the flag and we really hope to see this fixed for 14.04 as it's an LTS and we'll be rolling that out to many users.

To explain what I meant in my comment #9:
If you can't install libwebkitgtk-1.0-common:i386 on your system, but either force installation of Citrix client or ignore the dependency, then one part of it won't work. Namely this is the "/opt/Citrix/ICAClient/selfservice" binary which tries to dlopen libwebkit-1.0.so. This is a UI application that helps the user to log on to a Citrix environment.

What still works is the 'wfica' client binary itself, you just need to have a config file to feed to it. You can get that config file e.g. through logging on to the web interface of a citrix setup with a webbrowser.
So you can establish a remote session.

Simon K (octav14n) wrote :

@james-fsck, the bug I mentioned is fixed for me on 14.04 (2014-March-06)
I don't know exactly when this fix happened but version "2.3.90-1" should have the required flag.

libwebkitgtk-1.0-0:i386 however isn't able to install because of broken dependencies. But that has to go in an other bug-report.

So, my point of view is: this bug has been fixed by upgrading to upstream version "2.3.90-1", which is in Ubuntu 14.04 LTS

Simon K (octav14n) wrote :

OK, since i didn't get any response, i closed the bug.
for details see post #12.

If anyone is still experiencing this bug in Ubuntu 14.04 with the latest updates, please feel free to reopen this bug report.

Changed in webkit (Ubuntu):
status: Confirmed → Fix Released
James Lewis (james-fsck) wrote :

Apologies for delay, I have not been around to check this, but I see similar results... I now cannot install due to dependency issues of a different type... is there a bug logged separately for these elsewhere, or should I try to log one?

Simon K (octav14n) wrote :

I've not opened a bug report. So go ahead.

Edb (homemadejam) wrote :

This doesn't seem fixed for me on 14.04 - the Citrix installation still fails. Is this an issue with Citrix or Ubuntu?

Citrix lists the issue as one with Ubuntu.

Melroy vd Berg (openlaptop) wrote :

Same issue as Edb, can't start Citrix anymore running Linux Mint (Ubuntu), with the error:
libwebkit: libwebkit-1.0.so: cannot open shared object file: No such file or dir

k-m (k-m) wrote :

still same issue here

Does bug this have any attention?
Looks like nothing happened a long time.

The link in the Status field should at least point to information how it is fixed, where we can test the fix or something similar.

Greggth (greggth) wrote :

I don't see how this is fixed either. Trying to install Citrix on my 64-bit Ubuntu 12.04 still fails with this webkit error. Could you include instructions on how to install the correct version of Webkit?

$ /opt/Citrix/ICAClient/selfservice
libwebkit: libwebkit-1.0.so: cannot open shared object file: No such file or directory

SirWeazel (sirweazel) wrote :

How was this bug fixed? Please give a little more info. I understand citrix is its own issue, but i'm curious about the libwebkit 32bit install on 64bit.

Also, for the citrix error. I tried creating a symlink. I put the link for libwebkit-1.0.so in /usr/lib and pointed it to /usr/lib/x86_64-linux-gnu/libwebkitgtk-3.0.so.0 but recieved elf class error. I also tried pointing it to the 1.0 version with a elf class error. I think this is because i was pointing 32bit at 64bit version.

I'm probably just overlooking something. How do i get the 32bit version installed on 64bit OS. I haven't had any other issues installing 32bit stuff.

Simon K (octav14n) wrote :

This bug report was about the package "libwebkitgtk-1.0-common". This happened already so the case of this bug is closed (marked as "fixed").

If you still have problems installing software you should open a new bug-report.
Feel free to link to this (new) bug in this activity log/thread so other users will find your report.

As I see it, many have problems with some Citrix program. I don't have a Citrix architecture I can test on so I can't really fill this new bug report.

q4a (q4a) wrote :

We have a lot of problems without "Multi-Arch: foreign" mark: all packages that provide myspell-dictionary, aspell-dictionary, ispell-dictionary or hunspell-dictionary should have it.
Please, check and vote: https://bugs.launchpad.net/ubuntu/+source/aspell-en/+bug/1096669

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers