[regression] webbrowser_app.tests.test_basic_authentication fail with latest UITK

Bug #1664620 reported by Olivier Tilloy on 2017-02-14
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-ui-toolkit (Ubuntu)
High
Olivier Tilloy
webbrowser-app (Ubuntu)
Undecided
Unassigned

Bug Description

Running webbrowser-app on desktop xenial+overlay, I'm seeing the following autopilot tests fail:

webbrowser_app.tests.test_basic_authentication.TestBasicAuthentication.test_wrong_credentials
webbrowser_app.tests.test_basic_authentication.TestBasicAuthentication.test_right_credentials
webbrowser_app.tests.test_basic_authentication.TestBasicAuthentication.test_cancel

Indeed, when browsing to e.g. https://www.httpwatch.com/httpgallery/authentication/ and clicking the "DISPLAY IMAGE" button, no dialog is shown, and I’m seeing the following error in the logs:

file:///usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Components/Popups/1.3/popupUtils.js:75: TypeError: Cannot read property 'activeFocusItem' of null

Related branches

Olivier Tilloy (osomon) wrote :

From a quick look at the latest UITK landing, it looks like https://bazaar.launchpad.net/~ubuntu-sdk-team/ubuntu-ui-toolkit/trunk/revision/1000.1100.3 could have introduced that regression.

Olivier Tilloy (osomon) on 2017-02-14
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Olivier Tilloy (osomon)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
tags: added: unity8
Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.2184+17.04.20170306

---------------
ubuntu-ui-toolkit (1.3.2184+17.04.20170306) zesty; urgency=medium

  [ Adnane Belmadiaf ]
  * Add support for CheckBox label when set
  * Add more tests for checkbox. Fixes LP: #1333228, LP: #1442851.
  * Make sure we resets partial text input from the input method.
    Fixes LP: #1630872.
  * Fix ListItem title/subtitle alignment & elide in RTL mode.
    Fixes LP: #1665944.
  * Fix PageHeader title alignment & elide in RTL mode. Fixes LP: #1665942.
  * Fix UbuntuListView docs. Fixes LP: #1486940.
  * Add count prop to OptionSelector. Fixes LP: #1341559.
  * Replace the hardcoded color with a theme color. Fixes LP: #1664758.
  * Fix the import statement for Menu, MenuBar and MenuGroup.
    Fixes LP: #1660604.

  [ Albert Astals Cid ]
  * Fix memory leak in UCStyleHints
  * ThinDivider: Anchors can't be null, set to undefined
  * No need to call UCUnits::resolveResource to learn we just need to load it
    normally because the fact that we already loaded it normally means we need
    to load it normally. Fixes LP: #1558663.
  * Fix conditional jump or move depends on uninitialised value(s)

  [ Christian Dywan ]
  * Initialize UCApplication with no side effects. Fixes LP: #1662868.
  * Unit test case insensitive FilterBehavior.pattern. Fixes LP: #1663924.
  * ListItemPopover delegate should (in)visible as per action Bug 1662220:
    [ListItem] Popupmenu shows traces of disabled actions

  [ Olivier Tilloy ]
  * Check that window is not null before accessing its activeFocusItem property.
    Fixes LP: #1664620.

  [ Lukáš Tinkl ]
  * Unbreak the startup race between unity8/qtmir and UITK trying talk to
    content-hub. Fixes LP: #1663106.

 -- Zoltán Balogh <email address hidden> Mon, 06 Mar 2017 16:04:56 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers