browser stops rendering all pages instead shows new tab page

Bug #1659435 reported by Bill Filler on 2017-01-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Oxide
Undecided
Unassigned
webbrowser-app (Ubuntu)
Critical
Florian Boucault

Bug Description

running unity8 deb session on my laptop, with latest xenial + overlay

Browsing as normal, with 5 or 6 tabs open. All pages are rendering fine. Then when I click on a link in a page that opens a new tab, I get the new tab but the page is not displayed. It just displays the Top Sites, Bookmarks placeholder page. The url field has the correct url and the tab title is correct but the contents of the page never renders. Even when I press reload.

What is worse, every tab then has this problem. None will show the page content, all show the Top Sites, Bookmark page.

Attached is browser log, here are the relevant packages installed.

bfiller1@blackhorse1:~$ dpkg -l | grep oxide
ii liboxideqt-qmlplugin:amd64 1.19.7-0ubuntu0.16.04.1+overlay1 amd64 Web browser engine for Qt (QML plugin)
ii liboxideqtcore0:amd64 1.19.7-0ubuntu0.16.04.1+overlay1 amd64 Web browser engine for Qt (core library and components)
ii liboxideqtquick0:amd64 1.19.7-0ubuntu0.16.04.1+overlay1 amd64 Web browser engine for Qt (QtQuick library)
ii oxideqt-codecs-extra:amd64 1.19.7-0ubuntu0.16.04.1+overlay1 amd64 Web browser engine for Qt (codecs)
bfiller1@blackhorse1:~$ dpkg -l | grep webbrowser-app
ii webbrowser-app 0.23+16.04.20170110-0ubuntu1 amd64 Ubuntu web browser
bfiller1@blackhorse1:~$ dpkg -l | grep mir
ii libmiral2:amd64 1.0.2+16.04.20170118.1-0ubuntu1 amd64 Display server for Ubuntu - ABI preserving abstraction layer
ii libmirclient9:amd64 0.25.0+16.04.20161203-0ubuntu1 amd64 Display server for Ubuntu - client library
ii libmircommon5:amd64 0.22.1+16.04.20160516.2-0ubuntu1 amd64 Display server for Ubuntu - shared library
ii libmircommon7:amd64 0.25.0+16.04.20161203-0ubuntu1 amd64 Display server for Ubuntu - shared library
ii libmircookie2:amd64 0.25.0+16.04.20161203-0ubuntu1 amd64 Produce and verify spoof-resistant timestamps - runtime library
ii libmircore1:amd64 0.25.0+16.04.20161203-0ubuntu1 amd64 Display server for Ubuntu - shared library
ii libmirplatform14:amd64 0.25.0+16.04.20161203-0ubuntu1 amd64 Display server for Ubuntu - platform library
ii libmirprotobuf3:amd64 0.25.0+16.04.20161203-0ubuntu1 amd64 Display server for Ubuntu - RPC definitions
ii libmirserver42:amd64 0.25.0+16.04.20161203-0ubuntu1 amd64 Display server for Ubuntu - server library
ii mir-client-platform-mesa5:amd64 0.25.0+16.04.20161203-0ubuntu1 amd64 Display server for Ubuntu - client platform library for Mesa
ii mir-graphics-drivers-desktop:amd64 0.25.0+16.04.20161203-0ubuntu1 amd64 Display server for Ubuntu - desktop driver metapackage
ii mir-platform-graphics-mesa-kms11:amd64 0.25.0+16.04.20161203-0ubuntu1 amd64 Display server for Ubuntu - platform library for KMS Mesa
ii mir-platform-graphics-mesa-x11:amd64 0.25.0+16.04.20161203-0ubuntu1 amd64 Display server for Ubuntu - platform library for X11 Mesa
ii mir-platform-input-evdev6:amd64 0.25.0+16.04.20161203-0ubuntu1 amd64 Display server for Ubuntu - input platform library
ii qtdeclarative5-qtmir-plugin:amd64 0.5.1+16.04.20170124-0ubuntu1 amd64 Qt plugin for Unity specific Mir APIs
ii qtmir-desktop:amd64 0.5.1+16.04.20170124-0ubuntu1 amd64 Qt platform abstraction (QPA) plugin for a Mir server (desktop)
ii xmir 2:1.18.4-0ubuntu0.2 amd64 Xmir X server
bfiller1@blackhorse1:~$ dpkg -l | grep unity8
ii account-plugin-irc-unity8 0.1+16.04.20170123.2-0ubuntu1 all Online account plugin for unity8
ii account-plugin-sip-unity8 0.1+16.04.20170123.2-0ubuntu1 all Online account plugin for unity8
ii policykit-unity8 0.1+16.04.20161130-0ubuntu1 amd64 service to prompt for policy kit permissions
ii unity8 8.15+16.04.20170124-0ubuntu1 amd64 Unity 8 shell
ii unity8-common 8.15+16.04.20170124-0ubuntu1 all Unity 8 shell (common files)
ii unity8-desktop-session 1.0.13+16.04.20170110.1-0ubuntu1 all Unity8 desktop session for Mir
ii unity8-private:amd64 8.15+16.04.20170124-0ubuntu1 amd64 Unity 8 private libs
ii unity8-session-snap 1.0.13+16.04.20170110.1-0ubuntu1 all Unity8 session from a Snap

Related branches

Bill Filler (bfiller) wrote :
Changed in webbrowser-app (Ubuntu):
importance: Undecided → Critical
Bill Filler (bfiller) wrote :

It's happened 3 times in last hour, fwiw

Seeing multiple of these messages after the problem starts:

[0125/171219:ERROR:layer_tree_host_impl.cc(2189)] Forcing zero-copy tile initialization as worker context is missing
[0125/171219:ERROR:oxide_compositor_gpu_shims.cc(258)] Error creating EGLImage: EGL_BAD_PARAMETER

Changed in webbrowser-app (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon) wrote :

I’ve just spent ~an hour browsing many different websites with many tabs open in a unity8 deb session, and haven’t experienced that issue. I’m on a fully up-to-date xenial+overlay machine.

I’ve seen the same errors in the logs when clicking links that open in new tabs, but no visual problem, so they seem to be red herrings.

Bill Filler (bfiller) wrote :

Hit this again, looks like oxide-render processes are running
http://pastebin.ubuntu.com/23912354/

Here is log from browser:
http://pastebin.ubuntu.com/23912358/

The problem occurred clicking on a link in a gmail message which attempted to open a new tab.
Note that I can long press on a tab and open in a new window and it renders correctly. I can also create a new private window and that works correctly, so seems to be an issue only with the main window and not oxide rendering per se

Olivier Tilloy (osomon) wrote :

I initially thought the following error could be related:

  file:///usr/share/webbrowser-app/webbrowser/TabComponent.qml:259: ReferenceError: tabContainer is not defined

but apparently not, as I’m getting it too without observing the issue.

Olivier Tilloy (osomon) on 2017-02-02
Changed in oxide:
status: New → Invalid
Olivier Tilloy (osomon) wrote :

Attaching video demonstrating the issue, courtesy of Bill.

It’s clearly the new tab view that is incorrectly being overlaid on top of the actual webview. This apparently happens when clicking a link that opens a new tab, although there must be another factor at play because I haven’t been able to observe the issue myself.

Olivier Tilloy (osomon) wrote :

The new tab view is superimposed on the webview when newTabViewLoader.active is true.
When switching tabs, the following code (in Browser.qml) is responsible for unloading the new tab view if the tab we’re switching to has contents loaded:

Connections {
  target: browser
  onCurrentWebviewChanged: {
    if (currentWebview) {
      var tab = tabsModel.currentTab
      newTabViewLoader.active = !tab.url.toString() && !tab.restoreState
    }
  }
}

I’m not seeing any indication in the logs that this code fails to be executed.

Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
Changed in webbrowser-app (Ubuntu):
assignee: Olivier Tilloy (osomon) → Florian Boucault (fboucault)
status: Confirmed → In Progress
Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+17.04.20170310-0ubuntu1

---------------
webbrowser-app (0.23+17.04.20170310-0ubuntu1) zesty; urgency=medium

  [ Alexandre Abreu ]
  * Explicitely define Ctrl+R as the refresh shortcut for the browser
    (LP: #1593877)

  [ Andrew Hayzen ]
  * Use the new TabsBar component from Ubuntu.Components.Extras

  [ Florian Boucault ]
  * Add Peekier to available search engines (LP: #1649673)
  * Bookmarks and history: increased font size one level
  * Make new tabs opened in the background to be placed next to the tab
    requesting them instead of at the end of the list of tabs (LP: #1499780)
  * Enable predictive text in address bar (LP: #1378750)
  * Fix issue with new tab page sometimes never being unloaded (LP: #1659435)
  * Snap: embed ubuntu-ui-extras by building it from source
  * Improved UX for <select> dropdowns in web content
  * Store and restore on startup the size of each window (LP: #1312892)
  * Do not go fullscreen if already fullscreen (LP: #1665727)
  * Do not rely on qmake as webbrowser is CMake based

  [ Jeremy Bicha ]
  * Drop "Open a " prefix from .desktop Actions (LP: #1668699)

  [ Matthieu James ]
  * Updated browser icon (LP: #1358050)

  [ Michael Terry ]
  * Properly set the APP_ID variable for the snappy world

  [ Olivier Tilloy ]
  * Use the no-system-libraries build attribute instead of specifying extra
    stage packages
  * Move snapcraft.yaml to snap directory (new in snapcraft 2.26)
  * Add a desktop UA override for dailymotion.com (LP: #1662826)
  * Log oxide and chromium versions at app startup
  * Add UA overrides for google photos (desktop and mobile) (LP: #1665926)
  * Explicitly plug to the "mir" interface (LP: #1662145)
  * Add "ibus" and "nvidia" apparmor abstractions to webbrowser-app apparmor
    profile
  * Additional holes in generated apparmor profile to allow webbrowser-app
    to run under unity8 in zesty (LP: #1590561)

 -- Olivier Tilloy <email address hidden> Fri, 10 Mar 2017 15:35:28 +0000

Changed in webbrowser-app (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers