WebRTC: meet.jit.si videocall does not work

Bug #1635971 reported by Andrea Bernabei on 2016-10-23
70
This bug affects 15 people
Affects Status Importance Assigned to Milestone
webbrowser-app (Ubuntu)
High
Olivier Tilloy

Bug Description

krillin, rc-proposed/bq-aquaris.en channel, revision 456

I previously reported bug #1466015 about meet.jit.si not working on webbrowser-app, but that bug was marked as duplicate of another bug that is now marked as "Fix Released".
But meet.jit.si still does not work.
I'm opening a new bug since the errors in the log are different from the ones I reported in the previous bug.

How to reproduce:
1) visit meet.jit.si
2) click on Go to start a new videocall

Expected outcome:
a videocall is started

Actual outcome:
nothing happens

Additional info
Here's the content of webbrowser-app.log when visiting meet.jit.si:
qml: [JS] (https://meet.jit.si/:8) (TIME) index.html loaded:
qml: [JS] (https://d3f5ootf0jzs2j.cloudfront.net/1380/libs/lib-jitsi-meet.min.js?v=1380:1) Uncaught TypeError: Cannot read property '1' of null
qml: [JS] (https://d3f5ootf0jzs2j.cloudfront.net/1380/libs/app.bundle.min.js?v=1380:25) DEPRECATED JS - Cookie has been deprecated since 5.8.0 and will be removed in a future release. Use cookie instead.
qml: [JS] (https://d3f5ootf0jzs2j.cloudfront.net/1380/libs/app.bundle.min.js?v=1380:15) Uncaught ReferenceError: JitsiMeetJS is not defined
qml: [JS] (:0) SVG's SMIL animations (<animate>, <set>, etc.) are deprecated and will be removed. Please use CSS animations or Web animations instead.
[1023/145548:WARNING:webmediaplayer_impl.cc(346)] Using MultibufferDataSource
[1023/145548:WARNING:webmediaplayer_impl.cc(346)] Using MultibufferDataSource
[1023/145548:WARNING:webmediaplayer_impl.cc(346)] Using MultibufferDataSource
shm_open() failed: Permission denied
shm_open() failed: Permission denied

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
Olivier Tilloy (osomon) wrote :

A simple user agent override does the trick.

Changed in webbrowser-app (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
importance: Undecided → High
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+17.04.20161202-0ubuntu1

---------------
webbrowser-app (0.23+17.04.20161202-0ubuntu1) zesty; urgency=medium

  [ Andrew Hayzen ]
  * Ensure if the webview changes that the loading visible state of the
    progress bar is bound to the correct webview (LP: #1638337)
  * Additional autopilot tests
  * Add dependencies on qtdeclarative5-ubuntu-content1 and
    qtdeclarative5-ubuntu-download-manager0.1 as they are now in main
    (LP: #1491279)
  * Add Drag and drop support of tabs between windows on non-mir clients

  [ Olivier Tilloy ]
  * Add a desktop UA override for ESPN websites (LP: #1637285)
  * Add user agent overrides for meet.jit.si (LP: #1635971)
  * Make QmlTests::UbuntuWebView02::test_no_contextual_actions() more
    robust (LP: #1633528)
  * Run unit tests with verbose output by default when building packages
  * Do not transfer keyboard focus from the address bar to the new tab
    view in incognito mode (LP: #1634463)
  * Use new API in oxide 1.17 to copy image to clipboard (LP: #1585291)
  * Use the ubuntu-app-platform content interface
  * Desktop UA override for google docs (LP: #1643386)

 -- Olivier Tilloy <email address hidden> Fri, 02 Dec 2016 08:38:21 +0000

Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers