add additional shortcut support for zoom/unzoom in US keyboards

Bug #1624381 reported by Bill Filler on 2016-09-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
webbrowser-app (Ubuntu)
High
Olivier Tilloy

Bug Description

On US keyboards, the "+" (plus) key is in shifted position, and the "-" (minus) is not. All the other browsers (chrome, chromium, firefox) support the following shortcuts for zoom/unzoom and we should do the same, so user does not have to press ctrl+shift as that is not expected.

zoom in:
ctrl+plus
ctrl+equals

zoom out:
ctrl+underscore
ctrl+minus

Related branches

Bill Filler (bfiller) on 2016-09-16
Changed in webbrowser-app (Ubuntu):
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Olivier Tilloy (osomon)
summary: - add shortcut support for zoom in US keyboards
+ add additional shortcut support for zoom/unzoom in US keyboards
Olivier Tilloy (osomon) wrote :

Note that this is only valid on US keyboard layouts. On other layouts, "+" and "=" may be located on entirely different keys (and same goes for "-" and "_").
I wonder whether firefox and chrome special-case the US layout, or enable those shortcuts regardless.

Bill Filler (bfiller) wrote :

you should try on your french keyboard to see.. I'm guessing they are always enabled.

Olivier Tilloy (osomon) wrote :

Indeed on my fr-bépo keyboard layout Ctrl+= has the same effect as Ctrl++ (zooming in incrementally) both in firefox and chromium, despite the fact that "=" and "+" are two separate keys. Ctrl+_ doesn’t do anything, but that’s probably because with this layout "_" is obtained with AltGr+Space.

In chromium’s source code (src/chrome/browser/ui/views/accelerator_table.cc), the following two keyboard shortcuts are assigned to the "zooming in" action:

  { ui::VKEY_OEM_PLUS, ui::EF_CONTROL_DOWN, IDC_ZOOM_PLUS },
  { ui::VKEY_ADD, ui::EF_CONTROL_DOWN, IDC_ZOOM_PLUS },

and several other places in the code suggest that VKEY_OEM_PLUS is "=".
Similarly, VKEY_OEM_MINUS is "_".

Olivier Tilloy (osomon) on 2016-09-19
Changed in webbrowser-app (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+16.10.20160928-0ubuntu1

---------------
webbrowser-app (0.23+16.10.20160928-0ubuntu1) yakkety; urgency=medium

  [ Andrew Hayzen ]
  * Change use of ActionList.actions to ActionList.children and use
    modelData in Repeaters (LP: #1624470)
  * Clip the Loader containing NewTabView so that it doesn't overlap the
    bottom edge hint (LP: #1568740)
  * Modify calendar ua-override to allow anything before google.com
    (allowing calendar.google.com)

  [ Olivier Tilloy ]
  * Add "Ctrl+=" and "Ctrl+_" as shortcuts for zoom in and zoom out
    actions, (LP: #1624381)
  * Strip out problematic apparmor rule that prevents camera detection
    on desktop (LP: #1626611)

  [ Andrew Hayzen, Olivier Tilloy ]
  * Multiple window support in webbrowser-app.

 -- Olivier Tilloy <email address hidden> Wed, 28 Sep 2016 08:25:12 +0000

Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers